]> git.pld-linux.org Git - packages/mono.git/blame - mono.spec
- update for 2.6.1
[packages/mono.git] / mono.spec
CommitLineData
39176ea5 1#
fef1a4c5 2# NOTE: Makefiles are broken, build could stop long time after first fatal error
94b2d9a7
ER
3# TODO:
4# /usr/lib/mono-source-libs/Options.cs
5# /usr/lib/mono-source-libs/getline.cs
6# /usr/lib64/pkgconfig/mono-lineeditor.pc
7# /usr/lib64/pkgconfig/mono-options.pc
8# /usr/lib64/pkgconfig/mono.web.pc
9# /usr/lib64/pkgconfig/system.web.extensions.design_1.0.pc
10# /usr/lib64/pkgconfig/system.web.extensions_1.0.pc
11# /usr/lib64/pkgconfig/wcf.pc
00c74d1a
ER
12# - x86_64 searches .dll from %{_libdir}, not %{_prefix}/lib:
13# The assembly mscorlib.dll was not found or could not be loaded.
14# It should have been installed in the `/usr/lib64/mono/2.0/mscorlib.dll' directory.
245657c9 15#
01794b7a 16# - C# 4.0 (--with-profile4=yes)
245657c9 17# Conditional build:
fef1a4c5 18%bcond_without tls # don't use TLS (which requires recent 2.4.x or 2.6 kernel)
4d9455d0 19%bcond_without static_libs # don't build static libraries
8cabdc4d 20%bcond_with bootstrap # don't require mono-devel to find req/prov
75873ca6 21%bcond_with mint # build mint instead of mono VM (JIT) [broken]
245657c9 22#
75873ca6
JB
23%ifnarch %{ix86} %{x8664} alpha arm ia64 ppc s390 s390x sparc sparcv9 sparc64
24# JIT not supported on hppa
a465d985 25%define with_mint 1
f1c5438d 26%endif
5114c445 27%define glib_ver 1:2.4
8cabdc4d 28#
728c2265 29Summary: Common Language Infrastructure implementation
d1081961 30Summary(pl.UTF-8): Implementacja Common Language Infrastructure
728c2265 31Name: mono
01794b7a 32Version: 2.6.1
33Release: 0.1
5114c445 34License: LGPL (VM), GPL (C# compilers), MIT X11 with GPL additions (classes, tools)
728c2265 35Group: Development/Languages
0f6bc6e4
JB
36# latest downloads summary at http://ftp.novell.com/pub/mono/sources-stable/
37Source0: http://ftp.novell.com/pub/mono/sources/mono/%{name}-%{version}.tar.bz2
01794b7a 38# Source0-md5: 4cd2157c9eabbe9f49232d5ee3a2a57e
ddb02eae
JB
39Patch0: %{name}-alpha-float.patch
40Patch1: %{name}-mint.patch
41Patch2: %{name}-sonames.patch
3cdc32b9
JB
42Patch3: %{name}-awk.patch
43Patch4: %{name}-console-no-utf8-bom.patch
5114c445 44Patch5: %{name}-pc.patch
0f6bc6e4 45Patch6: %{name}-ARG_MAX.patch
e9945d9e 46Patch7: %{name}-metadata-makefile.patch
68174c6e 47URL: http://www.mono-project.com/
39176ea5 48%if %(test -r /dev/random; echo $?)
96185d3a
JB
49BuildRequires: ACCESSIBLE_/dev/random
50%endif
8aa3dace 51BuildRequires: autoconf
52BuildRequires: automake
3c4b0944 53BuildRequires: bison
4f07b841 54BuildRequires: gettext-devel
5114c445 55BuildRequires: glib2-devel >= %{glib_ver}
f7c57864 56BuildRequires: libtool
609d5e15 57%{!?with_bootstrap:BuildRequires: mono-devel >= 1.1.8.3-2}
f7c57864 58BuildRequires: pkgconfig
71415791 59BuildRequires: rpmbuild(macros) >= 1.213
2ca5ca77 60BuildRequires: rpmbuild(monoautodeps)
8c34c74b 61Suggests: binfmt-detector
5114c445 62# for System.Drawing
7b0dd1f7 63Suggests: libgdiplus >= 2.0
e19321c3 64ExclusiveArch: %{ix86} %{x8664} alpha arm hppa ia64 mips ppc s390 s390x sparc sparcv9
1de8200d
JB
65# plain i386 is not supported; mono uses cmpxchg/xadd which require i486
66ExcludeArch: i386
728c2265
AM
67BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
ad29385a 69%define _rpmlibdir /usr/lib/rpm
70
baf6636c 71# debugger doesn't work with stripped mono
72%define _noautostrip .*/mono
73
39176ea5 74%if %{without bootstrap}
d0023a38 75%define __mono_provides %{_rpmlibdir}/mono-find-provides
76%define __mono_requires %{_rpmlibdir}/mono-find-requires
77%endif
78
728c2265
AM
79%description
80The Common Language Infrastructure platform. Microsoft has created a
81new development platform. The highlights of this new development
82platform are:
86d7bbf3 83- A runtime environment that provides garbage collection, threading
728c2265 84 and a virtual machine specification (The Virtual Execution System,
8aa3dace 85 VES),
86- A comprehensive class library,
728c2265 87- A new language, C#. Very similar to Java, C# allows programmers to
8aa3dace 88 use all the features available on the .NET runtime,
728c2265
AM
89- A language specification that compilers can follow if they want to
90 generate classes and code that can interoperate with other programming
8aa3dace 91 languages (The Common Language Specification: CLS).
728c2265 92
39176ea5 93%{?with_tls:This version was built with TLS __thread.}
245657c9 94
a86cd9c8
JR
95%description -l pl.UTF-8
96Platforma CLI (Common Language Infrastructure). Microsoft stworzył
97nową platformę developerską. Zalety tej platformy to:
98- środowisko, które dostarcza garbage collector, wątki oraz
99 specyfikację maszyny wirtualnej (The Virtual Execution System, VES),
100- bibliotekę klas,
101- nowy język, C#. Bardzo podobny do Javy, C# pozwala programistom na
102 używanie wszystkich możliwości dostarczanych przez platformę .NET,
103- specyfikacja dla kompilatorów, które chcą generować kod
104 współpracujący z innymi językami programowania (The Common Language
8aa3dace 105 Specification: CLS).
106
a86cd9c8 107%{?with_tls:Ta wersja została zbudowana z TLS __thread.}
245657c9 108
8aa3dace 109%package devel
110Summary: Development resources for mono
d1081961 111Summary(pl.UTF-8): Zasoby programisty do mono
5114c445 112License: LGPL (VM), MIT X11 with GPL additions (classes, tools)
8aa3dace 113Group: Development/Libraries
76e7cb31 114Requires: %{name} = %{version}-%{release}
5114c445 115Requires: glib2-devel >= %{glib_ver}
8aa3dace 116
117%description devel
118Development resources for mono.
119
a86cd9c8 120%description devel -l pl.UTF-8
18ff84b2
MM
121Zasoby programisty dla mono.
122
5dab3216 123%package debug
124Summary: Mono libraries debugging resources
d1081961 125Summary(pl.UTF-8): Pliki umożliwiające debugowanie bibliotek mono
5dab3216 126Group: Development/Libraries
127Requires: %{name} = %{version}-%{release}
128
129%description debug
130Mono libraries debugging resources.
131
a86cd9c8
JR
132%description debug -l pl.UTF-8
133Pliki umożliwiające debugowanie bibliotek mono.
5dab3216 134
18ff84b2
MM
135%package csharp
136Summary: C# compiler for mono
d1081961 137Summary(pl.UTF-8): Kompilator C# dla mono
5114c445 138License: GPL
18ff84b2 139Group: Development/Languages
76e7cb31 140Requires: %{name}-devel = %{version}-%{release}
18ff84b2
MM
141
142%description csharp
143C# compiler for mono.
144
a86cd9c8 145%description csharp -l pl.UTF-8
18ff84b2
MM
146Kompilator C# dla mono.
147
148%package ilasm
149Summary: ILasm compiler for mono
d1081961 150Summary(pl.UTF-8): Kompilator ILasm dla mono
5114c445
JB
151# implied
152License: MIT X11
18ff84b2 153Group: Development/Languages
76e7cb31 154Requires: %{name}-devel = %{version}-%{release}
6ec58c77 155Provides: ilasm
156Obsoletes: pnet-compiler-ilasm
18ff84b2
MM
157
158%description ilasm
159ILasm compiler for mono.
160
a86cd9c8 161%description ilasm -l pl.UTF-8
18ff84b2 162Kompilator ILasm dla mono.
71c7a580 163
245657c9
MM
164%package jscript
165Summary: jscript compiler for mono
d1081961 166Summary(pl.UTF-8): Kompilator jscript dla mono
5114c445 167License: MIT X11
245657c9
MM
168Group: Development/Languages
169Requires: %{name}-devel = %{version}-%{release}
170
171%description jscript
172jscript compiler for mono.
173
a86cd9c8 174%description jscript -l pl.UTF-8
245657c9
MM
175Kompilator jscript dla mono.
176
e9945d9e 177%package monodoc
178Summary: Documentation for Mono class libraries and tools to produce and edit the documentation
179Summary(pl.UTF-8): Dokumentacja klas Mono wraz z narzędziami do jej generowania i przeglądania
180License: LGPL
181Group: Development/Libraries
182Requires: %{name}-devel = %{version}-%{release}
9bfc17bb 183Provides: monodoc = %{version}-%{release}
e9945d9e 184Obsoletes: monodoc
185
186%description monodoc
187This package contains the documentation for the Mono class libraries,
188tools to produce and edit the documentation, and a documentation
189browser.
190
191%description monodoc -l pl.UTF-8
192Ten pakiet zawiera dokumentację klas Mono wraz z narzędziami do jej
193generowania i przeglądania.
194
8aa3dace 195%package static
196Summary: Static mono library
d1081961 197Summary(pl.UTF-8): Statyczna biblioteka mono
5114c445 198License: LGPL
8aa3dace 199Group: Development/Libraries
76e7cb31 200Requires: %{name}-devel = %{version}-%{release}
8aa3dace 201
202%description static
203Static mono library.
204
a86cd9c8 205%description static -l pl.UTF-8
71c7a580
JB
206Statyczna biblioteka mono.
207
ea0e88d4
MM
208%package jay
209Summary: Yacc-like parser generator for Java and C#
d1081961 210Summary(pl.UTF-8): Podobny do Yacca generator parserów dla Javy i C#
5114c445 211License: BSD
ea0e88d4
MM
212Group: Development/Tools
213
214%description jay
215Yacc-like parser generator for Java and C#.
216
a86cd9c8
JR
217%description jay -l pl.UTF-8
218Podobny do Yacca generator parserów dla Javy i C#.
ea0e88d4 219
f327d485
MM
220%package compat-links
221Summary: Mono compatibility links
d1081961 222Summary(pl.UTF-8): Dowiązania dla kompatybilności
5114c445
JB
223# resgen license
224License: MIT X11
f327d485
MM
225Group: Development/Languages
226Requires: %{name}-devel = %{version}-%{release}
227
228%description compat-links
229This package contains links to binaries with names used in .NET and
230dotGNU.
231
a86cd9c8
JR
232%description compat-links -l pl.UTF-8
233Pakiet ten zawiera dowiązania do programów o nazwach używanych w .NET
f327d485
MM
234oraz dotGNU.
235
728c2265 236%prep
245657c9 237%setup -q
ddb02eae 238%patch0 -p1
24b388af 239%patch1 -p1
b3bdc9af 240%patch2 -p1
3cdc32b9 241%patch3 -p1
4a893061 242%patch4 -p1
ca59b162 243#%patch5 -p1
0f6bc6e4 244%patch6 -p1
e9945d9e 245%patch7 -p1
394cba3f 246
5114c445
JB
247# for jay
248cat >>mcs/build/config-default.make <<EOF
249CC = %{__cc}
250CFLAGS = %{rpmcflags}
251EOF
252
728c2265 253%build
7f02b7bf
JB
254cp -f /usr/share/automake/config.sub .
255cp -f /usr/share/automake/config.sub libgc
18ff84b2
MM
256%{__libtoolize}
257%{__aclocal}
245657c9 258%{__autoheader}
18ff84b2
MM
259%{__autoconf}
260%{__automake}
245657c9
MM
261cd libgc
262%{__libtoolize}
263%{__aclocal}
264%{__autoconf}
265%{__automake}
266cd ..
267
5114c445
JB
268# -DUSE_COMPILER_TLS is passed to libgc by main configure, but our
269# CPPFLAGS override that CPPFLAGS
270CPPFLAGS="-DUSE_LIBC_PRIVATE_SYMBOLS -DUSE_COMPILER_TLS"
0eeed8fb 271%configure \
f1c5438d 272 %{!?with_static_libs:--disable-static} \
91164168 273 --enable-fast-install \
f1c5438d 274 --with-gc=included \
245657c9 275 --with-icu=no \
f1c5438d
JB
276 --with-interp=%{?with_mint:yes}%{!?with_mint:no} \
277 --with-jit=%{?with_mint:no}%{!?with_mint:yes} \
278 --with-preview=yes \
fef1a4c5 279 --with-tls=%{?with_tls:__thread}%{!?with_tls:pthread}
0eeed8fb 280
a317f685
JB
281# mint uses heap to make trampolines, which need to be executable
282# there is mprotect(...,PROT_EXEC) for ppc/s390, but not used
283# (ifdef NEED_MPROTECT, which is never defined)
284# in fact the flag should be "-Wl,-z,execheap" for libmint, but:
285# -z execheap doesn't seem to do anything currently
286# -z execstack for library makes only stack executable, but not heap
24b469a9 287%{__make} -j1 \
a317f685 288 mint_LDFLAGS="-Wl,-z,execheap -Wl,-z,execstack"
728c2265
AM
289
290%install
291rm -rf $RPM_BUILD_ROOT
ad29385a 292install -d $RPM_BUILD_ROOT%{_rpmlibdir}
728c2265 293
24b469a9 294%{__make} -j1 install \
866e5301 295 DESTDIR=$RPM_BUILD_ROOT
b11f008f 296
65a9c4dc 297strip --strip-debug $RPM_BUILD_ROOT%{_bindir}/mono
298
ea0e88d4 299rm -f $RPM_BUILD_ROOT%{_datadir}/jay/[A-Z]*
728c2265 300
18ff84b2
MM
301# this way we can run rpmbuild -bi several times, and directories
302# have more meaningful name.
303rm -rf pld-doc
e6c59841 304install -d pld-doc/{webpage,notes}
5385129f 305cp -a web/* pld-doc/webpage
03ad8b19 306cp -a docs/* pld-doc/notes
18ff84b2 307rm -f pld-doc/*/Makefile*
728c2265 308
245657c9
MM
309rm -rf $RPM_BUILD_ROOT%{_datadir}/libgc-mono
310
5114c445
JB
311mv -f $RPM_BUILD_ROOT%{_bindir}/mono-find-* $RPM_BUILD_ROOT%{_rpmlibdir}
312
313# loadable modules
94b2d9a7
ER
314rm $RPM_BUILD_ROOT%{_libdir}/lib{MonoPosixHelper,MonoSupportW,ikvm-native}.la
315%if %{with static_libs}
316rm $RPM_BUILD_ROOT%{_libdir}/lib{MonoPosixHelper,MonoSupportW,ikvm-native}.a
317%endif
ad29385a 318
728c2265
AM
319%clean
320rm -rf $RPM_BUILD_ROOT
321
71c7a580
JB
322%post -p /sbin/ldconfig
323%postun -p /sbin/ldconfig
324
728c2265
AM
325%files
326%defattr(644,root,root,755)
4ffe85ea 327%doc AUTHORS ChangeLog NEWS README pld-doc/*
f1c5438d 328%if %{with mint}
245657c9 329%attr(755,root,root) %{_bindir}/mint
f1c5438d
JB
330%else
331%attr(755,root,root) %{_bindir}/mono
48941467 332%endif
840f8203 333%attr(755,root,root) %{_bindir}/caspol
5114c445
JB
334%attr(755,root,root) %{_bindir}/cert2spc
335%attr(755,root,root) %{_bindir}/certmgr
336%attr(755,root,root) %{_bindir}/chktrust
48cd6fab 337%attr(755,root,root) %{_bindir}/dtd2rng
e6c59841 338%attr(755,root,root) %{_bindir}/gacutil1
5114c445 339%attr(755,root,root) %{_bindir}/gacutil
7b0dd1f7 340%attr(755,root,root) %{_bindir}/gacutil2
4f35821b 341%attr(755,root,root) %{_bindir}/httpcfg
342%attr(755,root,root) %{_bindir}/installvst
5114c445
JB
343%attr(755,root,root) %{_bindir}/makecert
344%attr(755,root,root) %{_bindir}/mconfig
345%attr(755,root,root) %{_bindir}/mkbundle
7b0dd1f7 346%attr(755,root,root) %{_bindir}/mkbundle1
5114c445 347%attr(755,root,root) %{_bindir}/mkbundle2
840f8203 348%attr(755,root,root) %{_bindir}/mono-service
48cd6fab 349%attr(755,root,root) %{_bindir}/mono-service2
f3b0e346 350%attr(755,root,root) %{_bindir}/mono-test-install
48cd6fab 351%attr(755,root,root) %{_bindir}/mono-xmltool
840f8203 352%attr(755,root,root) %{_bindir}/mozroots
5114c445
JB
353%attr(755,root,root) %{_bindir}/secutil
354%attr(755,root,root) %{_bindir}/setreg
8ef557a4 355%attr(755,root,root) %{_bindir}/sgen
5114c445
JB
356%attr(755,root,root) %{_bindir}/signcode
357%attr(755,root,root) %{_bindir}/sn
358%if %{with mint}
359%attr(755,root,root) %{_libdir}/libmint.so.*.*.*
360%attr(755,root,root) %ghost %{_libdir}/libmint.so.0
361%else
362%attr(755,root,root) %{_libdir}/libmono.so.*.*.*
363%attr(755,root,root) %ghost %{_libdir}/libmono.so.0
364%attr(755,root,root) %{_libdir}/libmono-profiler-aot.so.*.*.*
365%attr(755,root,root) %ghost %{_libdir}/libmono-profiler-aot.so.0
366%attr(755,root,root) %{_libdir}/libmono-profiler-cov.so.*.*.*
367%attr(755,root,root) %ghost %{_libdir}/libmono-profiler-cov.so.0
7b0dd1f7 368%attr(755,root,root) %{_libdir}/libmono-profiler-logging.so.*.*.*
369%attr(755,root,root) %ghost %{_libdir}/libmono-profiler-logging.so.0
5114c445 370%endif
2c1ff86a 371%attr(755,root,root) %{_libdir}/libMonoPosixHelper.so
ff3439a4 372%attr(755,root,root) %{_libdir}/libMonoSupportW.so
2c1ff86a 373%attr(755,root,root) %{_libdir}/libikvm-native.so
f1c5438d
JB
374%dir %{_prefix}/lib/mono
375%dir %{_prefix}/lib/mono/1.0
5114c445
JB
376%{_prefix}/lib/mono/1.0/*.dll
377%attr(755,root,root) %{_prefix}/lib/mono/1.0/caspol.exe
378%attr(755,root,root) %{_prefix}/lib/mono/1.0/cert2spc.exe
379%attr(755,root,root) %{_prefix}/lib/mono/1.0/certmgr.exe
380%attr(755,root,root) %{_prefix}/lib/mono/1.0/chktrust.exe
381%attr(755,root,root) %{_prefix}/lib/mono/1.0/culevel.exe
382%attr(755,root,root) %{_prefix}/lib/mono/1.0/gacutil.exe
f3b0e346 383%attr(755,root,root) %{_prefix}/lib/mono/1.0/installutil.exe
5114c445
JB
384%attr(755,root,root) %{_prefix}/lib/mono/1.0/installvst.exe
385%attr(755,root,root) %{_prefix}/lib/mono/1.0/mkbundle.exe
386%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-service.exe
387%attr(755,root,root) %{_prefix}/lib/mono/1.0/mozroots.exe
388%attr(755,root,root) %{_prefix}/lib/mono/1.0/secutil.exe
389%attr(755,root,root) %{_prefix}/lib/mono/1.0/setreg.exe
390%attr(755,root,root) %{_prefix}/lib/mono/1.0/signcode.exe
391%attr(755,root,root) %{_prefix}/lib/mono/1.0/sn.exe
f1c5438d 392%dir %{_prefix}/lib/mono/2.0
5114c445 393%{_prefix}/lib/mono/2.0/*.dll
7b0dd1f7 394%attr(755,root,root) %{_prefix}/lib/mono/2.0/gacutil.exe
5114c445 395%attr(755,root,root) %{_prefix}/lib/mono/2.0/httpcfg.exe
f3b0e346 396%attr(755,root,root) %{_prefix}/lib/mono/2.0/installutil.exe
5114c445
JB
397%attr(755,root,root) %{_prefix}/lib/mono/2.0/mconfig.exe
398%attr(755,root,root) %{_prefix}/lib/mono/2.0/mkbundle.exe
399%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-service.exe
400%attr(755,root,root) %{_prefix}/lib/mono/2.0/sgen.exe
7b0dd1f7 401%attr(755,root,root) %{_prefix}/lib/mono/2.0/xsd.exe
f3b0e346 402%dir %{_prefix}/lib/mono/3.5
403%{_prefix}/lib/mono/3.5/*.dll
6d20487b 404%dir %{_prefix}/lib/mono/compat-1.0
5114c445 405%{_prefix}/lib/mono/compat-1.0/*.dll
6d20487b 406%dir %{_prefix}/lib/mono/compat-2.0
5114c445 407%{_prefix}/lib/mono/compat-2.0/*.dll
f1c5438d 408%{_prefix}/lib/mono/gac
5dab3216 409%exclude %{_prefix}/lib/mono/gac/*/*/*.mdb
5114c445
JB
410%{_mandir}/man1/cert2spc.1*
411%{_mandir}/man1/certmgr.1*
245657c9
MM
412%{_mandir}/man1/chktrust.1*
413%{_mandir}/man1/gacutil.1*
4a893061 414%{_mandir}/man1/httpcfg.1*
5385129f 415%{_mandir}/man1/makecert.1*
5114c445 416%{_mandir}/man1/mconfig.1*
245657c9
MM
417%{_mandir}/man1/mkbundle.1*
418%{_mandir}/man1/mint.1*
419%{_mandir}/man1/mono.1*
420%{_mandir}/man1/mono-service.1*
840f8203 421%{_mandir}/man1/mozroots.1*
5385129f 422%{_mandir}/man1/secutil.1*
5385129f 423%{_mandir}/man1/setreg.1*
8ef557a4 424%{_mandir}/man1/sgen.1*
245657c9
MM
425%{_mandir}/man1/signcode.1*
426%{_mandir}/man1/sn.1*
245657c9 427%{_mandir}/man5/mono-config.5*
fdd46781 428%dir %{_sysconfdir}/mono
f1c5438d 429%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/browscap.ini
f3b0e346 430%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/config
5114c445
JB
431%dir %{_sysconfdir}/mono/mconfig
432%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/mconfig/config.xml
245657c9 433%dir %{_sysconfdir}/mono/1.0
f1c5438d 434%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/DefaultWsdlHelpGenerator.aspx
f3b0e346 435%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/machine.config
245657c9 436%dir %{_sysconfdir}/mono/2.0
f1c5438d 437%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
f3b0e346 438%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/machine.config
439%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/settings.map
48cd6fab 440%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/web.config
7b0dd1f7 441%dir %{_sysconfdir}/mono/2.0/Browsers
442%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/Browsers/Compat.browser
8aa3dace 443
9f4cf2f1 444%exclude %{_prefix}/lib/mono/gac/Microsoft.JScript
445%exclude %{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
446%exclude %{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
504c4464 447%exclude %{_prefix}/lib/mono/gac/monodoc
9f4cf2f1 448
ea0e88d4
MM
449%files jay
450%defattr(644,root,root,755)
245657c9 451%doc mcs/jay/{ACKNOWLEDGEMENTS,ChangeLog,NEW_FEATURES,NOTES,README,README.jay}
ea0e88d4
MM
452%attr(755,root,root) %{_bindir}/jay
453%dir %{_datadir}/jay
454%{_datadir}/jay/skeleton*
455%{_mandir}/man1/jay.1*
456
245657c9
MM
457%files jscript
458%defattr(644,root,root,755)
459%attr(755,root,root) %{_bindir}/mjs
5114c445 460%attr(755,root,root) %{_prefix}/lib/mono/1.0/mjs.exe
9f4cf2f1 461%{_prefix}/lib/mono/gac/Microsoft.JScript
462%{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
463%{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
5dab3216 464%exclude %{_prefix}/lib/mono/gac/*/*/*.mdb
245657c9 465
f327d485
MM
466%files compat-links
467%defattr(644,root,root,755)
468%attr(755,root,root) %{_bindir}/resgen
7b0dd1f7 469%attr(755,root,root) %{_bindir}/resgen1
3d1af25b 470%attr(755,root,root) %{_bindir}/resgen2
f327d485 471
8aa3dace 472%files devel
473%defattr(644,root,root,755)
5114c445 474%attr(755,root,root) %{_bindir}/al
7b0dd1f7 475%attr(755,root,root) %{_bindir}/al1
5114c445
JB
476%attr(755,root,root) %{_bindir}/al2
477%attr(755,root,root) %{_bindir}/cilc
478%attr(755,root,root) %{_bindir}/disco
994ec6f9 479%attr(755,root,root) %{_bindir}/dtd2xsd
5114c445 480%attr(755,root,root) %{_bindir}/genxs
7b0dd1f7 481%attr(755,root,root) %{_bindir}/genxs1
994ec6f9 482%attr(755,root,root) %{_bindir}/macpack
39d58cda 483%attr(755,root,root) %{_bindir}/mono-api-info
e6c59841 484%attr(755,root,root) %{_bindir}/mono-cil-strip
245657c9 485%attr(755,root,root) %{_bindir}/monodis
2affc12a 486%attr(755,root,root) %{_bindir}/monograph
613285b2 487%attr(755,root,root) %{_bindir}/monolinker
5114c445 488%attr(755,root,root) %{_bindir}/monop
7b0dd1f7 489%attr(755,root,root) %{_bindir}/monop1
5114c445
JB
490%attr(755,root,root) %{_bindir}/monop2
491%attr(755,root,root) %{_bindir}/mono-shlib-cop
01794b7a 492%attr(755,root,root) %{_bindir}/lc
ff3439a4 493%attr(755,root,root) %{_bindir}/nunit-console
48cd6fab 494%attr(755,root,root) %{_bindir}/nunit-console2
18ff84b2 495%attr(755,root,root) %{_bindir}/pedump
994ec6f9 496%attr(755,root,root) %{_bindir}/permview
497%attr(755,root,root) %{_bindir}/prj2make
5114c445
JB
498%attr(755,root,root) %{_bindir}/soapsuds
499%attr(755,root,root) %{_bindir}/sqlsharp
500%attr(755,root,root) %{_bindir}/wsdl
7b0dd1f7 501%attr(755,root,root) %{_bindir}/wsdl1
5114c445 502%attr(755,root,root) %{_bindir}/wsdl2
4ffe85ea 503%attr(755,root,root) %{_bindir}/xbuild
5114c445 504%attr(755,root,root) %{_bindir}/xsd
7b0dd1f7 505%attr(755,root,root) %{_bindir}/xsd2
f1c5438d
JB
506%if %{with mint}
507%attr(755,root,root) %{_libdir}/libmint.so
5114c445 508%{_libdir}/libmint.la
f1c5438d 509%else
2c1ff86a 510%attr(755,root,root) %{_libdir}/libmono.so
5114c445 511%attr(755,root,root) %{_libdir}/libmono-profiler-aot.so
2c1ff86a 512%attr(755,root,root) %{_libdir}/libmono-profiler-cov.so
7b0dd1f7 513%attr(755,root,root) %{_libdir}/libmono-profiler-logging.so
5114c445
JB
514%{_libdir}/libmono.la
515%{_libdir}/libmono-profiler-aot.la
516%{_libdir}/libmono-profiler-cov.la
7b0dd1f7 517%{_libdir}/libmono-profiler-logging.la
f1c5438d 518%endif
5114c445
JB
519%attr(755,root,root) %{_prefix}/lib/mono/1.0/al.exe
520%attr(755,root,root) %{_prefix}/lib/mono/1.0/browsercaps-updater.exe
521%attr(755,root,root) %{_prefix}/lib/mono/1.0/cilc.exe
522%attr(755,root,root) %{_prefix}/lib/mono/1.0/disco.exe
523%attr(755,root,root) %{_prefix}/lib/mono/1.0/dtd2rng.exe
524%attr(755,root,root) %{_prefix}/lib/mono/1.0/dtd2xsd.exe
525%attr(755,root,root) %{_prefix}/lib/mono/1.0/genxs.exe
526%attr(755,root,root) %{_prefix}/lib/mono/1.0/ictool.exe
527%attr(755,root,root) %{_prefix}/lib/mono/1.0/macpack.exe
528%attr(755,root,root) %{_prefix}/lib/mono/1.0/makecert.exe
e6c59841 529%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-cil-strip.exe
5114c445
JB
530%attr(755,root,root) %{_prefix}/lib/mono/1.0/monop.exe
531%attr(755,root,root) %{_prefix}/lib/mono/1.0/nunit-console.exe
532%{_prefix}/lib/mono/1.0/nunit-console.exe.config
533%attr(755,root,root) %{_prefix}/lib/mono/1.0/permview.exe
534%attr(755,root,root) %{_prefix}/lib/mono/1.0/prj2make.exe
535%attr(755,root,root) %{_prefix}/lib/mono/1.0/resgen.exe
536%attr(755,root,root) %{_prefix}/lib/mono/1.0/soapsuds.exe
5114c445
JB
537%attr(755,root,root) %{_prefix}/lib/mono/1.0/wsdl.exe
538%attr(755,root,root) %{_prefix}/lib/mono/1.0/xsd.exe
539%attr(755,root,root) %{_prefix}/lib/mono/2.0/al.exe
01794b7a 540%attr(755,root,root) %{_prefix}/lib/mono/2.0/lc.exe
541%attr(755,root,root) %{_prefix}/lib/mono/2.0/monolinker.exe
5114c445 542%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-api-info.exe
e6c59841 543%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-shlib-cop.exe
01794b7a 544%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-xmltool.exe
e6c59841 545%{_prefix}/lib/mono/2.0/mono-shlib-cop.exe.config
5114c445
JB
546%attr(755,root,root) %{_prefix}/lib/mono/2.0/monop.exe
547%attr(755,root,root) %{_prefix}/lib/mono/2.0/nunit-console.exe
548%{_prefix}/lib/mono/2.0/nunit-console.exe.config
549%attr(755,root,root) %{_prefix}/lib/mono/2.0/resgen.exe
e6c59841 550%attr(755,root,root) %{_prefix}/lib/mono/2.0/sqlsharp.exe
5114c445
JB
551%attr(755,root,root) %{_prefix}/lib/mono/2.0/wsdl.exe
552%attr(755,root,root) %{_prefix}/lib/mono/2.0/xbuild.exe
553%{_prefix}/lib/mono/2.0/xbuild.rsp
4a893061 554%{_prefix}/lib/mono/2.0/MSBuild
5114c445
JB
555%{_prefix}/lib/mono/2.0/Microsoft.Build.xsd
556%{_prefix}/lib/mono/2.0/Microsoft.CSharp.targets
557%{_prefix}/lib/mono/2.0/Microsoft.Common.targets
558%{_prefix}/lib/mono/2.0/Microsoft.VisualBasic.targets
559%{_prefix}/lib/mono/2.0/Microsoft.Common.tasks
560%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
561%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
4a893061 562%{_datadir}/%{name}-1.0
5114c445
JB
563%{_pkgconfigdir}/cecil.pc
564%{_pkgconfigdir}/dotnet.pc
7b0dd1f7 565%{_pkgconfigdir}/dotnet35.pc
5114c445
JB
566%{_pkgconfigdir}/mono-cairo.pc
567%{_pkgconfigdir}/mono-nunit.pc
568%if %{with mint}
569%{_pkgconfigdir}/mint.pc
570%else
571%{_pkgconfigdir}/mono.pc
572%endif
4a893061 573%{_includedir}/%{name}-1.0
ff3439a4 574%{_mandir}/man1/al.1*
c8f3b110 575%{_mandir}/man1/cilc.1*
994ec6f9 576%{_mandir}/man1/disco.1*
577%{_mandir}/man1/dtd2xsd.1*
e0aee78b 578%{_mandir}/man1/genxs.1*
01794b7a 579%{_mandir}/man1/lc.1*
994ec6f9 580%{_mandir}/man1/macpack.1*
2affc12a 581%{_mandir}/man1/monodis.1*
613285b2 582%{_mandir}/man1/monolinker.1*
994ec6f9 583%{_mandir}/man1/monop.1*
e9945d9e 584%{_mandir}/man1/mono-cil-strip.1*
994ec6f9 585%{_mandir}/man1/mono-shlib-cop.1*
2affc12a 586%{_mandir}/man1/monostyle.1*
613285b2 587%{_mandir}/man1/mono-xmltool.1*
994ec6f9 588%{_mandir}/man1/oldmono.1*
5114c445 589%{_mandir}/man1/permview.1*
994ec6f9 590%{_mandir}/man1/prj2make.1*
613285b2 591%{_mandir}/man1/resgen.1*
994ec6f9 592%{_mandir}/man1/soapsuds.1*
18ff84b2 593%{_mandir}/man1/sqlsharp.1*
ff112d9b 594%{_mandir}/man1/wsdl.1*
a66172db 595%{_mandir}/man1/xsd.1*
18ff84b2 596
b6aa60a1
JB
597%files debug
598%defattr(644,root,root,755)
599%{_prefix}/lib/mono/1.0/*.mdb
600%{_prefix}/lib/mono/2.0/*.mdb
601%{_prefix}/lib/mono/gac/*/*/*.mdb
602
18ff84b2 603%files csharp
609883c4 604%defattr(644,root,root,755)
e6c59841 605%attr(755,root,root) %{_bindir}/csharp
a66172db 606%attr(755,root,root) %{_bindir}/mcs
7b0dd1f7 607%attr(755,root,root) %{_bindir}/mcs1
a66172db 608%attr(755,root,root) %{_bindir}/gmcs
5114c445
JB
609%attr(755,root,root) %{_prefix}/lib/mono/1.0/mcs.exe
610%{_prefix}/lib/mono/1.0/mcs.exe.config
611%attr(755,root,root) %{_prefix}/lib/mono/2.0/gmcs.exe
612%{_prefix}/lib/mono/2.0/gmcs.exe.config
e6c59841 613%attr(755,root,root) %{_prefix}/lib/mono/2.0/csharp.exe
18ff84b2 614%{_mandir}/man1/mcs.1*
e6c59841 615%{_mandir}/man1/csharp.1*
18ff84b2 616
18ff84b2 617%files ilasm
609883c4 618%defattr(644,root,root,755)
5114c445 619%attr(755,root,root) %{_bindir}/ilasm
7b0dd1f7 620%attr(755,root,root) %{_bindir}/ilasm1
5114c445
JB
621%attr(755,root,root) %{_bindir}/ilasm2
622%attr(755,root,root) %{_prefix}/lib/mono/1.0/ilasm.exe
623%attr(755,root,root) %{_prefix}/lib/mono/2.0/ilasm.exe
c8f3b110 624%{_mandir}/man1/ilasm.1*
8aa3dace 625
e9945d9e 626%files monodoc
627%defattr(644,root,root,755)
628%attr(755,root,root) %{_bindir}/mdassembler
629%attr(755,root,root) %{_bindir}/mdoc*
630%attr(755,root,root) %{_bindir}/mod
631%attr(755,root,root) %{_bindir}/monodocer
632%attr(755,root,root) %{_bindir}/monodocs2html
633%attr(755,root,root) %{_bindir}/monodocs2slashdoc
634%attr(755,root,root) %{_bindir}/mdvalidater
7bad922f 635%attr(755,root,root) %{_prefix}/lib/mono/1.0/mod.exe
636%attr(755,root,root) %{_prefix}/lib/mono/2.0/mdoc.exe
e65b976c 637%attr(755,root,root) %{_prefix}/lib/mono/monodoc/monodoc.dll
e9945d9e 638%{_prefix}/lib/mono/gac/monodoc
7bad922f 639%dir %{_prefix}/lib/mono/monodoc
fa67b165 640%dir %{_prefix}/lib/monodoc
7bad922f 641%{_prefix}/lib/monodoc/*
e9945d9e 642%{_pkgconfigdir}/monodoc.pc
643%{_mandir}/man1/mdassembler.1*
644%{_mandir}/man1/mdoc*.1*
645%{_mandir}/man1/monodocer.1*
646%{_mandir}/man1/monodocs2html.1*
647%{_mandir}/man1/mdvalidater.1*
648%{_mandir}/man5/mdoc.5*
649
4d9455d0 650%if %{with static_libs}
8aa3dace 651%files static
652%defattr(644,root,root,755)
5114c445
JB
653%if %{with mint}
654%{_libdir}/libmint.a
655%else
656%{_libdir}/libmono.a
657%{_libdir}/libmono-profiler-aot.a
658%{_libdir}/libmono-profiler-cov.a
7b0dd1f7 659%{_libdir}/libmono-profiler-logging.a
5114c445 660%endif
4d9455d0 661%endif
This page took 1.874385 seconds and 4 git commands to generate.