]> git.pld-linux.org Git - packages/mdds.git/blame - mdds.spec
fix build without apidocs
[packages/mdds.git] / mdds.spec
CommitLineData
17e84106
JB
1#
2# Conditional build:
3%bcond_without apidocs # doxygen/sphinx+breathe API documentation
4#
dbe2120a 5Summary: A collection of multi-dimensional data structures and indexing algorithms
021b4724 6Summary(pl.UTF-8): Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących
dbe2120a 7Name: mdds
261daa59 8Version: 1.6.0
c8be9e45 9Release: 1
dbe2120a
AM
10License: MIT
11Group: Development/Libraries
3a44f5ef 12#Source0Download: https://gitlab.com/mdds/mdds/raw/master/README.md
c8be9e45 13Source0: http://kohei.us/files/mdds/src/%{name}-%{version}.tar.bz2
261daa59 14# Source0-md5: a9e9704bddfacc27fcde6827b9cef1db
17e84106 15Patch0: %{name}-doc.patch
0a68325b 16URL: https://gitlab.com/mdds/mdds
47d79994 17BuildRequires: boost-devel >= 1.39
17e84106 18BuildRequires: libstdc++-devel >= 6:4.7
35b5323a 19BuildRequires: rpmbuild(macros) >= 1.446
17e84106
JB
20%if %{with apidocs}
21BuildRequires: doxygen
fa097365 22BuildRequires: python3-breathe
c8be9e45 23BuildRequires: sphinx-pdg-3
17e84106 24%endif
dbe2120a 25BuildArch: noarch
843e0754 26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
dbe2120a
AM
27
28%description
29A collection of multi-dimensional data structures and indexing
30algorithms.
31
32It implements the following data structures:
33- segment tree
34- flat segment tree
35- rectangle set
36- point quad tree
37- mixed type matrix
38
021b4724
JB
39%description -l pl.UTF-8
40Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących.
41Zaimplementowane są następujące struktury danych:
42- drzewo segmentowe
43- płaskie drzewo segmentowe
44- zbiór prostokątów
45- drzewo czwórkowe (quadtree) dla punktów
46- macierz mieszana
47
dbe2120a 48%package devel
021b4724
JB
49Summary: A collection of multi-dimensional data structures and indexing algorithms
50Summary(pl.UTF-8): Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących
dbe2120a 51Group: Development/Libraries
47d79994 52Requires: boost-devel >= 1.39
17e84106 53Requires: libstdc++-devel >= 6:4.7
dbe2120a
AM
54
55%description devel
021b4724
JB
56A collection of multi-dimensional data structures and indexing
57algorithms.
58
59It implements the following data structures:
60- segment tree
61- flat segment tree
62- rectangle set
63- point quad tree
64- mixed type matrix
65
66%description devel -l pl.UTF-8
67Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących.
68Zaimplementowane są następujące struktury danych:
69- drzewo segmentowe
70- płaskie drzewo segmentowe
71- zbiór prostokątów
72- drzewo czwórkowe (quadtree) dla punktów
73- macierz mieszana
dbe2120a 74
17e84106
JB
75%package apidocs
76Summary: API documentation for MDDS
77Summary(pl.UTF-8): Dokumentacja API biblioteki MDDS
78Group: Documentation
79
80%description apidocs
81API documentation for MDDS.
82
83%description apidocs -l pl.UTF-8
84Dokumentacja API biblioteki MDDS.
85
dbe2120a 86%prep
c8be9e45 87%setup -q
dbe2120a 88
dbe2120a 89%build
c8be9e45
JB
90%configure \
91 SPHINX=/usr/bin/sphinx-build-3 \
92 %{?with_apidocs:--enable-docs}
93
94%{__make}
17e84106 95
c8be9e45
JB
96%if %{with apidocs}
97%{__make} html-local
98%endif
dbe2120a
AM
99
100%install
101rm -rf $RPM_BUILD_ROOT
17e84106
JB
102
103%{__make} install \
104 DESTDIR=$RPM_BUILD_ROOT
105
106# packaged as %doc
5e9669f0 107%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/mdds
dbe2120a
AM
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%files devel
113%defattr(644,root,root,755)
344f4da2 114%doc AUTHORS CHANGELOG LICENSE README.md
27fa4889
JB
115%{_includedir}/mdds-1.5
116%{_npkgconfigdir}/mdds-1.5.pc
17e84106 117
ceee0b3a 118%if %{with apidocs}
17e84106
JB
119%files apidocs
120%defattr(644,root,root,755)
c8be9e45 121%doc doc/_doxygen/html doc/_build/{_static,*.html,*.js}
ceee0b3a 122%endif
This page took 0.08464 seconds and 4 git commands to generate.