]> git.pld-linux.org Git - packages/lighttpd.git/blame - lighttpd.spec
- patch from http://trac.lighttpd.net/trac/changeset/11
[packages/lighttpd.git] / lighttpd.spec
CommitLineData
8d734bed 1#
05f8c491 2# TODO
0ab57655 3# - test ldap and mysql (failed at this time)
ddfaf124 4# - documentroot specified in config doesn't exist
fcae54a7 5# - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
05f8c491 6#
4f968063 7# Conditional build for lighttpd:
ce8f06ab
KK
8%bcond_without xattr # without support of extended attributes
9%bcond_with mysql # with mysql
10%bcond_with ldap # with ldap
d80c1ef1 11%bcond_with valgrind # enable valgrind fixes in code.
ce8f06ab 12%bcond_without ipv6 # IPv4-only version (doesn't require IPv6 in kernel)
70373b58 13%bcond_without largefile # without largefile support,
49163762 14%bcond_without ssl # disable ssl support
70373b58
ER
15# use it if you have 2.4 kernel to get sendfile() support,
16# and don't need > 2GB file requests,
17# see http://article.gmane.org/gmane.comp.web.lighttpd:722
d20e182e 18#
2abd0792
ER
19
20# Prerelease snapshot: DATE-TIME
c1b34484 21##define _snap 20050116-1743
2abd0792
ER
22
23%if 0%{?_snap}
24%define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
25%else
26%define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
27%endif
28
7e061009 29%define _rel 2
2abd0792 30
027853cc 31Summary: Fast and light HTTP server
32Summary(pl): Szybki i lekki serwer HTTP
bee4f74e 33Name: lighttpd
73b36bb7 34Version: 1.3.10
2abd0792 35Release: %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
bee4f74e 36Group: Networking/Daemons
4241e769 37License: BSD
2abd0792 38Source0: %{_source}
73b36bb7 39# Source0-md5: 28623eff50653a9b104ddb20fe65aaf1
bee4f74e 40Source1: %{name}.init
2f7162ab
AM
41Source2: %{name}.conf
42Source3: %{name}.user
607835c0 43Source4: %{name}.logrotate
c54ca3d2 44Source5: %{name}.sysconfig
70373b58 45URL: http://www.lighttpd.net/
7e061009 46Patch0: %{name}-empty_cgi_handler.patch
1a75d3e1
JB
47BuildRequires: autoconf
48BuildRequires: automake
49BuildRequires: bzip2-devel
50BuildRequires: libtool
49163762 51%{?with_ssl:BuildRequires: openssl-devel}
1a75d3e1 52BuildRequires: pcre-devel
e68efba2 53BuildRequires: rpmbuild(macros) >= 1.159
1a75d3e1 54BuildRequires: zlib-devel
d20e182e 55%if %{with xattr}
56BuildRequires: attr-devel
57%endif
05f8c491
ER
58%{?with_ldap:BuildRequires: openldap-devel}
59%{?with_mysql:BuildRequires: mysql-devel}
d80c1ef1 60%{?with_valgrind:BuildRequires: valgrind}
bee4f74e
AM
61PreReq: rc-scripts
62Requires(pre): sh-utils
63Requires(pre): /bin/id
64Requires(pre): /usr/bin/getgid
65Requires(pre): /usr/sbin/groupadd
66Requires(pre): /usr/sbin/useradd
67Requires(post,preun): /sbin/chkconfig
bee4f74e 68Requires(postun): /usr/sbin/groupdel
e68efba2 69Requires(postun): /usr/sbin/userdel
70Provides: group(lighttpd)
1a75d3e1 71Provides: httpd
e68efba2 72Provides: user(lighttpd)
1a75d3e1 73Provides: webserver
bee4f74e
AM
74BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76%define _libdir %{_prefix}/%{_lib}/%{name}
8d734bed 77%define _lighttpddir /home/services/%{name}
bee4f74e
AM
78%define _sysconfdir /etc/%{name}
79
80%description
f655b1fd
MC
81lighttpd is a secure, fast, compliant and very flexible web-server
82which has been optimized for high-performance environments. It has
83a very low memory footprint compared to other webservers and takes
84care of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
bee4f74e
AM
85Output-Compression, URL-Rewriting and many more) make lighttpd the
86perfect webserver-software for every server that is suffering load
87problems.
88
f655b1fd
MC
89%description -l pl
90lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
1a75d3e1 91