]> git.pld-linux.org Git - packages/libx264.git/blame - libx264.spec
- fix ac-amd64 build, inspired from this post:
[packages/libx264.git] / libx264.spec
CommitLineData
bad36153 1%define snap 20080816
1eadea1c 2%define snaph 2245
cff56449 3%define rel 3
65b73f48 4Summary: H264 encoder library
23647862 5Summary(pl.UTF-8): Biblioteka kodująca H264
65b73f48
JB
6Name: libx264
7Version: 0.1.2
4663db6e 8Release: 1.%{snap}_%{snaph}.%{rel}
76f3f357 9License: GPL v2+
65b73f48 10Group: Libraries
aedfa898
JB
11# unofficial, debianized/libtoolized packaging:
12#Source0: http://www.acarlab.com/misc-dnlds/%{name}-%{version}.tar.gz
13# but it's too old, so use snapshots...
14Source0: ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{snap}-%{snaph}.tar.bz2
bad36153 15# Source0-md5: 0a188b8e13c62f6a97eba1c5d4ab3a3f
2741dce2 16Patch0: %{name}-alpha.patch
f33b600a 17URL: http://www.videolan.org/developers/x264.html
bad36153
KK
18BuildRequires: gettext-devel
19BuildRequires: gtk+2-devel
20BuildRequires: pkgconfig
21%ifarch %{ix86} %{x8664}
f33b600a 22BuildRequires: yasm >= 0.6.0
aedfa898 23%endif
65b73f48
JB
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
7cf55bee
PS
26# encoder/macroblock.c breaks strict-aliasing rules
27%define specflags -fno-strict-aliasing
28
65b73f48
JB
29%description
30libx264 library for encoding H264 video format.
31
3d6bd83a 32%description -l pl.UTF-8
65b73f48
JB
33Biblioteka libx264 do kodowania w formacie obrazu H264.
34
35%package devel
36Summary: Header files for x264 library
23647862 37Summary(pl.UTF-8): Pliki nagłówkowe biblioteki x264
65b73f48
JB
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40
41%description devel
42Header files for x264 library.
43
3d6bd83a
JR
44%description devel -l pl.UTF-8
45Pliki nagłówkowe biblioteki x264.
65b73f48
JB
46
47%package static
48Summary: Static x264 library
23647862 49Summary(pl.UTF-8): Statyczna biblioteka x264
65b73f48
JB
50Group: Development/Libraries
51Requires: %{name}-devel = %{version}-%{release}
52
53%description static
54Static x264 library.
55
3d6bd83a 56%description static -l pl.UTF-8
65b73f48
JB
57Statyczna biblioteka x264.
58
76f3f357
JB
59%package gtk
60Summary: x264 GTK+ configuration interface library
61Summary(pl.UTF-8): Biblioteka interfejsu konfiguracyjnego GTK+ dla x264
62Group: X11/Libraries
63Requires: %{name} = %{version}-%{release}
64Conflicts: libx264-gui < 0.1.2-1.20080816_2245.2
65
66%description gtk
67x264 GTK+ configuration interface library.
68
69%description gtk -l pl.UTF-8
70Biblioteka interfejsu konfiguracyjnego GTK+ dla x264.
71
72%package gtk-devel
73Summary: Header files for x264gtk library
74Summary(pl.UTF-8): Pliki nagłówkowe biblioteki x264gtk
75Group: X11/Development/Libraries
76Requires: %{name}-devel = %{version}-%{release}
77Requires: %{name}-gtk = %{version}-%{release}
78
79%description gtk-devel
80Header files for x264gtk library.
81
82%description gtk-devel -l pl.UTF-8
83Pliki nagłówkowe biblioteki x264gtk.
84
85%package gtk-static
86Summary: Static x264gtk library
87Summary(pl.UTF-8): Statyczna biblioteka x264gtk
88Group: X11/Development/Libraries
89Requires: %{name}-gtk-devel = %{version}-%{release}
90
91%description gtk-static
92Static x264gtk library.
93
94%description gtk-static -l pl.UTF-8
95Statyczna biblioteka x264gtk.
96
bad36153
KK
97%package gui
98Summary: Encoding GUI for x264
76f3f357 99Summary(pl.UTF-8): Graficzny interfejs użytkownika do kodera x264
bad36153 100Group: X11/Applications/Multimedia
76f3f357 101Requires: %{name}-gtk = %{version}-%{release}
bad36153
KK
102
103%description gui
104Encoding GUI for x264.
105
76f3f357
JB
106%description gui -l pl.UTF-8
107Graficzny interfejs użytkownika do kodera x264.
108
65b73f48 109%prep
aedfa898 110%setup -q -n x264-snapshot-%{snap}-%{snaph}
2741dce2 111%patch0 -p1
bad36153 112sed -i 's:-O4::g' configure
65b73f48
JB
113
114%build
704304fd 115CC="%{__cc}" \
7cf55bee 116./configure \
219e4f34
PS
117 --prefix=%{_prefix} \
118 --exec-prefix=%{_prefix} \
119 --bindir=%{_bindir} \
120 --includedir=%{_includedir} \
121 --libdir=%{_libdir} \
7cf55bee 122 --extra-cflags="%{rpmcflags}" \
bad36153
KK
123 --enable-gtk \
124 --enable-pic \
7cf55bee
PS
125 --enable-shared
126
65b73f48
JB
127%{__make}
128
129%install
130rm -rf $RPM_BUILD_ROOT
131
132%{__make} install \
133 DESTDIR=$RPM_BUILD_ROOT
134
bad36153
KK
135%find_lang x264_gtk
136
65b73f48
JB
137%clean
138rm -rf $RPM_BUILD_ROOT
139
140%post -p /sbin/ldconfig
141%postun -p /sbin/ldconfig
142
143%files
144%defattr(644,root,root,755)
247a0e4f 145%doc AUTHORS
65b73f48 146%attr(755,root,root) %{_bindir}/x264
76f3f357 147%attr(755,root,root) %{_libdir}/libx264.so.60
65b73f48
JB
148
149%files devel
150%defattr(644,root,root,755)
151%attr(755,root,root) %{_libdir}/libx264.so
65b73f48 152%{_includedir}/x264.h
247a0e4f 153%{_pkgconfigdir}/x264.pc
65b73f48
JB
154
155%files static
156%defattr(644,root,root,755)
157%{_libdir}/libx264.a
bad36153 158
76f3f357 159%files gtk -f x264_gtk.lang
bad36153 160%defattr(644,root,root,755)
76f3f357 161%attr(755,root,root) %{_libdir}/libx264gtk.so.60
bad36153 162%{_datadir}/x264
76f3f357
JB
163
164%files gtk-devel
165%defattr(644,root,root,755)
166%attr(755,root,root) %{_libdir}/libx264gtk.so
167%{_includedir}/x264_gtk*.h
168%{_pkgconfigdir}/x264gtk.pc
169
170%files gtk-static
171%defattr(644,root,root,755)
172%{_libdir}/libx264gtk.a
173
174%files gui
175%defattr(644,root,root,755)
176%attr(755,root,root) %{_bindir}/x264_gtk_encode
This page took 0.081224 seconds and 4 git commands to generate.