]> git.pld-linux.org Git - packages/libutempter.git/blame - libutempter.spec
s-/usr/sbin-%{_sbindir}-
[packages/libutempter.git] / libutempter.spec
CommitLineData
b1fb8c81 1Summary: Privledged helper for utmp/wtmp updates
2Name: utempter
3Version: 0.5
4Release: 2
5Copyright: MIT
6Group: Base
8558607f 7Group(pl): Podstawy
b1fb8c81 8Source: %{name}-%{version}.tar.gz
8edf1616 9Prereq: %{_sbindir}/groupadd, fileutils
b1fb8c81 10BuildRoot: /tmp/%{name}-%{version}-root
dd80edbc 11
12%description
13Utempter is a utility which allows programs to log information to a
b1fb8c81 14privledged file (/var/run/utmp), without compromising system security. It
15accomplishes this task by acting as a buffer between root and the programs.
16
17%package devel
18Summary: utempter library header files
19Group: Development/Libraties
8558607f 20Group(pl): Programowanie/Biblioteki
b1fb8c81 21Requires: %{name} = %{version}
22
23%description devel
24utempter library header files.
dd80edbc 25
26%prep
b1fb8c81 27%setup -q
dd80edbc 28
29%build
b1fb8c81 30make
dd80edbc 31
32%install
33rm -rf $RPM_BUILD_ROOT
34make PREFIX=$RPM_BUILD_ROOT install
35
b1fb8c81 36strip --strip-unneeded $RPM_BUILD_ROOT/usr/{lib/lib*.so.*.*,sbin/*}
37
dd80edbc 38%pre
8edf1616 39%{_sbindir}/groupadd -r -f utmp
dd80edbc 40
41%post
42/sbin/ldconfig
43
44if [ -f /var/log/wtmp ]; then
45 chown root.utmp /var/log/wtmp
46 chmod 664 /var/log/wtmp
47fi
48
49if [ -f /var/run/utmp ]; then
50 chown root.utmp /var/run/utmp
51 chmod 664 /var/run/utmp
52fi
53
54%postun -p /sbin/ldconfig
55
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59%files
b1fb8c81 60%defattr(644,root,root,755)
8edf1616 61%attr(2755,root,utmp) %{_sbindir}/utempter
aa7c5076 62%attr(0755,root,root) %{_libdir}/lib*.so.*.*
b1fb8c81 63
64%files devel
65%defattr(644,root,root,755)
aa7c5076 66%attr(0755,root,root) %{_libdir}/lib*.so
8edf1616 67%{_includedir}/utempter.h
b1fb8c81 68
69%changelog
70