]> git.pld-linux.org Git - packages/libopenmpt.git/blame - libopenmpt.spec
- new
[packages/libopenmpt.git] / libopenmpt.spec
CommitLineData
d1b3878e
JB
1#
2# Conditional build:
3%bcond_without openmpt123 # openmpt123 CLI player
4%bcond_with sdl # SDL2 output in openmpt123
5%bcond_without static_libs # don't build static libraries
6%bcond_without tests # unit tests
7#
8Summary: Tracker module player based on OpenMPT
9Summary(pl.UTF-8): Odtwarzacz modułów ścieżkowych oparty na OpenMPT
10Name: libopenmpt
11Version: 0.2.8461
12Release: 1
13License: BSD
14Group: Libraries
15# "betaNN" is only information, not element of version number
16Source0: https://lib.openmpt.org/files/libopenmpt/src/%{name}-%{version}-beta26-autotools.tar.gz
17# Source0-md5: 29ac490b6444be3f123d95650811b17d
18URL: https://lib.openmpt.org/
19BuildRequires: doxygen
20BuildRequires: libmpg123-devel
21BuildRequires: libstdc++-devel >= 6:4.3
22BuildRequires: libogg-devel
23BuildRequires: libvorbis-devel
24BuildRequires: pkgconfig >= 1:0.24
25BuildRequires: zlib-devel
26%if %{with openmpt123}
27%{?with_sdl:BuildRequires: SDL2-devel >= 2}
28BuildRequires: flac-devel >= 1.3.0
29BuildRequires: libsndfile-devel
30BuildRequires: portaudio-devel >= 19
31BuildRequires: portaudio-c++-devel >= 19
32BuildRequires: pulseaudio-devel
33%endif
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37Tracker module player based on OpenMPT.
38
39%description -l pl.UTF-8
40Odtwarzacz modułów ścieżkowych oparty na OpenMPT.
41
42%package devel
43Summary: Header files for OpenMPT library
44Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OpenMPT
45Group: Development/Libraries
46Requires: %{name} = %{version}-%{release}
47Requires: libmpg123-devel
48Requires: libogg-devel
49Requires: libvorbis-devel
50Requires: zlib-devel
51
52%description devel
53Header files for OpenMPT library.
54
55%description devel -l pl.UTF-8
56Pliki nagłówkowe biblioteki OpenMPT.
57
58%package static
59Summary: Static OpenMPT library
60Summary(pl.UTF-8): Statyczna biblioteka OpenMPT
61Group: Development/Libraries
62Requires: %{name}-devel = %{version}-%{release}
63
64%description static
65Static OpenMPT library.
66
67%description static -l pl.UTF-8
68Statyczna biblioteka OpenMPT.
69
70%package apidocs
71Summary: API documentation for OpenMPT library
72Summary(pl.UTF-8): Dokumentacja API biblioteki OpenMPT
73Group: Documentation
74%if "%{_rpmversion}" >= "5"
75BuildArch: noarch
76%endif
77
78%description apidocs
79API documentation and examples for OpenMPT library.
80
81%description apidocs -l pl.UTF-8
82Dokumentacja API i przykłady do biblioteki OpenMPT.
83
84%package -n openmpt123
85Summary: Command line module music player based on libopenmpt
86Summary(pl.UTF-8): Działający z linii poleceń odtwarzacz modułów muzycznych oparty na libopenmpt
87Group: Applications/Sound
88Requires: %{name} = %{version}-%{release}
89
90%description -n openmpt123
91Command line module music player based on libopenmpt.
92
93%description -n openmpt123 -l pl.UTF-8
94Działający z linii poleceń odtwarzacz modułów muzycznych oparty na
95libopenmpt.
96
97%prep
98%setup -q -n %{name}-%{version}-autotools
99
100%build
101%configure \
102 %{!?with_openmpt123:--disable-openmpt123} \
103 %{!?with_static_libs:--disable-static} \
104 %{?with_sdl:--with-sdl2}
105%{__make}
106
107%if %{with tests}
108%{__make} check
109%endif
110
111%install
112rm -rf $RPM_BUILD_ROOT
113
114%{__make} install \
115 DESTDIR=$RPM_BUILD_ROOT
116
117install -d $RPM_BUILD_ROOT%{_examplesdir}
118%{__mv} $RPM_BUILD_ROOT%{_docdir}/%{name}/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
119# packaged as %doc / examples
120%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
121# obsoleted by pkg-config
122%{__rm} $RPM_BUILD_ROOT%{_libdir}/libopenmpt.la
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%post -p /sbin/ldconfig
128%postun -p /sbin/ldconfig
129
130%files
131%defattr(644,root,root,755)
132# don't package README.md here, it contains only packager and libopenmpt developer information
133%doc LICENSE TODO
134%attr(755,root,root) %{_libdir}/libopenmpt.so.*.*.*
135%attr(755,root,root) %ghost %{_libdir}/libopenmpt.so.0
136
137%files devel
138%defattr(644,root,root,755)
139%attr(755,root,root) %{_libdir}/libopenmpt.so
140%{_includedir}/libopenmpt
141%{_pkgconfigdir}/libopenmpt.pc
142
143%if %{with static_libs}
144%files static
145%defattr(644,root,root,755)
146%{_libdir}/libopenmpt.a
147%endif
148
149%files apidocs
150%defattr(644,root,root,755)
151%doc doxygen-doc/html/*
152%{_examplesdir}/%{name}-%{version}
153
154%if %{with openmpt123}
155%files -n openmpt123
156%defattr(644,root,root,755)
157%attr(755,root,root) %{_bindir}/openmpt123
158%{_mandir}/man1/openmpt123.1*
159%endif
This page took 0.040408 seconds and 4 git commands to generate.