]> git.pld-linux.org Git - projects/template-specs.git/blame - lib.spec
- update
[projects/template-specs.git] / lib.spec
CommitLineData
3cb1cd3d 1#
66df3cad
ER
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
aed9d573 4%bcond_without static_libs # don't build static libraries
66df3cad 5#
f9986cd5 6Summary: -
ce39d734 7Summary(pl.UTF-8): -
3f8f5e5b
ER
8Name: ---
9Version: 0.1
10Release: 0.1
f9986cd5
JB
11License: - (enter GPL/LGPL/BSD/BSD-like/other license name here)
12Group: Libraries
13Source0: %{name}-%{version}.tar.gz
14# Source0-md5: -
3f8f5e5b
ER
15#Patch0: %{name}-what.patch
16#URL: -
17#BuildRequires: -
18#Requires(postun): -
19#Requires(pre,post): -
20#Requires(preun): -
21#Requires: -
22#Provides: -
23#Obsoletes: -
24#Conflicts: -
f9986cd5
JB
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
a1a32384
ER
27# do not keep them in newly created specs
28# these are only here to help fixing quickly broken specs
29%define filterout_ld -Wl,--no-copy-dt-needed-entries
30%define filterout_ld -Wl,--as-needed
31
20667fb2
ER
32# Ignore file in __spec_install_post_check_so
33BuildRequires: rpmbuild(macros) >= 1.583
e24df1c5 34%define skip_post_check_so libunresolved.so.*
20667fb2 35
f9986cd5
JB
36%description
37
3f8f5e5b 38#%description -l pl.UTF-8
f9986cd5 39
41119926 40%package common
ca8abdb7
TP
41Summary: Common files for %{name} library
42Summary(pl.UTF-8): Wspólne pliki biblioteki %{name}
41119926
TP
43Group: Libraries
44Requires: %{name} = %{version}-%{release}
45
46%description common
ca8abdb7 47Common files for %{name} library.
41119926
TP
48
49%description common -l pl.UTF-8
ca8abdb7 50Wspólne pliki biblioteki %{name}.
41119926 51
f9986cd5 52%package devel
ca8abdb7
TP
53Summary: Header files for %{name} library
54Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
f9986cd5 55Group: Development/Libraries
d7dd7729 56Requires: %{name} = %{version}-%{release}
f9986cd5
JB
57
58%description devel
ca8abdb7 59Header files for %{name} library.
f9986cd5 60
9be49f18 61%description devel -l pl.UTF-8
ca8abdb7 62Pliki nagłówkowe biblioteki %{name}.
f9986cd5
JB
63
64%package static
ca8abdb7
TP
65Summary: Static %{name} library
66Summary(pl.UTF-8): Statyczna biblioteka %{name}
f9986cd5 67Group: Development/Libraries
d7dd7729 68Requires: %{name}-devel = %{version}-%{release}
f9986cd5
JB
69
70%description static
ca8abdb7 71Static %{name} library.
f9986cd5 72
9be49f18 73%description static -l pl.UTF-8
ca8abdb7 74Statyczna biblioteka %{name}.
f9986cd5 75
66df3cad 76%package apidocs
ca8abdb7
TP
77Summary: %{name} API documentation
78Summary(pl.UTF-8): Dokumentacja API biblioteki %{name}
66df3cad
ER
79Group: Documentation
80
81%description apidocs
ca8abdb7 82API and internal documentation for %{name} library.
66df3cad 83
3cb1cd3d 84%description apidocs -l pl.UTF-8
ca8abdb7 85Dokumentacja API biblioteki %{name}.
3cb1cd3d 86
f9986cd5
JB
87%prep
88%setup -q
1c854c4b 89#%patch0 -p1
f9986cd5
JB
90
91%build
c42a30cf
JB
92# if ac/am/lt/* rebuilding is necessary, do it in this order and add
93# appropriate BuildRequires
94#%{__libtoolize}
95#%{__aclocal}
96#%{__autoconf}
97#%{__autoheader}
98#%{__automake}
f6de6810
ER
99%configure \
100 %{!?with_static_libs:--disable-static}
f9986cd5
JB
101%{__make}
102
103%install
104rm -rf $RPM_BUILD_ROOT
105# create directories if necessary
106#install -d $RPM_BUILD_ROOT
107
108%{__make} install \
109 DESTDIR=$RPM_BUILD_ROOT
110
14750145
JB
111# if library provides pkgconfig file containing proper {Requires,Libs}.private
112# then remove .la pollution
4b532792
JR
113#%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
114
f9986cd5
JB
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%post -p /sbin/ldconfig
119%postun -p /sbin/ldconfig
120
121%files
122%defattr(644,root,root,755)
41119926
TP
123%doc AUTHORS CREDITS README THANKS
124%attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
125%attr(755,root,root) %ghost %{_libdir}/%{name}.so.N
126
127%files common
128%defattr(644,root,root,755)
129%attr(755,root,root) %{_bindir}/%{name}*
f9986cd5
JB
130%{_datadir}/%{name}
131
132%files devel
133%defattr(644,root,root,755)
41119926
TP
134%doc devel-doc/* ChangeLog NEWS TODO
135%attr(755,root,root) %{_libdir}/%{name}.so
14750145
JB
136# if no pkgconfig support, or it misses .private deps, then include .la file
137#%{_libdir}/libFOO.la
41119926
TP
138%{_includedir}/%{name}
139%{_aclocaldir}/%{name}.m4
140%{_pkgconfigdir}/%{name}.pc
f9986cd5 141
f6de6810 142%if %{with static_libs}
f9986cd5
JB
143%files static
144%defattr(644,root,root,755)
41119926 145%{_libdir}/%{name}.a
f6de6810 146%endif
66df3cad 147
a5f7d790 148%if %{with apidocs}
66df3cad
ER
149%files apidocs
150%defattr(644,root,root,755)
151%doc apidocs/*
a5f7d790 152%endif
This page took 0.06608 seconds and 4 git commands to generate.