]> git.pld-linux.org Git - projects/template-specs.git/blame - lib.spec
- added .la removal for pkgconfig enabled libs
[projects/template-specs.git] / lib.spec
CommitLineData
3cb1cd3d 1#
66df3cad
ER
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
aed9d573 4%bcond_without static_libs # don't build static libraries
66df3cad 5#
f9986cd5 6Summary: -
ce39d734 7Summary(pl.UTF-8): -
3f8f5e5b
ER
8Name: ---
9Version: 0.1
10Release: 0.1
f9986cd5
JB
11License: - (enter GPL/LGPL/BSD/BSD-like/other license name here)
12Group: Libraries
13Source0: %{name}-%{version}.tar.gz
14# Source0-md5: -
3f8f5e5b
ER
15#Patch0: %{name}-what.patch
16#URL: -
17#BuildRequires: -
18#Requires(postun): -
19#Requires(pre,post): -
20#Requires(preun): -
21#Requires: -
22#Provides: -
23#Obsoletes: -
24#Conflicts: -
f9986cd5
JB
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
a1a32384
ER
27# do not keep them in newly created specs
28# these are only here to help fixing quickly broken specs
29%define filterout_ld -Wl,--no-copy-dt-needed-entries
30%define filterout_ld -Wl,--as-needed
31
20667fb2
ER
32# Ignore file in __spec_install_post_check_so
33BuildRequires: rpmbuild(macros) >= 1.583
e24df1c5 34%define skip_post_check_so libunresolved.so.*
20667fb2 35
f9986cd5
JB
36%description
37
3f8f5e5b 38#%description -l pl.UTF-8
f9986cd5
JB
39
40%package devel
41Summary: Header files for FOO library
ce39d734 42Summary(pl.UTF-8): Pliki nagłówkowe biblioteki FOO
f9986cd5 43Group: Development/Libraries
d7dd7729 44Requires: %{name} = %{version}-%{release}
f9986cd5
JB
45
46%description devel
47Header files for FOO library.
48
9be49f18
JR
49%description devel -l pl.UTF-8
50Pliki nagłówkowe biblioteki FOO.
f9986cd5
JB
51
52%package static
53Summary: Static FOO library
ce39d734 54Summary(pl.UTF-8): Statyczna biblioteka FOO
f9986cd5 55Group: Development/Libraries
d7dd7729 56Requires: %{name}-devel = %{version}-%{release}
f9986cd5
JB
57
58%description static
59Static FOO library.
60
9be49f18 61%description static -l pl.UTF-8
f9986cd5
JB
62Statyczna biblioteka FOO.
63
66df3cad
ER
64%package apidocs
65Summary: FOO API documentation
9fcce7f1 66Summary(pl.UTF-8): Dokumentacja API biblioteki FOO
66df3cad
ER
67Group: Documentation
68
69%description apidocs
70API and internal documentation for FOO library.
71
3cb1cd3d
JB
72%description apidocs -l pl.UTF-8
73Dokumentacja API biblioteki FOO.
74
f9986cd5
JB
75%prep
76%setup -q
1c854c4b 77#%patch0 -p1
f9986cd5
JB
78
79%build
c42a30cf
JB
80# if ac/am/lt/* rebuilding is necessary, do it in this order and add
81# appropriate BuildRequires
82#%{__libtoolize}
83#%{__aclocal}
84#%{__autoconf}
85#%{__autoheader}
86#%{__automake}
f6de6810
ER
87%configure \
88 %{!?with_static_libs:--disable-static}
f9986cd5
JB
89%{__make}
90
91%install
92rm -rf $RPM_BUILD_ROOT
93# create directories if necessary
94#install -d $RPM_BUILD_ROOT
95
96%{__make} install \
97 DESTDIR=$RPM_BUILD_ROOT
98
4b532792
JR
99# if library provides pkgconfig then remove .la pollution
100#%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
101
f9986cd5
JB
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%post -p /sbin/ldconfig
106%postun -p /sbin/ldconfig
107
108%files
109%defattr(644,root,root,755)
110%doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
111%attr(755,root,root) %{_bindir}/*
f6de6810 112%attr(755,root,root) %{_libdir}/libFOO.so.*.*.*
4b532792 113%attr(755,root,root) %ghost %{_libdir}/libFOO.so.[0-9]
f9986cd5
JB
114%{_datadir}/%{name}
115
116%files devel
117%defattr(644,root,root,755)
118%doc devel-doc/*
f6de6810
ER
119%{_libdir}/libFOO.so
120%{_libdir}/libFOO.la
f9986cd5 121%{_includedir}/foo
f6de6810
ER
122%{_aclocaldir}/FOO.m4
123%{_pkgconfigdir}/FOO.pc
f9986cd5 124
f6de6810 125%if %{with static_libs}
f9986cd5
JB
126%files static
127%defattr(644,root,root,755)
f6de6810
ER
128%{_libdir}/libFOO.a
129%endif
66df3cad 130
a5f7d790 131%if %{with apidocs}
66df3cad
ER
132%files apidocs
133%defattr(644,root,root,755)
134%doc apidocs/*
a5f7d790 135%endif
This page took 0.053132 seconds and 4 git commands to generate.