]> git.pld-linux.org Git - projects/template-specs.git/blame - lib.spec
dokuwiki: add .less, drop _test
[projects/template-specs.git] / lib.spec
CommitLineData
3cb1cd3d 1#
66df3cad
ER
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
aed9d573 4%bcond_without static_libs # don't build static libraries
66df3cad 5#
f9986cd5 6Summary: -
ce39d734 7Summary(pl.UTF-8): -
3f8f5e5b
ER
8Name: ---
9Version: 0.1
10Release: 0.1
f9986cd5
JB
11License: - (enter GPL/LGPL/BSD/BSD-like/other license name here)
12Group: Libraries
13Source0: %{name}-%{version}.tar.gz
14# Source0-md5: -
3f8f5e5b
ER
15#Patch0: %{name}-what.patch
16#URL: -
17#BuildRequires: -
c53387e8
ER
18#BuildRequires: autoconf
19#BuildRequires: automake
20#BuildRequires: intltool
21#BuildRequires: libtool
3f8f5e5b
ER
22#Requires(postun): -
23#Requires(pre,post): -
24#Requires(preun): -
25#Requires: -
26#Provides: -
27#Obsoletes: -
28#Conflicts: -
f9986cd5
JB
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
a1a32384
ER
31# do not keep them in newly created specs
32# these are only here to help fixing quickly broken specs
33%define filterout_ld -Wl,--no-copy-dt-needed-entries
34%define filterout_ld -Wl,--as-needed
31c122e0
ER
35# do not commit spec containing this (use for local testing only):
36%define filterout_c -Werror=format-security
877721ed 37%define filterout_cxx -Werror=format-security
a1a32384 38
20667fb2 39# Ignore file in __spec_install_post_check_so
5346ce74 40BuildRequires: rpmbuild(macros) >= 1.583
e24df1c5 41%define skip_post_check_so libunresolved.so.*
20667fb2 42
e025831d
ER
43# do not commit spec containing this (use for local testing only):
44%define no_install_post_check_tmpfiles 1
45
f9986cd5
JB
46%description
47
3f8f5e5b 48#%description -l pl.UTF-8
f9986cd5 49
41119926 50%package common
ca8abdb7
TP
51Summary: Common files for %{name} library
52Summary(pl.UTF-8): Wspólne pliki biblioteki %{name}
41119926
TP
53Group: Libraries
54Requires: %{name} = %{version}-%{release}
55
56%description common
ca8abdb7 57Common files for %{name} library.
41119926
TP
58
59%description common -l pl.UTF-8
ca8abdb7 60Wspólne pliki biblioteki %{name}.
41119926 61
f9986cd5 62%package devel
ca8abdb7
TP
63Summary: Header files for %{name} library
64Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
f9986cd5 65Group: Development/Libraries
d7dd7729 66Requires: %{name} = %{version}-%{release}
f9986cd5
JB
67
68%description devel
ca8abdb7 69Header files for %{name} library.
f9986cd5 70
9be49f18 71%description devel -l pl.UTF-8
ca8abdb7 72Pliki nagłówkowe biblioteki %{name}.
f9986cd5
JB
73
74%package static
ca8abdb7
TP
75Summary: Static %{name} library
76Summary(pl.UTF-8): Statyczna biblioteka %{name}
f9986cd5 77Group: Development/Libraries
d7dd7729 78Requires: %{name}-devel = %{version}-%{release}
f9986cd5
JB
79
80%description static
ca8abdb7 81Static %{name} library.
f9986cd5 82
9be49f18 83%description static -l pl.UTF-8
ca8abdb7 84Statyczna biblioteka %{name}.
f9986cd5 85
66df3cad 86%package apidocs
ca8abdb7
TP
87Summary: %{name} API documentation
88Summary(pl.UTF-8): Dokumentacja API biblioteki %{name}
66df3cad
ER
89Group: Documentation
90
91%description apidocs
e077345b 92API documentation for %{name} library.
66df3cad 93
3cb1cd3d 94%description apidocs -l pl.UTF-8
ca8abdb7 95Dokumentacja API biblioteki %{name}.
3cb1cd3d 96
f9986cd5
JB
97%prep
98%setup -q
1c854c4b 99#%patch0 -p1
f9986cd5
JB
100
101%build
c42a30cf
JB
102# if ac/am/lt/* rebuilding is necessary, do it in this order and add
103# appropriate BuildRequires
104#%{__libtoolize}
105#%{__aclocal}
106#%{__autoconf}
107#%{__autoheader}
108#%{__automake}
f6de6810
ER
109%configure \
110 %{!?with_static_libs:--disable-static}
f9986cd5
JB
111%{__make}
112
113%install
114rm -rf $RPM_BUILD_ROOT
115# create directories if necessary
116#install -d $RPM_BUILD_ROOT
117
118%{__make} install \
119 DESTDIR=$RPM_BUILD_ROOT
120
14750145
JB
121# if library provides pkgconfig file containing proper {Requires,Libs}.private
122# then remove .la pollution
4b532792
JR
123#%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
124
f9986cd5
JB
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%post -p /sbin/ldconfig
129%postun -p /sbin/ldconfig
130
131%files
132%defattr(644,root,root,755)
41119926
TP
133%doc AUTHORS CREDITS README THANKS
134%attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
135%attr(755,root,root) %ghost %{_libdir}/%{name}.so.N
136
137%files common
138%defattr(644,root,root,755)
139%attr(755,root,root) %{_bindir}/%{name}*
f9986cd5
JB
140%{_datadir}/%{name}
141
142%files devel
143%defattr(644,root,root,755)
41119926
TP
144%doc devel-doc/* ChangeLog NEWS TODO
145%attr(755,root,root) %{_libdir}/%{name}.so
14750145
JB
146# if no pkgconfig support, or it misses .private deps, then include .la file
147#%{_libdir}/libFOO.la
41119926
TP
148%{_includedir}/%{name}
149%{_aclocaldir}/%{name}.m4
150%{_pkgconfigdir}/%{name}.pc
f9986cd5 151
f6de6810 152%if %{with static_libs}
f9986cd5
JB
153%files static
154%defattr(644,root,root,755)
41119926 155%{_libdir}/%{name}.a
f6de6810 156%endif
66df3cad 157
a5f7d790 158%if %{with apidocs}
66df3cad
ER
159%files apidocs
160%defattr(644,root,root,755)
161%doc apidocs/*
a5f7d790 162%endif
This page took 0.199064 seconds and 4 git commands to generate.