]> git.pld-linux.org Git - packages/certbot.git/blame - letsencrypt.spec
use subver/rel macro; cleanups
[packages/certbot.git] / letsencrypt.spec
CommitLineData
e10a8dd3
AM
1# TODO: finish, test
2#
3# Conditional build:
4%bcond_without doc # don't build doc
5%bcond_without tests # do not perform "make test"
6
0f357a7d
ER
7%define rel 1
8%define subver 20151017
e10a8dd3
AM
9Summary: Let's Encrypt client
10Name: letsencrypt
11Version: 0.0.0
0f357a7d 12Release: 0.%{subver}.%{rel}
e10a8dd3 13License: APL 2.0
0f357a7d
ER
14Group: Applications/Networking
15Source0: https://github.com/letsencrypt/letsencrypt/archive/v%{version}.dev%{subver}.tar.gz
e10a8dd3
AM
16# Source0-md5: 1cac8a454e466136f70834c76977ef17
17URL: https://letsencrypt.org/
e10a8dd3
AM
18BuildRequires: python-modules
19BuildRequires: python-setuptools
20BuildRequires: rpm-pythonprov
21BuildRequires: rpmbuild(macros) >= 1.612
22%if %{with tests}
23BuildRequires: python-mock
24BuildRequires: python-pythondialog
25BuildRequires: python-zope.component
26BuildRequires: python-zope.interface
27%endif
28%if %{with doc}
29BuildRequires: python-repoze.sphinx.autointerfac
30BuildRequires: sphinx-pdg
31%endif
32Requires: python-cryptography
33Requires: python-modules
34Requires: python-pyOpenSSL
35Requires: python-pytz
36BuildArch: noarch
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
40The Let's Encrypt Client is a tool to automatically receive and
41install X.509 certificates to enable TLS on servers. The client will
42interoperate with the Let's Encrypt CA which will be issuing
43browser-trusted certificates for free.
44
45%prep
0f357a7d 46%setup -q -n %{name}-%{version}.dev%{subver}
e10a8dd3
AM
47
48%build
49%{__python} setup.py build %{?with_tests:test}
50
51%if %{with doc}
52cd docs
53%{__make} -j1 html
0f357a7d 54rm -r _build/html/_sources
e10a8dd3
AM
55%endif
56
57%install
58rm -rf $RPM_BUILD_ROOT
e10a8dd3
AM
59%{__python} setup.py \
60 build \
61 install --skip-build \
62 --optimize=2 \
63 --root=$RPM_BUILD_ROOT
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(644,root,root,755)
70%doc {CHANGES,README}.rst CONTRIBUTING.md %{?with_doc:docs/_build/html/*}
71%attr(755,root,root) %{_bindir}/letsencrypt
72%attr(755,root,root) %{_bindir}/letsencrypt-renewer
73%{py_sitescriptdir}/letsencrypt
0f357a7d 74%{py_sitescriptdir}/letsencrypt-%{version}*-py*.egg-info
This page took 0.151501 seconds and 4 git commands to generate.