]> git.pld-linux.org Git - packages/dehydrated.git/blame - letsencrypt.sh.spec
package config dir
[packages/dehydrated.git] / letsencrypt.sh.spec
CommitLineData
1780cc1f
ER
1Summary: letsencrypt/acme client implemented as a shell-script
2Name: letsencrypt.sh
3Version: 0.1.0
7410a329 4Release: 0.2
1780cc1f
ER
5License: MIT
6Group: Applications/Networking
7Source0: https://github.com/lukas2511/letsencrypt.sh/archive/v%{version}/%{name}-%{version}.tar.gz
eb6aa75d
ER
8# Source0-md5: eadd134cc5365753c03929dd70db341d
9Source1: apache.conf
10Source2: lighttpd.conf
1780cc1f
ER
11URL: https://github.com/lukas2511/letsencrypt.sh
12BuildRequires: rpmbuild(macros) >= 1.713
13Requires: curl
14Requires: grep
15Requires: mktemp
16Requires: openssl
17Requires: sed
eb6aa75d
ER
18Requires: webapps
19Requires: webserver(access)
20Requires: webserver(alias)
1780cc1f
ER
21BuildArch: noarch
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
eb6aa75d
ER
24%define _webapps /etc/webapps
25%define _webapp %{name}
26%define _sysconfdir %{_webapps}/%{_webapp}
27%define _appdir %{_datadir}/%{_webapp}
28
1780cc1f
ER
29%description
30This is a client for signing certificates with an ACME-server
31(currently only provided by letsencrypt) implemented as a relatively
32simple bash-script.
33
34Current features:
35- Signing of a list of domains
36- Signing of a CSR
37- Renewal if a certificate is about to expire or SAN (subdomains)
38 changed
39- Certificate revocation
40
41%prep
42%setup -q
43
44%install
45rm -rf $RPM_BUILD_ROOT
eb6aa75d
ER
46install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/acme-challenges}
47
48install -p letsencrypt.sh $RPM_BUILD_ROOT%{_sbindir}
49
50cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
51cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
52cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
1780cc1f
ER
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
eb6aa75d
ER
57%triggerin -- apache1 < 1.3.37-3, apache1-base
58%webapp_register apache %{_webapp}
59
60%triggerun -- apache1 < 1.3.37-3, apache1-base
61%webapp_unregister apache %{_webapp}
62
63%triggerin -- apache < 2.2.0, apache-base
64%webapp_register httpd %{_webapp}
65
66%triggerun -- apache < 2.2.0, apache-base
67%webapp_unregister httpd %{_webapp}
68
69%triggerin -- lighttpd
70%webapp_register lighttpd %{_webapp}
71
72%triggerun -- lighttpd
73%webapp_unregister lighttpd %{_webapp}
74
1780cc1f
ER
75%files
76%defattr(644,root,root,755)
77%doc README.md CHANGELOG LICENSE
7410a329 78%dir %attr(750,root,http) %{_sysconfdir}
eb6aa75d
ER
79%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
80%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
81%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
82# challenges written here from letsencrypt.sh, need to be readable by webserver
83%dir %attr(751,root,root) %{_sysconfdir}/acme-challenges
7410a329
ER
84
85%attr(755,root,root) %{_sbindir}/letsencrypt.sh
This page took 0.049358 seconds and 4 git commands to generate.