]> git.pld-linux.org Git - packages/ldns.git/blame - ldns.spec
- tabs in preamble
[packages/ldns.git] / ldns.spec
CommitLineData
f831bab4 1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
4#
48e924a7 5Summary: ldns - a library with the aim to simplify DNS programing in C
b8fc5d25 6Summary(pl.UTF-8): ldns - biblioteka mająca na celu uproszczenie programowania DNS w C
4b698da8 7Name: ldns
eaf00628 8Version: 1.0.1
4b698da8 9Release: 0.1
10License: GPL
11Group: Libraries
12Source0: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
eaf00628 13# Source0-md5: 39210ff3bb2673d57e024f7908d31be5
4b698da8 14URL: http://www.nlnetlabs.nl/ldns/
15BuildRequires: autoconf
48e924a7 16BuildRequires: automake
eaf00628 17BuildRequires: doxygen
4b698da8 18BuildRequires: libtool
664f9903 19BuildRequires: openssl-devel
4b698da8 20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23ldns is a library with the aim to simplify DNS programing in C. It is
24heavily based upon the Net::DNS module from perl.
25
74537b0c
JR
26%description -l pl.UTF-8
27ldns jest biblioteka mającą na celu uproszczenie programowania w C.
28Jest w dużym stopniu oparta na module Perla Net::DNS.
4b698da8 29
30%package devel
31Summary: Header files for ldns library
b8fc5d25 32Summary(pl.UTF-8): Pliki nagłówkowe biblioteki ldns
4b698da8 33Group: Development/Libraries
34Requires: %{name} = %{version}-%{release}
664f9903 35Requires: openssl-devel
4b698da8 36
37%description devel
38Header files for ldns library.
39
74537b0c
JR
40%description devel -l pl.UTF-8
41Pliki nagłówkowe biblioteki ldns.
4b698da8 42
43%package static
44Summary: Static ldns library
b8fc5d25 45Summary(pl.UTF-8): Statyczna biblioteka ldns
4b698da8 46Group: Development/Libraries
47Requires: %{name}-devel = %{version}-%{release}
48
49%description static
50Static ldns library.
51
74537b0c 52%description static -l pl.UTF-8
4b698da8 53Statyczna biblioteka ldns.
54
55%prep
56%setup -q
4b698da8 57
58%build
59%{__libtoolize}
60%{__aclocal}
61%{__autoconf}
62%{__autoheader}
f831bab4 63%configure \
eaf00628 64 --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no}
4b698da8 65%{__make}
66%{__make} doc
67
664f9903
JB
68# change symlinks into .so redirects
69cd doc/man/man3
70for f in `find . -type l`; do
71 d=`readlink $f`
72 rm -f $f
73 echo ".so $d" > $f
74done
75
4b698da8 76%install
77rm -rf $RPM_BUILD_ROOT
78
79%{__make} install \
80 DESTDIR=$RPM_BUILD_ROOT
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%post -p /sbin/ldconfig
86%postun -p /sbin/ldconfig
87
88%files
89%defattr(644,root,root,755)
eaf00628 90%doc Changelog ProgrammingPhilosophy README ROADMAP TODO
91%attr(755,root,root) %{_libdir}/lib*-*.*.*.so
4b698da8 92
93%files devel
94%defattr(644,root,root,755)
eaf00628 95%doc doc/{*.html,LDNS_API,overview,PacketTypes,dns-lib-implementations,function_manpages,ldns_manpages,CodingStyle,html}
4b698da8 96%attr(755,root,root) %{_libdir}/lib*.so
97%{_libdir}/lib*.la
98%{_includedir}/%{name}
664f9903 99%{_mandir}/man3/*.3*
4b698da8 100
f831bab4 101%if %{with static_libs}
4b698da8 102%files static
103%defattr(644,root,root,755)
104%{_libdir}/lib*.a
f831bab4 105%endif
This page took 0.081188 seconds and 4 git commands to generate.