]> git.pld-linux.org Git - packages/ldns.git/blame - ldns.spec
- rel 4; openssl 1.1.1 rebuild; force gost support
[packages/ldns.git] / ldns.spec
CommitLineData
f831bab4 1#
2# Conditional build:
85e5069d 3%bcond_without dane # OpenSSL DANE functions for verification (requires openssl >= 1.1.0)
fe4ba188
JB
4%bcond_without static_libs # don't build static libraries
5%bcond_without python # Python modules
f831bab4 6#
48e924a7 7Summary: ldns - a library with the aim to simplify DNS programing in C
b8fc5d25 8Summary(pl.UTF-8): ldns - biblioteka mająca na celu uproszczenie programowania DNS w C
4b698da8 9Name: ldns
45d04eb4 10Version: 1.7.0
85e5069d 11Release: 4
fe4ba188 12License: BSD
4b698da8 13Group: Libraries
30a21c94 14Source0: http://www.nlnetlabs.nl/downloads/ldns/%{name}-%{version}.tar.gz
45d04eb4
JB
15# Source0-md5: 74b75c9ba69fb3af2a0c26244ecfd9f6
16Patch0: python-install.patch
17Patch1: %{name}-link.patch
4b698da8 18URL: http://www.nlnetlabs.nl/ldns/
fe4ba188 19BuildRequires: autoconf >= 2.56
48e924a7 20BuildRequires: automake
eaf00628 21BuildRequires: doxygen
45d04eb4
JB
22BuildRequires: libtool >= 2:2
23%if %{with dane}
24BuildRequires: openssl-devel >= 1.1.0
25%else
2755bb0b 26BuildRequires: openssl-devel >= 1.0.0
45d04eb4 27%endif
fe4ba188
JB
28%if %{with python}
29BuildRequires: python-devel >= 1:2.4.0
30BuildRequires: rpmbuild(macros) >= 1.219
31BuildRequires: swig-python
32%endif
33Requires: openssl >= 1.0.0
4b698da8 34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37ldns is a library with the aim to simplify DNS programing in C. It is
38heavily based upon the Net::DNS module from perl.
39
74537b0c 40%description -l pl.UTF-8
fe4ba188
JB
41ldns jest biblioteka mającą na celu uproszczenie programowania
42związanego z usługą DNS w C. Jest w dużym stopniu oparta na module
43Perla Net::DNS.
4b698da8 44
45%package devel
46Summary: Header files for ldns library
b8fc5d25 47Summary(pl.UTF-8): Pliki nagłówkowe biblioteki ldns
4b698da8 48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
45d04eb4
JB
50%if %{with dane}
51Requires: openssl-devel >= 1.1.0
52%else
fe4ba188 53Requires: openssl-devel >= 1.0.0
45d04eb4 54%endif
4b698da8 55
56%description devel
57Header files for ldns library.
58
74537b0c
JR
59%description devel -l pl.UTF-8
60Pliki nagłówkowe biblioteki ldns.
4b698da8 61
62%package static
63Summary: Static ldns library
b8fc5d25 64Summary(pl.UTF-8): Statyczna biblioteka ldns
4b698da8 65Group: Development/Libraries
66Requires: %{name}-devel = %{version}-%{release}
67
68%description static
69Static ldns library.
70
74537b0c 71%description static -l pl.UTF-8
4b698da8 72Statyczna biblioteka ldns.
73
fe4ba188
JB
74%package -n python-ldns
75Summary: Python interface do ldns library
76Summary(pl.UTF-8): Pythonowy interfejs do biblioteki ldns
77Group: Libraries/Python
78Requires: %{name} = %{version}-%{release}
79
80%description -n python-ldns
81Python interface do ldns library.
82
83%description -n python-ldns -l pl.UTF-8
84Pythonowy interfejs do biblioteki ldns.
85
22a1a36d
JB
86%package -n drill
87Summary: drill - tool to get all sorts of information out of the DNS(SEC)
88Summary(pl.UTF-8): drill - narzędzie do pobierania dowolnych informacji z DNS(SEC)
89Group: Applications/Network
90Requires: %{name} = %{version}-%{release}
91
92%description -n drill
93drill is a tool to get all sorts of information out of the DNS. It is
94specifically designed to be used with DNSSEC.
95
96%description -n drill -l pl.UTF-8
97drill to narzędzie do pobierania dowolnych informacji z DNS. Jest
98zaprojektowane szczególnie z myślą o użyciu z DNSSEC.
99
ac1def33
AO
100%package tools
101Summary: Example tools for ldns.
102Summary(pl.UTF-8): Przykładowe narzędzie wykorzystujące ldns.
103Group: Applications/Network
104Requires: %{name} = %{version}-%{release}
105
106%description tools
107These tools are examples of ldns usage. They are not meant for
108production systems and will not be supported as such.
109
110%description tools -l pl.UTF-8
111Te narzędzia są przykładami użycia biblioteki ldns.
112Nie są przeznaczone do produkcyjnego użycia i jako takie
113nie będa wspierane.
114
4b698da8 115%prep
116%setup -q
b72951c3
JR
117%patch0 -p1
118%patch1 -p1
4b698da8 119
120%build
121%{__libtoolize}
122%{__aclocal}
123%{__autoconf}
124%{__autoheader}
f831bab4 125%configure \
85e5069d 126 --enable-gost-anyway \
45d04eb4 127 %{!?with_dane:--disable-dane-ta-usage} \
fe4ba188 128 --enable-static%{!?with_static_libs:=no} \
22a1a36d 129 --with-drill \
fe4ba188 130 %{?with_python:--with-pyldns}
4b698da8 131%{__make}
132%{__make} doc
133
ac1def33
AO
134cd examples
135%{__libtoolize}
136%{__aclocal}
137%{__autoconf}
138%{__autoheader}
139%configure
140%{__make}
141cd ..
142
664f9903
JB
143# change symlinks into .so redirects
144cd doc/man/man3
145for f in `find . -type l`; do
146 d=`readlink $f`
fe4ba188 147 %{__rm} $f
664f9903
JB
148 echo ".so $d" > $f
149done
150
4b698da8 151%install
152rm -rf $RPM_BUILD_ROOT
153
154%{__make} install \
155 DESTDIR=$RPM_BUILD_ROOT
156
fe4ba188
JB
157%if %{with python}
158%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_ldns.la
159%if %{with static_libs}
160%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_ldns.a
161%endif
162%py_comp $RPM_BUILD_ROOT%{py_sitedir}
163%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
164%py_postclean
165%endif
166
ac1def33
AO
167cd examples
168%{__make} install \
169 DESTDIR=$RPM_BUILD_ROOT
170cd ..
171
4b698da8 172%clean
173rm -rf $RPM_BUILD_ROOT
174
175%post -p /sbin/ldconfig
176%postun -p /sbin/ldconfig
177
178%files
179%defattr(644,root,root,755)
fe4ba188 180%doc Changelog LICENSE README
e29f02dc 181%attr(755,root,root) %{_libdir}/libldns.so.*.*.*
45d04eb4 182%attr(755,root,root) %ghost %{_libdir}/libldns.so.2
4b698da8 183
184%files devel
185%defattr(644,root,root,755)
e29f02dc 186%doc doc/{*.html,dns-lib-implementations,function_manpages,ldns_manpages,CodingStyle}
fe4ba188
JB
187%attr(755,root,root) %{_bindir}/ldns-config
188%attr(755,root,root) %{_libdir}/libldns.so
189%{_libdir}/libldns.la
4b698da8 190%{_includedir}/%{name}
fe4ba188
JB
191%{_mandir}/man1/ldns-config.1*
192%{_mandir}/man3/ldns_*.3*
4b698da8 193
f831bab4 194%if %{with static_libs}
4b698da8 195%files static
196%defattr(644,root,root,755)
fe4ba188
JB
197%{_libdir}/libldns.a
198%endif
199
200%if %{with python}
201%files -n python-ldns
202%defattr(644,root,root,755)
203%attr(755,root,root) %{py_sitedir}/_ldns.so*
204%{py_sitedir}/ldns.py[co]
205%{py_sitedir}/ldnsx.py[co]
f831bab4 206%endif
22a1a36d
JB
207
208%files -n drill
209%defattr(644,root,root,755)
210%attr(755,root,root) %{_bindir}/drill
211%{_mandir}/man1/drill.1*
ac1def33
AO
212
213%files tools
214%defattr(644,root,root,755)
215%attr(755,root,root) %{_bindir}/ldns-chaos
216%attr(755,root,root) %{_bindir}/ldns-compare-zones
217%attr(755,root,root) %{_bindir}/ldns-dane
218%attr(755,root,root) %{_bindir}/ldns-dpa
219%attr(755,root,root) %{_bindir}/ldns-gen-zone
220%attr(755,root,root) %{_bindir}/ldns-key2ds
221%attr(755,root,root) %{_bindir}/ldns-keyfetcher
222%attr(755,root,root) %{_bindir}/ldns-keygen
223%attr(755,root,root) %{_bindir}/ldns-mx
224%attr(755,root,root) %{_bindir}/ldns-notify
225%attr(755,root,root) %{_bindir}/ldns-nsec3-hash
226%attr(755,root,root) %{_bindir}/ldns-read-zone
227%attr(755,root,root) %{_bindir}/ldns-resolver
228%attr(755,root,root) %{_bindir}/ldns-revoke
229%attr(755,root,root) %{_bindir}/ldns-rrsig
230%attr(755,root,root) %{_bindir}/ldns-signzone
231%attr(755,root,root) %{_bindir}/ldns-test-edns
232%attr(755,root,root) %{_bindir}/ldns-testns
233%attr(755,root,root) %{_bindir}/ldns-update
234%attr(755,root,root) %{_bindir}/ldns-verify-zone
235%attr(755,root,root) %{_bindir}/ldns-version
236%attr(755,root,root) %{_bindir}/ldns-walk
237%attr(755,root,root) %{_bindir}/ldns-zcat
238%attr(755,root,root) %{_bindir}/ldns-zsplit
239%attr(755,root,root) %{_bindir}/ldnsd
240%{_mandir}/man1/ldns-chaos.1*
241%{_mandir}/man1/ldns-compare-zones.1*
242%{_mandir}/man1/ldns-dane.1*
243%{_mandir}/man1/ldns-dpa.1*
244%{_mandir}/man1/ldns-gen-zone.1*
245%{_mandir}/man1/ldns-key2ds.1*
246%{_mandir}/man1/ldns-keyfetcher.1*
247%{_mandir}/man1/ldns-keygen.1*
248%{_mandir}/man1/ldns-mx.1*
249%{_mandir}/man1/ldns-notify.1*
250%{_mandir}/man1/ldns-nsec3-hash.1*
251%{_mandir}/man1/ldns-read-zone.1*
252%{_mandir}/man1/ldns-resolver.1*
253%{_mandir}/man1/ldns-revoke.1*
254%{_mandir}/man1/ldns-rrsig.1*
255%{_mandir}/man1/ldns-signzone.1*
256%{_mandir}/man1/ldns-test-edns.1*
257%{_mandir}/man1/ldns-testns.1*
258%{_mandir}/man1/ldns-update.1*
259%{_mandir}/man1/ldns-verify-zone.1*
260%{_mandir}/man1/ldns-version.1*
261%{_mandir}/man1/ldns-walk.1*
262%{_mandir}/man1/ldns-zcat.1*
263%{_mandir}/man1/ldns-zsplit.1*
264%{_mandir}/man1/ldnsd.1*
This page took 0.113164 seconds and 4 git commands to generate.