]> git.pld-linux.org Git - packages/kf5-threadweaver.git/blame - kf5-threadweaver.spec
- updated to 5.249.0; rel 0.1
[packages/kf5-threadweaver.git] / kf5-threadweaver.spec
CommitLineData
83975b84
WF
1#
2# Conditional build:
3%bcond_with tests # build with tests
558cbf1a 4%define kdeframever 5.249.0
3925adfc 5%define qtver 5.15.2
3bdb5420 6%define kfname threadweaver
e4d028f1
WF
7
8Summary: Helper for multithreaded programming
3bdb5420 9Name: kf5-%{kfname}
558cbf1a
WF
10Version: 5.249.0
11Release: 0.1
e4d028f1
WF
12License: LGPL v2.1+
13Group: X11/Libraries
558cbf1a
WF
14Source0: https://download.kde.org/unstable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15# Source0-md5: 9b4e710a774efb96847a8e33d129e4d3
e4d028f1 16URL: http://www.kde.org/
558cbf1a
WF
17BuildRequires: Qt6Core-devel >= %{qtver}
18BuildRequires: Qt6Test-devel >= %{qtver}
ccb1d1b1 19BuildRequires: cmake >= 3.16
0ab83511 20BuildRequires: kf5-extra-cmake-modules >= %{version}
0cb87ac3 21BuildRequires: ninja
e4d028f1 22BuildRequires: rpmbuild(macros) >= 1.164
026ad4d9
ER
23BuildRequires: tar >= 1:1.22
24BuildRequires: xz
e4d028f1 25BuildRequires: zlib-devel
343db5db 26Requires: kf5-dirs
e4d028f1
WF
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
558cbf1a 29%define qt6dir %{_libdir}/qt6
e4d028f1
WF
30
31%description
32ThreadWeaver is a helper for multithreaded programming. It uses a
33job-based interface to queue tasks and execute them in an efficient
34way.
35
36You simply divide the workload into jobs, state the dependencies
37between the jobs and ThreadWeaver will work out the most efficient way
38of dividing the work between threads within a set of resource limits.
39
40See the information on [use cases](@ref usecases) and [why
41multithreading can help](@ref multithreading), as well as the usage
42section below, for more detailed information.
43
44%package devel
3bdb5420
AM
45Summary: Header files for %{kfname} development
46Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{kfname}
e4d028f1
WF
47Group: X11/Development/Libraries
48Requires: %{name} = %{version}-%{release}
49
50%description devel
3bdb5420 51Header files for %{kfname} development.
e4d028f1
WF
52
53%description devel -l pl.UTF-8
3bdb5420 54Pliki nagłówkowe dla programistów używających %{kfname}.
e4d028f1
WF
55
56%prep
3bdb5420 57%setup -q -n %{kfname}-%{version}
e4d028f1
WF
58
59%build
ccb1d1b1
WF
60%cmake -B build \
61 -G Ninja \
83975b84 62 %{!?with_tests:-DBUILD_TESTING=OFF} \
ccb1d1b1
WF
63 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
64
65%ninja_build -C build
e4d028f1 66
83975b84 67%if %{with tests}
ccb1d1b1 68%ninja_build -C build test
83975b84
WF
69%endif
70
71
e4d028f1
WF
72%install
73rm -rf $RPM_BUILD_ROOT
0cb87ac3 74%ninja_install -C build
e4d028f1
WF
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%post -p /sbin/ldconfig
80%postun -p /sbin/ldconfig
81
82%files
83%defattr(644,root,root,755)
84%doc README.md
558cbf1a
WF
85%ghost %{_libdir}/libKF6ThreadWeaver.so.6
86%attr(755,root,root) %{_libdir}/libKF6ThreadWeaver.so.*.*
e4d028f1
WF
87
88%files devel
89%defattr(644,root,root,755)
558cbf1a
WF
90%{_includedir}/KF6/ThreadWeaver
91%{_libdir}/cmake/KF6ThreadWeaver
92%{_libdir}/libKF6ThreadWeaver.so
This page took 0.349855 seconds and 4 git commands to generate.