]> git.pld-linux.org Git - packages/kernel.git/blame - kernel.spec
- HEAD comes back to life
[packages/kernel.git] / kernel.spec
CommitLineData
a5585a68
AM
1#
2# SEE PLD-doc/maintainers file before you edit this file!!
3#
4# If you define the following as 1, only kernel, -headers and -source
5# packages will be built
6#
7# TODO:
8# - check I2C
9# - fix lirc_sasem (usb api)
10# - update HP-OmniBook patchset (2.6.1-all-in-1.patch)
11# - reiserfs4
12# - update grsecurity patch
13# - update i2o patchset
14# - update software suspend patch
15# - add distcc support (and don't break crossbuild!)
16#
17# Conditional build:
18%bcond_without BOOT # don't build BOOT kernel
19%bcond_without smp # don't build SMP kernel
20%bcond_without up # don't build UP kernel
21%bcond_without source # don't build kernel-source package
22%bcond_without grsec # build without grsec
23%bcond_with pax # enable PaX
24%bcond_with execshield # build without exec-shield
25%bcond_with pramfs # build pramfs support (EXPERIMENTAL)
26%bcond_with verbose # verbose build (V=1)
27%bcond_with preemptive # build preemptive kernel
28%bcond_with fbsplash # build with fbsplash
29%bcond_with swsuspend # build with software suspend v2 (EXPERIMENTAL)
30
31%{?debug:%define with_verbose 1}
32
33# see TODO
34%if %{with grsec}
35%undefine with_grsec
36%endif
37
38%if !%{with grsec}
39%undefine with_pax
40%endif
41
42%ifarch sparc
43# sparc32 is missing important updates from 2.5 cycle - won't build
44%undefine with_smp
45%endif
46%ifarch ia64
47# broken
48%undefine with_up
49%endif
50
51%ifarch i586 i686 pentium3 pentium4 athlon
52%undefine with_BOOT
53%endif
54# temporary as BOOT is not finished yet
55%undefine with_BOOT
56
57## Program required by kernel to work.
58%define _binutils_ver 2.12
59%define _util_linux_ver 2.10o
60%define _module_init_tool_ver 0.9.10
61%define _e2fsprogs_ver 1.29
62%define _jfsutils_ver 1.1.3
63%define _reiserfsprogs_ver 3.6.3
64%define _xfsprogs_ver 2.6.0
65%define _pcmcia_cs_ver 3.1.21
66%define _quota_tools_ver 3.09
67%define _PPP_ver 2.4.0
68%define _isdn4k_utils_ver 3.1pre1
69%define _nfs_utils_ver 1.0.5
70%define _procps_ver 3.2.0
71%define _oprofile_ver 0.5.3
72
73#define _post_ver .1
74%define _post_ver %{nil}
75%define _rel 0.22
76%define _cset 20040914_1622
77%define _apply_cset 1
78
79%define _netfilter_snap 20040629
80
81%define _enable_debug_packages 0
82%define no_install_post_strip 1
83%define no_install_post_chrpath 1
84
85%define pcmcia_version 3.1.22
86%define drm_xfree_version 4.3.0
87#define pwc_version 9.0.2
88
89Summary: The Linux kernel (the core of the Linux operating system)
90Summary(de): Der Linux-Kernel (Kern des Linux-Betriebssystems)
91Summary(fr): Le Kernel-Linux (La partie centrale du systeme)
92