]> git.pld-linux.org Git - packages/ixion.git/blame - ixion.spec
- up to 0.12.2
[packages/ixion.git] / ixion.spec
CommitLineData
fb44557a
JB
1#
2# Conditional build:
3%bcond_without static_libs # static library
4fca7b80 4
fb44557a
JB
5Summary: Generic formula compulation library
6Summary(pl.UTF-8): Ogólna biblioteka do obliczania wzorów
7Name: ixion
006c23a2
AM
8Version: 0.12.2
9Release: 1
0885abe8 10License: MPL v2.0
fb44557a 11Group: Libraries
ef81fbd2 12#Source0Download: https://gitlab.com/ixion/ixion
0885abe8 13Source0: http://kohei.us/files/ixion/src/libixion-%{version}.tar.xz
006c23a2 14# Source0-md5: 50873fec72f7f74bb0c0c216ee092d32
0885abe8 15Patch0: %{name}-flags.patch
ef81fbd2 16URL: https://gitlab.com/ixion/ixion
b8fb894e 17BuildRequires: autoconf >= 2.63
f369ddf3 18BuildRequires: automake >= 1:1.11
fb44557a 19BuildRequires: boost-devel >= 1.36
0885abe8 20BuildRequires: libstdc++-devel >= 6:4.7
940f72a8 21BuildRequires: libtool >= 2:2
0885abe8 22BuildRequires: mdds-devel >= 1.2.0
4fca7b80 23BuildRequires: pkgconfig
9c6a3add
JB
24BuildRequires: python3 >= 1:3.4
25BuildRequires: python3-devel >= 1:3.4
ef81fbd2
JB
26BuildRequires: tar >= 1:1.22
27BuildRequires: xz
fb44557a
JB
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
9c6a3add
JB
30# __once_call, __once_callable non-function symbols
31%define skip_post_check_so libixion-0.12.so.*
32
fb44557a
JB
33%description
34Ixion aims to provide a library for calculating the results of formula
35expressions stored in multiple named targets, or "cells". The cells
36can be referenced from each other, and the library takes care of
37resolving their dependencies automatically upon calculation. The
38caller can run the calculation routine either in a single-threaded
39mode, or a multi-threaded mode. The library also supports
40re-calculation where the contents of one or more cells have been
41modified since the last calculation, and a partial calculation of only
42the affected cells gets performed. It is written entirely in C++, and
43makes extensive use of the boost library to achieve portability across
44different platforms.
45
46%description -l pl.UTF-8
47Projekt Ixion ma na celu dostarczenie biblioteki do obliczania wyników
48wyrażeń określonych wzorami zapisanymi w wielu nazwanych miejscach -
49"komórkach". Komórki mogą odwoływać się do siebie nawzajem, a
50biblioteka dba o automatyczne rozwiązywanie ich zależności przy
51obliczeniach. Procedura obliczająca może być wywołana w trybie
52jednowątkowym lub wielowątkowym. Biblioteka obsługuje także ponowne
53przeliczanie w przypadku zmiany zawartości jednej lub większej liczby
54komórek od poprzednich obliczeń; wykonywane jest tylko przeliczanie
55komórek, których zmiana dotyczy. Biblioteka jest napisana całkowicie w
56C++ i intensywnie wykorzystuje bibliotekę boost, aby osiągnąć
57przenośność na wiele platform.
58
59%package devel
60Summary: Development files for ixion
61Summary(pl.UTF-8): Pliki nagłówkowe dla ixion
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64Requires: boost-devel >= 1.36
65Requires: libstdc++-devel
0885abe8 66Requires: mdds-devel >= 1.2.0
fb44557a
JB
67
68%description devel
69This package contains the header files for developing applications
70that use ixion.
71
72%description devel -l pl.UTF-8
73Pen pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
74ixion.
75
76%package static
77Summary: Static ixion library
78Summary(pl.UTF-8): Statyczna biblioteka ixion
79Group: Development/Libraries
80Requires: %{name}-devel = %{version}-%{release}
81
82%description static
83Static ixion library.
84
85%description static -l pl.UTF-8
86Statyczna biblioteka ixion.
87
0885abe8
JB
88%package -n python3-ixion
89Summary: Python 3 interface to ixion library
90Summary(pl.UTF-8): Interfejs Pythona 3 do biblioteki ixion
ef81fbd2
JB
91Group: Libraries/Python
92Requires: %{name} = %{version}-%{release}
9c6a3add 93Requires: python3-libs >= 1:3.4
0885abe8
JB
94# python 2 is no longer supported
95Obsoletes: python-ixion
ef81fbd2 96
0885abe8
JB
97%description -n python3-ixion
98Python 3 interface to ixion library.
ef81fbd2 99
0885abe8
JB
100%description -n python3-ixion -l pl.UTF-8
101Interfejs Pythona 3 do biblioteki ixion.
ef81fbd2 102
fb44557a 103%prep
0885abe8 104%setup -q -n libixion-%{version}
70d27115 105%patch0 -p1
fb44557a
JB
106
107%build
b8fb894e
JB
108%{__libtoolize}
109%{__aclocal} -I m4
110%{__autoconf}
111%{__automake}
fb44557a 112%configure \
940f72a8
JB
113 --disable-silent-rules \
114 %{?with_static_libs:--enable-static}
fb44557a
JB
115
116%{__make}
117
118
119%install
120rm -rf $RPM_BUILD_ROOT
121%{__make} install \
122 DESTDIR=$RPM_BUILD_ROOT
123
0885abe8 124%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/ixion.la
ef81fbd2 125%if %{with static_libs}
0885abe8 126%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/ixion.a
ef81fbd2 127%endif
fb44557a
JB
128# obsoleted by pkg-config
129%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134%post -p /sbin/ldconfig
135%postun -p /sbin/ldconfig
136
137%files
138%defattr(644,root,root,755)
44043c57 139%doc AUTHORS ChangeLog LICENSE README
fb44557a
JB
140%attr(755,root,root) %{_bindir}/ixion-parser
141%attr(755,root,root) %{_bindir}/ixion-sorter
9c6a3add
JB
142%attr(755,root,root) %{_libdir}/libixion-0.12.so.*.*.*
143%attr(755,root,root) %ghost %{_libdir}/libixion-0.12.so.0
fb44557a
JB
144
145%files devel
146%defattr(644,root,root,755)
9c6a3add
JB
147%attr(755,root,root) %{_libdir}/libixion-0.12.so
148%{_includedir}/libixion-0.12
149%{_pkgconfigdir}/libixion-0.12.pc
fb44557a
JB
150
151%if %{with static_libs}
152%files static
153%defattr(644,root,root,755)
9c6a3add 154%{_libdir}/libixion-0.12.a
fb44557a 155%endif
ef81fbd2 156
0885abe8 157%files -n python3-ixion
ef81fbd2 158%defattr(644,root,root,755)
0885abe8 159%attr(755,root,root) %{py3_sitedir}/ixion.so
This page took 0.080017 seconds and 4 git commands to generate.