]> git.pld-linux.org Git - packages/thunderbird.git/blame - icedove.spec
- added sh patch (fixes argumentless for taking last positional args)
[packages/thunderbird.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - build with system mozldap
c4ddd260 4#
44be9ed4 5# Conditional builds
6%bcond_without enigmail # don't build enigmail - GPG/PGP support
44be9ed4 7%bcond_without ldap # disable e-mail address lookups in LDAP directories
e820c55e 8%bcond_without lightning # disable Sunbird/Lightning calendar
fac7e24d 9%bcond_with xulrunner # system xulrunner
765a3a27 10%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 11
f4114a7f 12%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
13%undefine crashreporter
14%endif
15
d0b96b40 16%define enigmail_ver 1.6
9c1b9ad4 17%define nspr_ver 4.9.3
d0b96b40 18%define nss_ver 3.15.3.1
44be9ed4 19
d0b96b40 20%define xulrunner_ver 2:24.0
4f34f106 21
7d981f69
ER
22%if %{without xulrunner}
23# The actual sqlite version (see RHBZ#480989):
24%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
25%endif
26
44be9ed4 27Summary: Icedove - email client
28Summary(pl.UTF-8): Icedove - klient poczty
29Name: icedove
bc85e07e 30Version: 24.5.0
d63413d4 31Release: 1
44be9ed4 32License: MPL 1.1 or GPL v2+ or LGPL v2.1+
2d289b25 33Group: X11/Applications/Mail
cadfb931 34Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
bc85e07e 35# Source0-md5: dbe164c48e42c04b4959910eda2e52ca
44be9ed4 36Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
d0b96b40 37# Source1-md5: 4a2bbcb020bdb282a660fda8c70d5608
44be9ed4 38Source2: %{name}-branding.tar.bz2
d0b96b40 39# Source2-md5: d8e6897870bf288fdf264c0e9ef85f7d
44be9ed4 40Source3: %{name}-rm_nonfree.sh
41Source4: %{name}.desktop
42Source5: %{name}.sh
44be9ed4 43Patch0: %{name}-branding.patch
faa5c89d 44Patch1: %{name}-enigmail-shared.patch
b3ab192f 45Patch2: %{name}-sh.patch
faa5c89d 46Patch3: %{name}-fonts.patch
faa5c89d 47Patch6: %{name}-prefs.patch
9a743685 48Patch7: system-mozldap.patch
a85e0ecb 49Patch8: %{name}-makefile.patch
ccc206fe 50Patch10: %{name}-extensiondir.patch
765a3a27 51Patch11: crashreporter.patch
268e7766 52Patch12: no-subshell.patch
03be87a5
JR
53# Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
54Patch13: system-virtualenv.patch
13ed8387 55Patch14: gyp-slashism.patch
d0b96b40 56Patch15: enable-addons.patch
5745d706 57URL: http://www.pld-linux.org/Packages/Icedove
6458b220 58BuildRequires: GConf2-devel >= 1.2.1
51a3b6db 59BuildRequires: alsa-lib-devel
44be9ed4 60BuildRequires: automake
51a3b6db 61BuildRequires: bzip2-devel
e820c55e
JB
62BuildRequires: cairo-devel >= 1.10
63BuildRequires: dbus-glib-devel >= 0.60
44be9ed4 64BuildRequires: freetype-devel >= 1:2.1.8
6458b220 65BuildRequires: glib2-devel >= 2.0
d0b96b40
JR
66BuildRequires: gstreamer0.10-devel
67BuildRequires: gstreamer0.10-plugins-base-devel
e820c55e 68BuildRequires: gtk+2-devel >= 2:2.10.0
5e9bb798 69BuildRequires: hunspell-devel
44be9ed4 70BuildRequires: libIDL-devel >= 0.8.0
d0b96b40 71BuildRequires: libevent-devel
51a3b6db 72BuildRequires: libiw-devel
e82da7a1 73# requires libjpeg-turbo implementing at least libjpeg 6b API
44be9ed4 74BuildRequires: libjpeg-devel >= 6b
e82da7a1 75BuildRequires: libjpeg-turbo-devel
51a3b6db 76BuildRequires: libnotify-devel >= 0.4
e820c55e 77BuildRequires: libpng-devel >= 1.4.1
44be9ed4 78BuildRequires: libstdc++-devel
d0b96b40 79BuildRequires: mozldap-devel
f4114a7f
ER
80BuildRequires: nspr-devel >= 1:%{nspr_ver}
81BuildRequires: nss-devel >= 1:%{nss_ver}
3815090b 82BuildRequires: pango-devel >= 1:1.14.0
e820c55e 83BuildRequires: perl-base >= 1:5.6
d0b96b40 84BuildRequires: python-virtualenv
1c62cadb 85BuildRequires: pkgconfig
e820c55e 86BuildRequires: python >= 1:2.5
44be9ed4 87BuildRequires: sed >= 4.0
9d1bfad8 88BuildRequires: sqlite3-devel >= 3.7.4
1c62cadb 89BuildRequires: startup-notification-devel >= 0.8
d0b96b40 90BuildRequires: libvpx-devel >= 1.0.0
44be9ed4 91BuildRequires: xorg-lib-libXext-devel
44be9ed4 92BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 93BuildRequires: xorg-lib-libXt-devel
5745d706 94BuildRequires: yasm
1c62cadb 95BuildRequires: zip
7d981f69 96%if %{with xulrunner}
e8326f77 97BuildRequires: xulrunner-devel >= %{xulrunner_ver}
7d981f69 98%else
44be9ed4 99Requires: myspell-common
f4114a7f
ER
100Requires: nspr >= 1:%{nspr_ver}
101Requires: nss >= 1:%{nss_ver}
4b6bc367 102Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 103%endif
4f34f106
ER
104Requires(post): mktemp >= 1.5-18
105%if %{with xulrunner}
106%requires_eq_to xulrunner xulrunner-devel
107%endif
e82da7a1 108Requires: libjpeg-turbo
44be9ed4 109Obsoletes: mozilla-thunderbird
110Obsoletes: mozilla-thunderbird-dictionary-en-US
d606e9b3 111Conflicts: icedove-lang-resources < %{version}
44be9ed4 112BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
9e366f18
AM
114%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
115
44be9ed4 116# iceweasel/icedove/iceape provide their own versions
44be9ed4 117%define _noautoprovfiles %{_libdir}/%{name}/components
fb7d4f06
JB
118%if %{without xulrunner}
119# we don't want these to satisfy packages depending on xulrunner
120%define _noautoprov libmozalloc.so libxpcom.so libxul.so
44be9ed4 121# and as we don't provide them, don't require either
fb7d4f06
JB
122%define _noautoreq libmozalloc.so libxpcom.so libxul.so
123%endif
44be9ed4 124
9e7875fc
ER
125%define topdir %{_builddir}/%{name}-%{version}
126%define objdir %{topdir}/obj-%{_target_cpu}
127
44be9ed4 128%description
6b327de6 129Icedove is an open-source, fast and portable email client.
44be9ed4 130
131%description -l pl.UTF-8
6b327de6
JB
132Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
133poczty.
44be9ed4 134
6578c165 135%package addon-lightning
136Summary: An integrated calendar for Icedove
137Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
138License: MPL 1.1 or GPL v2+ or LGPL v2.1+
139Group: Applications/Networking
140Requires: %{name} = %{version}-%{release}
141
142%description addon-lightning
143Lightning is an calendar extension to Icedove email client.
144
145%description addon-lightning -l pl.UTF-8
146Lightning to rozszerzenie do klienta poczty Icedove dodające
147funkcjonalność kalendarza.
148
44be9ed4 149%package addon-enigmail
150Summary: Extension for the authentication and encryption features provided by GnuPG
151Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
152License: MPL/LGPL
153Group: Applications/Networking
154URL: http://enigmail.mozdev.org/
cd056caa 155Requires: %{name} = %{version}-%{release}
d076d93e 156Requires: gnupg
75991bbb 157Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 158
159%description addon-enigmail
c5e06599 160Enigmail is an extension to the Icedove mail client which allows users
161to access the authentication and encryption features provided by
162GnuPG.
44be9ed4 163
164Main Features:
165- Encrypt/sign mail when sending, decrypt/authenticate received mail
166- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
167- Per-Account based encryption and signing defaults
168- Per-Recipient rules for automated key selection, and
169 enabling/disabling encryption and signing
170- OpenPGP key management interface
171
172%description addon-enigmail -l pl.UTF-8
c5e06599 173Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
174użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
175przez GnuPG.
44be9ed4 176
177Główne możliwości:
178- szyfrowanie/podpisywanie poczty przy wysyłaniu,
179 odszyfrowywanie/uwierzytelnianie poczty odebranej
180- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
181- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
182- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
183 podpisywania dla każdego adresata
184- interfejs do zarządzania kluczami OpenPGP
185
186%prep
983562b1 187%setup -qc
d0b96b40 188mv comm-esr24 mozilla
983562b1 189%setup -q -T -D -a2
190cd mozilla
1c70899a 191%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
44be9ed4 192/bin/sh %{SOURCE3}
983562b1 193%patch0 -p1
faa5c89d 194%{?with_enigmail:%patch1 -p1}
b3ab192f 195%patch2 -p1
4ccc2157 196%patch3 -p1
983562b1 197%patch6 -p1
9a743685 198%patch7 -p1
f4114a7f 199%patch8 -p2
ccc206fe 200%patch10 -p2
d0b96b40 201#patch11 -p2
268e7766 202%patch12 -p1
03be87a5 203%patch13 -p1
13ed8387 204%patch14 -p1
d0b96b40
JR
205%patch15 -p1
206
207# the entire check in that configure is so wrong, it's simpler to just workaround it here temporarily
208%{__sed} -i -e 's|min_nss_version=3.15.3.1|min_nss_version=3.15.3|' mozilla/configure
44be9ed4 209
210%build
983562b1 211cd mozilla
cadfb931
SP
212cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
213cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
f4114a7f 214cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
44be9ed4 215
fbac75ca 216cat << EOF > .mozconfig
9e7875fc 217mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 218
fac7e24d 219export CFLAGS="%{rpmcflags}"
73d54cb2 220export CXXFLAGS="%{rpmcflags}"
765a3a27
ER
221
222%if %{with crashreporter}
223export MOZ_DEBUG_SYMBOLS=1
224%endif
225
59c5a0e8 226# Options for 'configure' (same as command-line options).
44be9ed4 227ac_add_options --prefix=%{_prefix}
228ac_add_options --exec-prefix=%{_exec_prefix}
229ac_add_options --bindir=%{_bindir}
230ac_add_options --sbindir=%{_sbindir}
231ac_add_options --sysconfdir=%{_sysconfdir}
232ac_add_options --datadir=%{_datadir}
233ac_add_options --includedir=%{_includedir}
234ac_add_options --libdir=%{_libdir}
235ac_add_options --libexecdir=%{_libexecdir}
236ac_add_options --localstatedir=%{_localstatedir}
237ac_add_options --sharedstatedir=%{_sharedstatedir}
238ac_add_options --mandir=%{_mandir}
239ac_add_options --infodir=%{_infodir}
240%if %{?debug:1}0
59c5a0e8 241ac_add_options --disable-optimize
44be9ed4 242ac_add_options --enable-debug
243ac_add_options --enable-debug-modules
59c5a0e8
SP
244ac_add_options --enable-debugger-info-modules
245ac_add_options --enable-crash-on-assert
44be9ed4 246%else
247ac_add_options --disable-debug
248ac_add_options --disable-debug-modules
59c5a0e8
SP
249ac_add_options --disable-logging
250ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 251%endif
88149483
ER
252ac_add_options --disable-strip
253ac_add_options --disable-strip-libs
44be9ed4 254%if %{with tests}
255ac_add_options --enable-tests
256%else
257ac_add_options --disable-tests
258%endif
6458b220 259ac_add_options --enable-gio
44be9ed4 260ac_add_options --disable-gnomeui
44be9ed4 261ac_add_options --disable-gnomevfs
44be9ed4 262%if %{with ldap}
263ac_add_options --enable-ldap
9a743685 264ac_add_options --with-system-ldap
44be9ed4 265%else
266ac_add_options --disable-ldap
267%endif
765a3a27
ER
268%if %{with crashreporter}
269ac_add_options --enable-crashreporter
270%else
59c5a0e8 271ac_add_options --disable-crashreporter
765a3a27 272%endif
59c5a0e8 273ac_add_options --disable-xterm-updates
59c5a0e8 274ac_add_options --enable-postscript
d076d93e 275%if %{with lightning}
cb0e4412 276ac_add_options --enable-calendar
d076d93e
SP
277%else
278ac_add_options --disable-calendar
279%endif
d0b96b40 280ac_add_options --disable-elf-dynstr-gc
44be9ed4 281ac_add_options --disable-installer
d0b96b40 282ac_add_options --disable-javaxpcom
88149483 283ac_add_options --disable-updater
44be9ed4 284ac_add_options --enable-crypto
d0b96b40 285ac_add_options --enable-libxul
44be9ed4 286ac_add_options --enable-pango
d0b96b40 287ac_add_options --enable-shared-js
88149483 288ac_add_options --enable-startup-notification
44be9ed4 289ac_add_options --enable-system-cairo
5e9bb798 290ac_add_options --enable-system-hunspell
7d981f69 291ac_add_options --enable-system-sqlite
cadfb931 292ac_add_options --enable-application=mail
88149483
ER
293ac_add_options --with-distribution-id=org.pld-linux
294ac_add_options --with-branding=icedove/branding
295%if %{with xulrunner}
f4114a7f 296ac_add_options --with-system-libxul
d0b96b40 297ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
88149483
ER
298%endif
299ac_add_options --with-pthreads
300ac_add_options --with-system-bz2
d0b96b40 301ac_add_options --with-system-ffi
44be9ed4 302ac_add_options --with-system-jpeg
d0b96b40
JR
303ac_add_options --with-system-libevent
304ac_add_options --with-system-libvpx
44be9ed4 305ac_add_options --with-system-nspr
306ac_add_options --with-system-nss
307ac_add_options --with-system-png
308ac_add_options --with-system-zlib
44be9ed4 309ac_add_options --enable-single-profile
310ac_add_options --disable-profilesharing
44be9ed4 311ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
312EOF
313
d0b96b40
JR
314mkdir -p %{objdir}/config
315ln -s %{topdir}/mozilla/config/*.mk %{objdir}/config
316
90e998ba 317%{__make} -j1 -f client.mk build \
d076d93e 318 STRIP="/bin/true" \
765a3a27 319 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d0b96b40 320 installdir=%{_libdir}/%{name} \
de09c00d 321 XLIBS="-lX11 -lXt" \
d076d93e 322 CC="%{__cc}" \
44be9ed4 323 CXX="%{__cxx}"
324
765a3a27
ER
325%if %{with crashreporter}
326# create debuginfo for crash-stats.mozilla.com
327%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
328%endif
329
44be9ed4 330%if %{with enigmail}
59c5a0e8 331cd mailnews/extensions/enigmail
9e7875fc 332./makemake -r -o %{objdir}
d0b96b40 333%{__make} -j1 -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
334 STRIP="/bin/true" \
335 CC="%{__cc}" \
336 CXX="%{__cxx}"
916d4050 337
d0b96b40 338%{__make} -j1 -C %{objdir}/mailnews/extensions/enigmail xpi \
916d4050
JR
339 STRIP="/bin/true" \
340 CC="%{__cc}" \
341 CXX="%{__cxx}"
44be9ed4 342%endif
343
344%install
345rm -rf $RPM_BUILD_ROOT
765a3a27 346install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 347
9e7875fc 348cd %{objdir}
ecf04393 349%{__make} -C mail/installer stage-package \
44be9ed4 350 DESTDIR=$RPM_BUILD_ROOT \
d0b96b40 351 installdir=%{_libdir}/%{name} \
44be9ed4 352 PKG_SKIP_STRIP=1
353
d0b96b40
JR
354%{__make} -C icedove/branding install \
355 DESTDIR=$RPM_BUILD_ROOT
356
357cp -a mozilla/dist/icedove/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
358
9b40a2c3
JB
359%if %{with xulrunner}
360# needed to find mozilla runtime
361ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
362%endif
363
364# Enable crash reporter for Thunderbird application
765a3a27
ER
365%if %{with crashreporter}
366%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
367
368# Add debuginfo for crash-stats.mozilla.com
51a3b6db 369install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
370cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
371%endif
372
ecf04393 373# copy manually lightning files, somewhy they are not installed by make
d0b96b40 374cp -a mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
ecf04393
ER
375 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
376
44be9ed4 377# move arch independant ones to datadir
eca54e0f 378mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
eca54e0f 379ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
44be9ed4 380
c6ec3c1c
ER
381# dir for arch independant extensions besides arch dependant extensions
382# see mozilla/xpcom/build/nsXULAppAPI.h
383# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
384install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
385
73d54cb2 386%if %{without xulrunner}
63d8f5c3 387%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 388ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
73d54cb2 389%endif
e6bc19b3 390
0889474f
JR
391%{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
392 -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
393 %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
394
44be9ed4 395%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
396ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
397ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
398
d0b96b40 399# install icons and desktop file
52f5507d 400cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
d0b96b40
JR
401for i in 16 32 48 64 128 256; do
402 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
403 cp -a %{topdir}/mozilla/icedove/branding/icedove${i}.png \
404 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/icedove.png
405done
406install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps
407cp -a %{topdir}/mozilla/icedove/branding/icedove.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/icedove.svg
408
409cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
44be9ed4 410
e8f4ba81 411# files created by regxpcom -register in post
52fc61e6
ER
412touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
413touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
414cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
415#!/bin/sh
416umask 022
417# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
418# dangerous if you run this with sudo with keep_env += HOME
419# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
420t=$(mktemp -d)
d50a2a28 421%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
422TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
423rm -rf $t
424EOF
425chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 426
44be9ed4 427%if %{with enigmail}
283702b9 428ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
916d4050 429install -d $ext_dir/{chrome,components,defaults/preferences,modules}
52fc61e6 430cd mozilla/dist/bin
916d4050 431cp -rfLp chrome/enigmail.jar $ext_dir/chrome
52fc61e6 432cp -rfLp components/enig* $ext_dir/components
52fc61e6 433cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
de09c00d 434cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
916d4050 435cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
52fc61e6 436cd -
52f5507d
ER
437cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
438cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 439%endif
440
283702b9 441# mozldap
d0b96b40
JR
442%{__sed} -i '/lib\(ldap\|ldif\|prldap\)60.so/d' $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
443%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap}60.so
283702b9 444
44be9ed4 445%clean
446rm -rf $RPM_BUILD_ROOT
447
448%pretrans
449if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
450 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
451fi
eca54e0f 452for d in chrome defaults icons isp modules res searchplugins; do
44be9ed4 453 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
454 install -d %{_datadir}/%{name}
455 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
456 fi
457done
458exit 0
459
e8f4ba81
ER
460%post
461%{_libdir}/%{name}/register || :
462
44be9ed4 463%files
464%defattr(644,root,root,755)
465%attr(755,root,root) %{_bindir}/icedove
466%attr(755,root,root) %{_bindir}/mozilla-thunderbird
467%attr(755,root,root) %{_bindir}/thunderbird
468%dir %{_libdir}/%{name}
765a3a27 469%{_libdir}/%{name}/application.ini
6b327de6
JB
470%{_libdir}/%{name}/blocklist.xml
471%{_libdir}/%{name}/chrome.manifest
44be9ed4 472%dir %{_libdir}/%{name}/components
6b327de6 473%{_libdir}/%{name}/components/components.manifest
73d54cb2
JB
474%attr(755,root,root) %{_libdir}/%{name}/*.sh
475%attr(755,root,root) %{_libdir}/%{name}/*-bin
476%attr(755,root,root) %{_libdir}/%{name}/icedove
477%attr(755,root,root) %{_libdir}/%{name}/register
d0b96b40 478%{_libdir}/%{name}/omni.ja
73d54cb2 479%if %{without xulrunner}
a367af64 480%{_libdir}/%{name}/dependentlibs.list
73d54cb2 481%{_libdir}/%{name}/platform.ini
d0b96b40 482#%{_libdir}/%{name}/greprefs.js
73d54cb2 483%attr(755,root,root) %{_libdir}/%{name}/components/*.so
0516fc42 484%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
d0b96b40 485%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
0516fc42 486%attr(755,root,root) %{_libdir}/%{name}/libxul.so
44be9ed4 487%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
cf62736e 488%attr(755,root,root) %{_libdir}/%{name}/plugin-container
73d54cb2 489%endif
44be9ed4 490
491# symlinks
492%{_libdir}/%{name}/chrome
493%{_libdir}/%{name}/defaults
44be9ed4 494%{_libdir}/%{name}/isp
d0b96b40 495#%{_libdir}/%{name}/modules
eca54e0f 496%{_libdir}/%{name}/searchplugins
9b40a2c3
JB
497%if %{with xulrunner}
498%{_libdir}/%{name}/xulrunner
499%else
73d54cb2 500%{_libdir}/%{name}/dictionaries
73d54cb2 501%endif
44be9ed4 502
224cf96a
JB
503%{_pixmapsdir}/icedove.png
504%{_desktopdir}/icedove.desktop
44be9ed4 505
506%dir %{_datadir}/%{name}
eca54e0f 507%{_datadir}/%{name}/extensions
eca54e0f 508%{_datadir}/%{name}/searchplugins
44be9ed4 509
765a3a27
ER
510%if %{with crashreporter}
511%attr(755,root,root) %{_libdir}/%{name}/crashreporter
512%{_libdir}/%{name}/crashreporter.ini
513%{_libdir}/%{name}/Throbber-small.gif
514%endif
515
44be9ed4 516%dir %{_libdir}/%{name}/extensions
517%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 518
52fc61e6
ER
519# files created by regxpcom -register
520%ghost %{_libdir}/%{name}/components/compreg.dat
521%ghost %{_libdir}/%{name}/components/xpti.dat
522
d0b96b40
JR
523%{_iconsdir}/hicolor/*/apps/icedove.*
524
6578c165 525%if %{with lightning}
526%files addon-lightning
527%defattr(644,root,root,755)
f3b6d696 528%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
cf62736e 529%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
f3b6d696
ER
530%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
531%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
cf62736e 532%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
f3b6d696
ER
533%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
534%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
535%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
f3b6d696 536%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
cf62736e
JB
537%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
538%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
f3b6d696
ER
539%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
540%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
541%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
6578c165 542%endif
44be9ed4 543
544%if %{with enigmail}
545%files addon-enigmail
546%defattr(644,root,root,755)
f6a43e2f
ER
547%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
548%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
549%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
550%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
551%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
552%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
f6a43e2f
ER
553%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
554%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
916d4050
JR
555%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
556%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
557%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
44be9ed4 558%endif
This page took 0.181171 seconds and 4 git commands to generate.