]> git.pld-linux.org Git - packages/thunderbird.git/blame - icedove.spec
- fix building with libpng
[packages/thunderbird.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - fix icedove (building) and installing nss/nspr libs!
283702b9 4# - build with system mozldap
c4ddd260 5#
44be9ed4 6# Conditional builds
7%bcond_without enigmail # don't build enigmail - GPG/PGP support
8%bcond_without gnomeui # disable gnomeui support
9%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
10%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
11%bcond_without ldap # disable e-mail address lookups in LDAP directories
6578c165 12%bcond_without lightning # disable sunbird calendar
88149483
ER
13%bcond_with xulrunner # build with system xulrunner
14
44be9ed4 15%if %{without gnome}
16%undefine with_gnomeui
17%undefine with_gnomevfs
18%endif
88149483 19
f4aadbdb 20%define enigmail_ver 1.1.2
44be9ed4 21
7d981f69
ER
22%if %{without xulrunner}
23# The actual sqlite version (see RHBZ#480989):
24%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
25%endif
26
44be9ed4 27Summary: Icedove - email client
28Summary(pl.UTF-8): Icedove - klient poczty
29Name: icedove
a85e0ecb 30Version: 3.1
31Release: 0.1
44be9ed4 32License: MPL 1.1 or GPL v2+ or LGPL v2.1+
33Group: Applications/Networking
cadfb931 34Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
a85e0ecb 35# Source0-md5: feb4d737d568066076879a09bd0d506e
44be9ed4 36Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
f4aadbdb 37# Source1-md5: 7d329d5e8afbbb28214ca1995beb09c9
44be9ed4 38Source2: %{name}-branding.tar.bz2
6578c165 39# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
44be9ed4 40Source3: %{name}-rm_nonfree.sh
41Source4: %{name}.desktop
42Source5: %{name}.sh
2f151de0 43Source6: %{name}-enigmail.manifest
44be9ed4 44Patch0: %{name}-branding.patch
faa5c89d
SP
45Patch1: %{name}-enigmail-shared.patch
46Patch2: %{name}-gcc.patch
47Patch3: %{name}-fonts.patch
48Patch4: %{name}-install.patch
5e9bb798 49Patch5: %{name}-hunspell.patch
faa5c89d 50Patch6: %{name}-prefs.patch
9a743685 51Patch7: system-mozldap.patch
a85e0ecb 52Patch8: %{name}-makefile.patch
4922c320 53URL: http://www.pld-linux.org/Packages/Icedove
44be9ed4 54%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
55BuildRequires: automake
56BuildRequires: freetype-devel >= 1:2.1.8
57%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
58BuildRequires: gtk+2-devel >= 1:2.0.0
5e9bb798 59BuildRequires: hunspell-devel
44be9ed4 60BuildRequires: libIDL-devel >= 0.8.0
61%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
62%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
63BuildRequires: libjpeg-devel >= 6b
64BuildRequires: libpng-devel >= 1.2.0
65BuildRequires: libstdc++-devel
cadfb931
SP
66BuildRequires: nspr-devel >= 1:4.8
67BuildRequires: nss-devel >= 1:3.12.0
44be9ed4 68BuildRequires: pango-devel >= 1:1.1.0
1c62cadb 69BuildRequires: pkgconfig
44be9ed4 70BuildRequires: sed >= 4.0
4b6bc367 71BuildRequires: sqlite3-devel >= 3.6.22
1c62cadb 72BuildRequires: startup-notification-devel >= 0.8
44be9ed4 73BuildRequires: xorg-lib-libXext-devel
44be9ed4 74BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 75BuildRequires: xorg-lib-libXt-devel
1c62cadb 76BuildRequires: zip
7d981f69
ER
77%if %{with xulrunner}
78%else
44be9ed4 79Requires: myspell-common
80Requires: nspr >= 1:4.6.1
81Requires: nss >= 1:3.11.3
4b6bc367 82Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 83%endif
44be9ed4 84Obsoletes: mozilla-thunderbird
85Obsoletes: mozilla-thunderbird-dictionary-en-US
86BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
87
9e366f18
AM
88%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
89
44be9ed4 90# iceweasel/icedove/iceape provide their own versions
91%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
92%define _noautoprovfiles %{_libdir}/%{name}/components
93# we don't want these to satisfy xulrunner-devel
5ac9187e 94%define _noautoprov libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
44be9ed4 95# and as we don't provide them, don't require either
5ac9187e 96%define _noautoreq libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
44be9ed4 97
98%description
99Icedove is an open-source,fast and portable email client.
100
101%description -l pl.UTF-8
102Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
103
6578c165 104%package addon-lightning
105Summary: An integrated calendar for Icedove
106Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
107License: MPL 1.1 or GPL v2+ or LGPL v2.1+
108Group: Applications/Networking
109Requires: %{name} = %{version}-%{release}
110
111%description addon-lightning
112Lightning is an calendar extension to Icedove email client.
113
114%description addon-lightning -l pl.UTF-8
115Lightning to rozszerzenie do klienta poczty Icedove dodające
116funkcjonalność kalendarza.
117
44be9ed4 118%package addon-enigmail
119Summary: Extension for the authentication and encryption features provided by GnuPG
120Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
121License: MPL/LGPL
122Group: Applications/Networking
123URL: http://enigmail.mozdev.org/
cd056caa 124Requires: %{name} = %{version}-%{release}
d076d93e 125Requires: gnupg
75991bbb 126Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 127
128%description addon-enigmail
c5e06599 129Enigmail is an extension to the Icedove mail client which allows users
130to access the authentication and encryption features provided by
131GnuPG.
44be9ed4 132
133Main Features:
134- Encrypt/sign mail when sending, decrypt/authenticate received mail
135- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
136- Per-Account based encryption and signing defaults
137- Per-Recipient rules for automated key selection, and
138 enabling/disabling encryption and signing
139- OpenPGP key management interface
140
141%description addon-enigmail -l pl.UTF-8
c5e06599 142Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
143użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
144przez GnuPG.
44be9ed4 145
146Główne możliwości:
147- szyfrowanie/podpisywanie poczty przy wysyłaniu,
148 odszyfrowywanie/uwierzytelnianie poczty odebranej
149- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
150- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
151- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
152 podpisywania dla każdego adresata
153- interfejs do zarządzania kluczami OpenPGP
154
155%prep
983562b1 156%setup -qc
a85e0ecb 157mv -f comm-1.9.2 mozilla
983562b1 158%setup -q -T -D -a2
159cd mozilla
44be9ed4 160%{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
161/bin/sh %{SOURCE3}
983562b1 162%patch0 -p1
faa5c89d
SP
163%{?with_enigmail:%patch1 -p1}
164%patch2 -p1
4ccc2157 165%patch3 -p1
faa5c89d 166%patch4 -p1
5e9bb798 167%patch5 -p1
983562b1 168%patch6 -p1
9a743685 169%patch7 -p1
a85e0ecb 170%patch8 -p0
44be9ed4 171
172%build
983562b1 173cd mozilla
44be9ed4 174export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
175export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
176
cadfb931
SP
177cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
178cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
44be9ed4 179cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
180
9a743685
ER
181install -d libxul-sdk
182ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
9a743685 183
fbac75ca 184cat << EOF > .mozconfig
cb0e4412
SP
185mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
186
59c5a0e8 187# Options for 'configure' (same as command-line options).
44be9ed4 188ac_add_options --prefix=%{_prefix}
189ac_add_options --exec-prefix=%{_exec_prefix}
190ac_add_options --bindir=%{_bindir}
191ac_add_options --sbindir=%{_sbindir}
192ac_add_options --sysconfdir=%{_sysconfdir}
193ac_add_options --datadir=%{_datadir}
194ac_add_options --includedir=%{_includedir}
195ac_add_options --libdir=%{_libdir}
196ac_add_options --libexecdir=%{_libexecdir}
197ac_add_options --localstatedir=%{_localstatedir}
198ac_add_options --sharedstatedir=%{_sharedstatedir}
199ac_add_options --mandir=%{_mandir}
200ac_add_options --infodir=%{_infodir}
201%if %{?debug:1}0
59c5a0e8 202ac_add_options --disable-optimize
44be9ed4 203ac_add_options --enable-debug
204ac_add_options --enable-debug-modules
59c5a0e8
SP
205ac_add_options --enable-debugger-info-modules
206ac_add_options --enable-crash-on-assert
44be9ed4 207%else
208ac_add_options --disable-debug
209ac_add_options --disable-debug-modules
59c5a0e8
SP
210ac_add_options --disable-logging
211ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 212%endif
88149483
ER
213ac_add_options --disable-strip
214ac_add_options --disable-strip-libs
44be9ed4 215%if %{with tests}
216ac_add_options --enable-tests
217%else
218ac_add_options --disable-tests
219%endif
220%if %{with gnomeui}
221ac_add_options --enable-gnomeui
222%else
223ac_add_options --disable-gnomeui
224%endif
225%if %{with gnomevfs}
226ac_add_options --enable-gnomevfs
227%else
228ac_add_options --disable-gnomevfs
229%endif
230%if %{with ldap}
231ac_add_options --enable-ldap
9a743685 232ac_add_options --with-system-ldap
44be9ed4 233%else
234ac_add_options --disable-ldap
235%endif
59c5a0e8 236ac_add_options --disable-crashreporter
59c5a0e8 237ac_add_options --disable-xterm-updates
59c5a0e8 238ac_add_options --enable-postscript
d076d93e 239%if %{with lightning}
cb0e4412 240ac_add_options --enable-calendar
d076d93e
SP
241%else
242ac_add_options --disable-calendar
243%endif
44be9ed4 244ac_add_options --disable-installer
245ac_add_options --disable-jsd
88149483 246ac_add_options --disable-updater
44be9ed4 247ac_add_options --disable-xprint
cadfb931
SP
248ac_add_options --disable-permissions
249ac_add_options --disable-pref-extensions
44be9ed4 250ac_add_options --enable-canvas
251ac_add_options --enable-crypto
44be9ed4 252ac_add_options --enable-mathml
44be9ed4 253ac_add_options --enable-pango
254ac_add_options --enable-reorder
88149483
ER
255ac_add_options --enable-startup-notification
256ac_add_options --enable-svg
44be9ed4 257ac_add_options --enable-system-cairo
5e9bb798 258ac_add_options --enable-system-hunspell
7d981f69 259ac_add_options --enable-system-sqlite
44be9ed4 260ac_add_options --enable-xft
cadfb931
SP
261ac_add_options --enable-application=mail
262ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 263ac_add_options --enable-xinerama
88149483
ER
264ac_add_options --with-distribution-id=org.pld-linux
265ac_add_options --with-branding=icedove/branding
266%if %{with xulrunner}
fbac75ca
ER
267ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk
268ac_add_options --enable-shared
269%else
270ac_add_options --enable-static
88149483
ER
271%endif
272ac_add_options --with-pthreads
273ac_add_options --with-system-bz2
44be9ed4 274ac_add_options --with-system-jpeg
275ac_add_options --with-system-nspr
276ac_add_options --with-system-nss
277ac_add_options --with-system-png
278ac_add_options --with-system-zlib
44be9ed4 279ac_add_options --enable-single-profile
280ac_add_options --disable-profilesharing
44be9ed4 281ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
282EOF
283
90e998ba 284%{__make} -j1 -f client.mk build \
d076d93e
SP
285 STRIP="/bin/true" \
286 CC="%{__cc}" \
44be9ed4 287 CXX="%{__cxx}"
288
289%if %{with enigmail}
59c5a0e8 290cd mailnews/extensions/enigmail
d076d93e 291./makemake -r
59c5a0e8 292%{__make} -C ../../../obj-%{_target_cpu}/mailnews/extensions/enigmail \
d076d93e
SP
293 STRIP="/bin/true" \
294 CC="%{__cc}" \
295 CXX="%{__cxx}"
44be9ed4 296%endif
297
298%install
299rm -rf $RPM_BUILD_ROOT
300install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}} \
60c77977
SP
301 $RPM_BUILD_ROOT%{_datadir}/%{name}
302install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
44be9ed4 303
983562b1 304cd mozilla
cb0e4412 305%{__make} -C obj-%{_target_cpu}/mail/installer stage-package \
44be9ed4 306 DESTDIR=$RPM_BUILD_ROOT \
307 MOZ_PKG_APPDIR=%{_libdir}/%{name} \
308 PKG_SKIP_STRIP=1
309
310# move arch independant ones to datadir
311mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
312mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
313mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
44be9ed4 314mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
315mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
316ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
317ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
318ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
44be9ed4 319ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
320ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
321
322rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
323ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
324
325%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
326ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
327ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
328
329install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
330
331%if %{with enigmail}
283702b9
ER
332ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
333install -d $ext_dir/{chrome,components,defaults/preferences}
334mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail.jar $ext_dir/chrome
335mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig* $ext_dir/components
336mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so $ext_dir/components
337mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt $ext_dir/components
338mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences/enigmail.js $ext_dir/defaults/preferences
339cp -f mailnews/extensions/enigmail/package/install.rdf $ext_dir
44be9ed4 340rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences
341rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-en-US.jar
342rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin.jar
343rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmime.jar
344rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig*
345rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so
346rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt
283702b9 347cp -f %{SOURCE6} $ext_dir/chrome.manifest
983562b1 348cp -f icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/icedove.png
44be9ed4 349%endif
350
9a743685
ER
351# remove unecessary stuff
352rm $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
44be9ed4 353
9a743685 354# never package these
283702b9
ER
355# nss
356rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
357# nspr
358rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9
ER
359# mozldap
360rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
361
44be9ed4 362%clean
363rm -rf $RPM_BUILD_ROOT
364
365%pretrans
366if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
367 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
368fi
bc9cd18a 369for d in chrome defaults greprefs icons isp res; do
44be9ed4 370 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
371 install -d %{_datadir}/%{name}
372 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
373 fi
374done
375exit 0
376
377%files
378%defattr(644,root,root,755)
379%attr(755,root,root) %{_bindir}/icedove
380%attr(755,root,root) %{_bindir}/mozilla-thunderbird
381%attr(755,root,root) %{_bindir}/thunderbird
382%dir %{_libdir}/%{name}
60c77977 383%{_libdir}/%{name}/*.ini
44be9ed4 384%dir %{_libdir}/%{name}/components
385%attr(755,root,root) %{_libdir}/%{name}/components/*.so
386%{_libdir}/%{name}/components/*.js
387%{_libdir}/%{name}/components/*.xpt
283702b9
ER
388%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
389%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
390%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
44be9ed4 391%attr(755,root,root) %{_libdir}/%{name}/*.sh
392%attr(755,root,root) %{_libdir}/%{name}/*-bin
393%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
bc9cd18a 394%attr(755,root,root) %{_libdir}/%{name}/icedove
44be9ed4 395
396# symlinks
397%{_libdir}/%{name}/chrome
398%{_libdir}/%{name}/defaults
399%{_libdir}/%{name}/dictionaries
400%{_libdir}/%{name}/greprefs
44be9ed4 401%{_libdir}/%{name}/isp
402%{_libdir}/%{name}/res
403
404%{_libdir}/%{name}/dependentlibs.list
5e9bb798 405%{_pixmapsdir}/*.png
44be9ed4 406%{_desktopdir}/*.desktop
407
408%dir %{_datadir}/%{name}
409%{_datadir}/%{name}/chrome
410%{_datadir}/%{name}/defaults
411%{_datadir}/%{name}/greprefs
44be9ed4 412%{_datadir}/%{name}/isp
413%{_datadir}/%{name}/res
414
60c77977
SP
415%dir %{_libdir}/%{name}/modules
416%{_libdir}/%{name}/modules/*.js*
417%dir %{_libdir}/%{name}/modules/activity
418%{_libdir}/%{name}/modules/activity/*.js
419%dir %{_libdir}/%{name}/modules/gloda
420%{_libdir}/%{name}/modules/gloda/*.js
421
44be9ed4 422%dir %{_libdir}/%{name}/extensions
423%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 424
425%if %{with lightning}
426%files addon-lightning
427%defattr(644,root,root,755)
94402182 428%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
6578c165 429%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
430%endif
44be9ed4 431
432%if %{with enigmail}
433%files addon-enigmail
434%defattr(644,root,root,755)
435%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
436%endif
This page took 0.101763 seconds and 4 git commands to generate.