]> git.pld-linux.org Git - packages/highlight.git/blame - highlight.spec
- force moc regeneration
[packages/highlight.git] / highlight.spec
CommitLineData
28e6757e 1#
4d835968 2# Conditional build:
28e6757e 3%bcond_without apidocs # don't generate apidocs subpackage
6dca621b 4
28e6757e 5Summary: A source code converter to HTML, XHTML, RTF, TeX, LaTeX, XSL-FO, and XML
d4345fd9 6Summary(pl.UTF-8): Konwerter kodu źródłowego do formatów HTML, XHTML, RTF, TeX, LaTeX, XSL-FO oraz XML
28e6757e 7Name: highlight
0cf94734 8Version: 2.16
6f174515 9Release: 3
761eb7d5 10License: GPL v3
28e6757e 11Group: Applications/Publishing
78f01f41 12Source0: http://www.andre-simon.de/zip/%{name}-%{version}.tar.bz2
0cf94734 13# Source0-md5: 08f1429a6db258ab1a7eecbb4e0d44b2
28e6757e 14Patch0: %{name}-Makefile.patch
15URL: http://www.andre-simon.de/
761eb7d5
TP
16BuildRequires: QtCore-devel
17BuildRequires: QtGui-devel
6dca621b
ER
18%{?with_apidocs:BuildRequires: doxygen}
19BuildRequires: libstdc++-devel
761eb7d5 20BuildRequires: qt4-build
54d6d16e 21BuildRequires: qt4-qmake
28e6757e 22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
761eb7d5 24%define _sysconfdir /etc/highlight
28e6757e 25
26%description
27Highlight is a universal converter from source code to HTML, XHTML,
28RTF, TeX, LaTeX, XSL-FO, and XML. (X)HTML output is formatted by
29Cascading Style Sheets. It supports 100 programming languages and
30includes 50 highlighting color themes. It's possible to easily enhance
31the parsing database. The converter includes some features to provide
32a consistent layout of the input code.
33
100d6ecf
JR
34%description -l pl.UTF-8
35Highlight jest uniwersalnym konwerterem kodu źródłowego do formatów
36HTML, XHTML, RTF, TeX, LaTeX, XSL-FO, and XML. Wyjście (X)HTML jest
37formatowane przez kaskadowe arkusze stylów (CSS). Highlight wspiera
38100 języków programowania i zawiera 50 kolorystycznych motywów
39podświetlania składni. Umożliwia łatwe ulepszanie bazy parsowania.
40Konwerter zawiera pewne cechy zapewniające spójny układ graficzny kodu
41wejściowego.
28e6757e 42
43%package apidocs
44Summary: API documentation for highlight - a source code converter to HTML, XHTML, RTF, TeX, LaTeX, XSL-FO, and XML
d4345fd9 45Summary(pl.UTF-8): Dokumentacja API highlight - konwertera kodu źródłowego do HTML, XHTML, RTF, TeX, LaTeX, XSL-FO oraz XML
28e6757e 46Group: Documentation
6dca621b
ER
47%if "%{_rpmversion}" >= "5"
48BuildArch: noarch
49%endif
28e6757e 50
51%description apidocs
52API documentation for highlight - a source code converter to HTML,
53XHTML, RTF, TeX, LaTeX, XSL-FO, and XML.
54
100d6ecf
JR
55%description apidocs -l pl.UTF-8
56Dokumentacja API highlight - konwertera kodu źródłowego do formatu
4d835968 57HTML, XHTML, RTF, TeX, LaTeX, XSL-FO oraz XML.
28e6757e 58
761eb7d5
TP
59%package gui
60Summary: GUI for highlight - a source code converter to HTML, XHTML, RTF, TeX, LaTeX, XSL-FO, and XML
61Summary(pl.UTF-8): GUI do highlight - konwertera kodu źródłowego do HTML, XHTML, RTF, TeX, LaTeX, XSL-FO oraz XML
62Group: Development/Tools
63Requires: %{name}
64
65%description gui
66Qt4 GUI for for highlight - a source code converter to HTML, XHTML,
67RTF, TeX, LaTeX, XSL-FO, and XML.
68
28e6757e 69%prep
70%setup -q
71%patch0 -p1
72
6f174515
JR
73%{__rm} src/gui-qt/moc_*.cpp
74
28e6757e 75%build
4d835968
JB
76%{__make} \
77 CXX="%{__cxx}" \
78 CXXFLAGS="%{rpmcxxflags}"
761eb7d5 79%{__make} gui \
bc00ee0f 80 QMAKE=qmake-qt4 \
761eb7d5 81 CXX="%{__cxx}" \
54d6d16e 82 CXXFLAGS="%{rpmcxxflags} "'$(DEFINES)'
28e6757e 83
84%{?with_apidocs:%{__make} apidocs}
85
86%install
87rm -rf $RPM_BUILD_ROOT
88
89%{__make} install \
90 DESTDIR=$RPM_BUILD_ROOT
91
761eb7d5
TP
92%{__make} install-gui \
93 DESTDIR=$RPM_BUILD_ROOT
94
28e6757e 95# to avoid false `warning: Installed (but unpackaged) file(s) found:' - these files are packaged through %doc
6dca621b 96rm -fr $RPM_BUILD_ROOT%{_docdir}/highlight
28e6757e 97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%files
102%defattr(644,root,root,755)
761eb7d5 103%doc AUTHORS ChangeLog README README_LANGLIST README_REGEX TODO examples
28e6757e 104%lang(de) %doc README_DE
761eb7d5 105%attr(755,root,root) %{_bindir}/%{name}
54d6d16e
TP
106%dir %{_datadir}/%{name}
107%{_datadir}/%{name}/langDefs
108%{_datadir}/%{name}/themes
28e6757e 109%{_mandir}/man1/*
9274fa23
JB
110%dir %{_sysconfdir}
111%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
28e6757e 112
113%if %{with apidocs}
114%files apidocs
115%defattr(644,root,root,755)
116%doc apidocs/html/*
117%endif
761eb7d5
TP
118
119%files gui
6dca621b 120%defattr(644,root,root,755)
761eb7d5 121%attr(755,root,root) %{_bindir}/%{name}-gui
54d6d16e
TP
122%dir %{_datadir}/%{name}/gui_files
123%dir %{_datadir}/%{name}/gui_files/l10n
124%lang(de) %dir %{_datadir}/%{name}/gui_files/l10n/highlight_de_DE.qm
125%lang(es) %dir %{_datadir}/%{name}/gui_files/l10n/highlight_es_ES.qm
126%{_datadir}/%{name}/gui_files/ext
761eb7d5
TP
127%{_desktopdir}/*.desktop
128%{_pixmapsdir}/*.xpm
This page took 0.07013 seconds and 4 git commands to generate.