]> git.pld-linux.org Git - packages/gtkmm3.git/blame - gtkmm3.spec
BR: graphviz
[packages/gtkmm3.git] / gtkmm3.spec
CommitLineData
33bee831
AF
1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
222a6ef9 4
928477ea 5%define atkmm_ver 2.24.2
7c2001a4
JB
6%define glibmm_ver 2.54.0
7%define gtk3_ver 3.24.0
928477ea 8%define pangomm_ver 2.38.2
33bee831
AF
9Summary: A C++ interface for the GTK+ (a GUI library for X)
10Summary(pl.UTF-8): Wrapper C++ dla GTK+
11Name: gtkmm3
dac66963 12Version: 3.24.7
70058bc0 13Release: 1
33bee831
AF
14License: LGPL v2+
15Group: X11/Libraries
c6e33ff3 16Source0: https://download.gnome.org/sources/gtkmm/3.24/gtkmm-%{version}.tar.xz
dac66963 17# Source0-md5: 9576353c26db5e273a074264b68ad6cf
7c1d0224 18URL: https://www.gtkmm.org/
928477ea 19BuildRequires: atkmm-devel >= %{atkmm_ver}
33bee831 20BuildRequires: autoconf >= 2.59
31a8d119 21BuildRequires: automake >= 1:1.11
70058bc0 22BuildRequires: cairomm-devel >= 1.12.0
c6e33ff3 23BuildRequires: doxygen >= 1:1.8.9
ef8910d5 24BuildRequires: gdk-pixbuf2-devel >= 2.36.0
e34bbb24 25BuildRequires: glibmm-devel >= %{glibmm_ver}
4c3990ce 26BuildRequires: graphviz
a4ed03e8 27BuildRequires: gtk+3-devel >= %{gtk3_ver}
70058bc0 28BuildRequires: libepoxy-devel >= 1.2
33bee831 29BuildRequires: libsigc++-devel
4f3647ae 30BuildRequires: libstdc++-devel >= 6:4.7
e3273d66 31BuildRequires: libtool >= 2:2.0
928477ea
JB
32BuildRequires: mm-common >= 0.9.10
33BuildRequires: pangomm-devel >= %{pangomm_ver}
33bee831
AF
34BuildRequires: perl-base >= 1:5.6.0
35BuildRequires: pkgconfig
ff26e432 36BuildRequires: rpm-build >= 4.6
c6e33ff3 37BuildRequires: rpmbuild(macros) >= 1.752
e3273d66
JB
38BuildRequires: tar >= 1:1.22
39BuildRequires: xz
928477ea 40Requires: atkmm >= %{atkmm_ver}
70058bc0 41Requires: cairomm >= 1.12.0
ef8910d5 42Requires: gdk-pixbuf2 >= 2.36.0
e34bbb24 43Requires: glibmm >= %{glibmm_ver}
a4ed03e8 44Requires: gtk+3 >= %{gtk3_ver}
928477ea 45Requires: pangomm >= %{pangomm_ver}
33bee831
AF
46BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48%description
49This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
50library. The interface provides a convenient interface for C++
51programmers to create GUIs with GTK+'s flexible object-oriented
52framework. Features include type safe callbacks, widgets that are
53extensible using inheritance and over 110 classes that can be freely
54combined to quickly create complex user interfaces.
55
56%description -l pl.UTF-8
57gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
58służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
59także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
60
61%package devel
62Summary: gtkmm and gdkmm header files
63Summary(pl.UTF-8): Pliki nagłówkowe gtkmm i gdkmm
64Group: X11/Development/Libraries
65Requires: %{name} = %{version}-%{release}
928477ea 66Requires: atkmm-devel >= %{atkmm_ver}
70058bc0 67Requires: cairomm-devel >= 1.12.0
ef8910d5 68Requires: gdk-pixbuf2-devel >= 2.36.0
e34bbb24 69Requires: glibmm-devel >= %{glibmm_ver}
a4ed03e8 70Requires: gtk+3-devel >= %{gtk3_ver}
70058bc0 71Requires: libstdc++-devel >= 6:4.6
928477ea 72Requires: pangomm-devel >= %{pangomm_ver}
33bee831
AF
73
74%description devel
75Header files for gtkmm library.
76
77%description devel -l pl.UTF-8
78Pliki nagłówkowe biblioteki gtkmm.
79
80%package static
81Summary: gtkmm and gdkmm static libraries
82Summary(pl.UTF-8): Biblioteki statyczne gtkmm i gdkmm
83Group: X11/Development/Libraries
84Requires: %{name}-devel = %{version}-%{release}
85
86%description static
87gtkmm and gdkmm static libraries.
88
89%description static -l pl.UTF-8
90Biblioteki statyczne gtkmm i gdkmm.
91
92%package apidocs
93Summary: Reference documentation for gtkmm and gdkmm
94Summary(pl.UTF-8): Szczegółowa dokumentacja gtkmm i gdkmm
95Group: Documentation
96Requires: devhelp
128e601f 97BuildArch: noarch
33bee831
AF
98
99%description apidocs
100Reference documentation for gtkmm and gdkmm.
101
102%description apidocs -l pl.UTF-8
103Szczegółowa dokumentacja gtkmm i gdkmm.
104
105%prep
106%setup -q -n gtkmm-%{version}
107
c6e33ff3
JB
108# missing in release tarball, not needed for Linux
109mkdir win32_installer
110touch win32_installer/filelist.am \
111 win32_installer/gtkmm-installer.nsi.in
112
33bee831 113%build
c6e33ff3 114mm-common-prepare --copy --force
33bee831
AF
115%{__libtoolize}
116%{__aclocal} -I build
117%{__autoconf}
118%{__autoheader}
119%{__automake}
120%configure \
c6e33ff3 121 --enable-maintainer-mode \
ef8910d5 122 --disable-silent-rules \
33bee831
AF
123 %{?with_static_libs:--enable-static}
124
125%{__make}
126
127%install
128rm -rf $RPM_BUILD_ROOT
129
130%{__make} install \
131 DESTDIR=$RPM_BUILD_ROOT
132
133%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
134
135%clean
136rm -rf $RPM_BUILD_ROOT
137
138%post -p /sbin/ldconfig
139%postun -p /sbin/ldconfig
140
141%files
142%defattr(644,root,root,755)
3f8d9ad2 143%doc AUTHORS ChangeLog NEWS README
33bee831
AF
144%attr(755,root,root) %{_libdir}/libgdkmm-3.0.so.*.*.*
145%attr(755,root,root) %ghost %{_libdir}/libgdkmm-3.0.so.1
146%attr(755,root,root) %{_libdir}/libgtkmm-3.0.so.*.*.*
147%attr(755,root,root) %ghost %{_libdir}/libgtkmm-3.0.so.1
148
149%files devel
150%defattr(644,root,root,755)
151%attr(755,root,root) %{_libdir}/libgdkmm-3.0.so
152%attr(755,root,root) %{_libdir}/libgtkmm-3.0.so
153%{_libdir}/gdkmm-3.0
154%{_libdir}/gtkmm-3.0
155%{_includedir}/gdkmm-3.0
156%{_includedir}/gtkmm-3.0
157%{_pkgconfigdir}/gdkmm-3.0.pc
158%{_pkgconfigdir}/gtkmm-3.0.pc
159
160%if %{with static_libs}
161%files static
162%defattr(644,root,root,755)
163%{_libdir}/libgdkmm-3.0.a
164%{_libdir}/libgtkmm-3.0.a
165%endif
166
167%files apidocs
168%defattr(644,root,root,755)
169%{_docdir}/gtkmm-3.0
170%{_datadir}/devhelp/books/gtkmm-3.0
This page took 0.157222 seconds and 4 git commands to generate.