]> git.pld-linux.org Git - packages/gpac.git/blame - gpac.spec
- fix building with ffmpeg 3
[packages/gpac.git] / gpac.spec
CommitLineData
16219ea0
JB
1# TODO:
2# - Platinum UPnP: http://www.plutinosoft.com/platinum
3# - AVCap: http://libavcap.sourceforge.net/
4# - OpenSVCDecoder: http://opensvcdecoder.sourceforge.net/
5# - libfreenect: http://openkinect.org/wiki/Main_Page
4979ec52 6#
cee2dd04 7# Conditional build:
0f42ec7c 8%bcond_with amr # AMR-NB and AMR-WB (floating-point) support
57e5083b 9%bcond_without directfb # DirectFB support
13701c20
JB
10%bcond_without faad # AAC decoding support
11%bcond_without ffmpeg # ffmpeg support
12%bcond_without freetype # freetype support
13%bcond_without jpeg # JPEG support
65491e54 14%bcond_with js # JavaScript support
13701c20
JB
15%bcond_without mad # MP3 support
16%bcond_without png # PNG support
17%bcond_without xvid # xvid support
0f42ec7c 18%bcond_without wx # wxWidgets support
f6687443 19%bcond_without plugin # don't build xulrunner/firefox/iceweasel plugin
cee2dd04 20#
bdb13b9e
AM
21%define snap 20141007
22#
f6687443
JR
23%ifarch x32
24%undefine with_plugin
25%endif
b2995149 26Summary: GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-1)
5dbd083d 27Summary(pl.UTF-8): GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
5f694ea5 28Name: gpac
16219ea0 29Version: 0.5.0
705c1692 30Release: 16.%{snap}.1
13701c20
JB
31License: LGPL v2+
32Group: Applications/Multimedia
bdb13b9e
AM
33# Source0: http://downloads.sourceforge.net/gpac/%{name}-%{version}.tar.gz
34Source0: %{name}-%{snap}.tar.bz2
35# Source0-md5: 9e37b324e490d3118622d77bf238cb16
e25a2665 36Patch0: %{name}-install.patch
16219ea0
JB
37Patch1: %{name}-xulrunner.patch
38Patch2: %{name}-amr.patch
39Patch3: %{name}-install-is-not-clean.patch
40Patch4: %{name}-flags.patch
bdb13b9e 41Patch5: wxWidgets3.patch
16219ea0
JB
42Patch6: %{name}-js.patch
43Patch7: %{name}-apps.patch
705c1692 44Patch8: ffmpeg3.patch
5f694ea5 45URL: http://gpac.sourceforge.net/
57e5083b 46%{?with_directfb:BuildRequires: DirectFB-devel}
2c7550ba 47BuildRequires: OpenGL-GLU-devel
f0a57dca 48BuildRequires: SDL-devel
13701c20
JB
49BuildRequires: a52dec-libs-devel
50BuildRequires: alsa-lib-devel >= 0.9
0f42ec7c
JB
51%{?with_amr:BuildRequires: amrnb-devel}
52%{?with_amr:BuildRequires: amrwb-devel}
cee2dd04 53%{?with_faad:BuildRequires: faad2-devel}
9c5072f3 54%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.6}
cee2dd04 55%{?with_freetype:BuildRequires: freetype-devel}
2c7550ba 56%{?with_wx:BuildRequires: gtk+2-devel >= 2:2.20.1}
13701c20 57BuildRequires: jack-audio-connection-kit-devel
62f5b1b8 58%{?with_js:BuildRequires: js-devel < 2:1.8.5}
cee2dd04
JB
59%{?with_jpeg:BuildRequires: libjpeg-devel}
60%{?with_mad:BuildRequires: libmad-devel}
13701c20 61BuildRequires: libogg-devel
cee2dd04 62%{?with_png:BuildRequires: libpng-devel}
13701c20
JB
63BuildRequires: libtheora-devel
64BuildRequires: libvorbis-devel
6dcdf31e 65BuildRequires: libxml2-devel
13701c20 66BuildRequires: openjpeg-devel
16219ea0 67BuildRequires: openssl-devel
2c7550ba 68BuildRequires: pkgconfig
13701c20 69BuildRequires: pulseaudio-devel
60486834 70BuildRequires: rpmbuild(macros) >= 1.357
0f42ec7c 71BuildRequires: sed >= 4.0
b676b63c 72BuildRequires: unzip
37b9f29d 73%{?with_wx:BuildRequires: wxGTK2-unicode-devel >= 2.6.0}
a8c7bdfb 74BuildRequires: xmlrpc-c-server-devel
13701c20
JB
75BuildRequires: xorg-lib-libXext-devel
76BuildRequires: xorg-lib-libXv-devel
f6687443 77%{?with_plugin:BuildRequires: xulrunner-devel >= 2:9.0.0}
cee2dd04 78%{?with_xvid:BuildRequires: xvid-devel}
16219ea0 79BuildRequires: zlib-devel
5f694ea5 80BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82%description
b2995149 83GPAC is an implementation of the MPEG-4 Systems standard (ISO/IEC
8414496-1) developed from scratch in ANSI C.
5f694ea5 85
b2995149 86The main development goal is to provide a clean (a.k.a. readable by as
87many people as possible), small and flexible alternative to the MPEG-4
88Systems reference software (known as IM1 and distributed in ISO/IEC
8914496-5). The MPEG-4 Reference software is indeed a very large piece
90of software, designed to verify the standard rather than provide a
91small, production-stable software. GPAC is written in ANSI C for
92portability reasons (embedded platforms and DSPs) with a simple goal:
93keep the memory footprint as low as possible. The project will at term
94provide player(s), systems encoders and publishing tools for content
95distribution.
5f694ea5 96
80b9bf8c 97%description -l pl.UTF-8
cee2dd04
JB
98GPAC to implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
99stworzona od zera w ANSI C.
100
80b9bf8c
JR
101Głównym celem tworzenia jej jest dostarczenie czystej (tzn. czytelnej
102dla jak największej liczby ludzi), małej i elastycznej alternatywy dla
cee2dd04
JB
103wzorcowego oprogramowania MPEG-4 Systems (znanego jako IM1 i
104rozprowadzanego w ISO/IEC 14496-5). Wzorcowe oprogramowanie MPEG-4
80b9bf8c
JR
105jest bardzo dużą porcją kodu, zaprojektowaną raczej do zweryfikowania
106standardu niż dostarczenia małej, stabilnej wersji produkcyjnej. GPAC
107jest pisany w ANSI C ze względu na przenośność (platformy wbudowane i
108DSP) z prostym celem: wymagać tak mało pamięci, jak to tylko możliwe.
109Projekt docelowo dostarczy odtwarzacz(e), kodery systemowe i narzędzia
110do publikacji w celu dystrybucji materiałów.
cee2dd04 111
9cf5dcbc
JB
112%package devel
113Summary: Header files for GPAC library
114Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GPAC
115Group: Development/Libraries
116Requires: %{name} = %{version}-%{release}
117
118%description devel
119Header files for GPAC library.
120
121%description devel -l pl.UTF-8
122Pliki nagłówkowe biblioteki GPAC.
123
16219ea0
JB
124%package static
125Summary: Static GPAC library
126Summary(pl.UTF-8): Statyczna biblioteka GPAC
127Group: Development/Libraries
128Requires: %{name}-devel = %{version}-%{release}
129
130%description static
131Static GPAC library.
132
133%description static -l pl.UTF-8
134Statyczna biblioteka GPAC.
135
0f42ec7c
JB
136%package gui
137Summary: wxWidgets-based GUI for GPAC
138Summary(pl.UTF-8): Oparty na wxWidgets graficzny interfejs do GPAC
139Group: X11/Applications/Multimedia
140Requires: %{name} = %{version}-%{release}
141
142%description gui
143Osmo4 - wxWidgets-based GUI for GPAC.
144
145%description gui -l pl.UTF-8
146Osmo4 - oparty na wxWidgets graficzny interfejs do GPAC.
147
84d02762 148%package -n browser-plugin-%{name}
149Summary: GPAC browser plugin
5dbd083d 150Summary(pl.UTF-8): Wtyczka GPAC do przegląderek WWW
84d02762 151Group: X11/Libraries
152Requires: %{name} = %{version}-%{release}
60486834
ER
153Requires: browser-plugins >= 2.0
154Requires: browser-plugins(%{_target_base_arch})
84d02762 155
156%description -n browser-plugin-%{name}
157GPAC plugin for Netscape-compatible WWW browsers.
158
80b9bf8c
JR
159%description -n browser-plugin-%{name} -l pl.UTF-8
160Wtyczka GPAC dla przeglądarek WWW zgodnych z Netscape.
84d02762 161
5f694ea5 162%prep
f0a57dca
ER
163%setup -q -n %{name}
164%patch0 -p1
0f42ec7c 165%patch1 -p1
267232dd 166%patch2 -p1
5eb82e91 167%patch3 -p1
13701c20 168%patch4 -p1
ab82664f 169%patch5 -p1
c59004e5 170%patch6 -p1
a8c7bdfb 171%patch7 -p1
705c1692 172%patch8 -p1
13701c20 173
0f42ec7c 174sed -i -e 's/wx-config/wx-gtk2-unicode-config/' configure
e25a2665 175chmod a+x configure
5f694ea5 176
5f694ea5 177%build
16219ea0
JB
178# not autoconf configure
179./configure \
180 --prefix=%{_prefix} \
181 --libdir=%{_lib} \
182 --mandir=%{_mandir} \
13701c20
JB
183 --X11-path=/usr \
184 --cc="%{__cc}" \
16219ea0 185 --cpp="%{__cxx}" \
13701c20 186 --disable-opt \
0f42ec7c
JB
187 %{!?with_wx:--disable-wx} \
188 %{?with_amr:--enable-amr} \
13701c20 189 --enable-pic \
f6687443 190 --extra-cflags="%{rpmcflags} -DFF_API_CLOSE_INPUT_FILE" \
13701c20 191 --extra-ldflags="%{rpmldflags}" \
f6687443
JR
192 %{?with_plugin:--mozdir=%{_browserpluginsdir}} \
193 %{?with_plugin:--xulsdk-path="/usr/include/xulrunner -I/usr/include/nspr"} \
13701c20
JB
194 %{!?with_faad:--use-faad=no} \
195 %{!?with_ffmpeg:--use-ffmpeg=no} \
196 %{!?with_freetype:--use-ft=no} \
197 %{!?with_jpeg:--use-jpeg=no} \
198 %{!?with_js:--use-js=no} \
199 %{!?with_mad:--use-mad=no} \
200 %{!?with_png:--use-png=no} \
201 %{!?with_xvid:--use-xvid=no} \
f6687443 202 --enable-joystick
5f694ea5 203
57e5083b
KK
204%{!?with_directfb: sed -i 's/CONFIG_DIRECTFB.*/CONFIG_DIRECTFB=no/' config.mak}
205
16219ea0 206%{__make} -j1
5f694ea5 207
208%install
209rm -rf $RPM_BUILD_ROOT
16219ea0 210install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
5f694ea5 211
f2e9b0f0 212%{__make} -j1 install install-lib \
16219ea0
JB
213 DESTDIR=$RPM_BUILD_ROOT
214
f2e9b0f0 215%{__make} -j1 -C applications install \
13701c20 216 DESTDIR=$RPM_BUILD_ROOT \
60486834 217 MOZILLA_DIR=$RPM_BUILD_ROOT%{_browserpluginsdir}
5f694ea5 218
5f694ea5 219%clean
220rm -rf $RPM_BUILD_ROOT
221
222%post -p /sbin/ldconfig
223%postun -p /sbin/ldconfig
224
60486834
ER
225%post -n browser-plugin-%{name}
226%update_browser_plugins
84d02762 227
60486834
ER
228%postun -n browser-plugin-%{name}
229if [ "$1" = 0 ]; then
230 %update_browser_plugins
84d02762 231fi
232
5f694ea5 233%files
234%defattr(644,root,root,755)
e51b2790 235%doc AUTHORS BUGS Changelog README TODO
13701c20
JB
236%attr(755,root,root) %{_bindir}/MP4Box
237%attr(755,root,root) %{_bindir}/MP4Client
16219ea0 238%attr(755,root,root) %{_libdir}/libgpac.so.*.*.*
bdb13b9e 239%attr(755,root,root) %ghost %{_libdir}/libgpac.so.3
4979ec52 240%dir %{_libdir}/gpac
13701c20
JB
241%attr(755,root,root) %{_libdir}/gpac/gm_*.so
242%{_datadir}/gpac
243%{_mandir}/man1/gpac.1*
244%{_mandir}/man1/mp4box.1*
245%{_mandir}/man1/mp4client.1*
84d02762 246
9cf5dcbc
JB
247%files devel
248%defattr(644,root,root,755)
16219ea0 249%attr(755,root,root) %{_libdir}/libgpac.so
9cf5dcbc 250%{_includedir}/gpac
16219ea0
JB
251%{_pkgconfigdir}/gpac.pc
252
253%files static
254%defattr(644,root,root,755)
255%{_libdir}/libgpac_static.a
9cf5dcbc 256
563c3d16 257%if %{with wx}
0f42ec7c
JB
258%files gui
259%defattr(644,root,root,755)
bdb13b9e 260%attr(755,root,root) %{_bindir}/DashCast
0f42ec7c 261%attr(755,root,root) %{_bindir}/Osmo4
563c3d16 262%endif
0f42ec7c 263
f6687443 264%if %{with plugin}
84d02762 265%files -n browser-plugin-%{name}
266%defattr(644,root,root,755)
60486834
ER
267%attr(755,root,root) %{_browserpluginsdir}/nposmozilla.so
268%{_browserpluginsdir}/nposmozilla.xpt
f6687443 269%endif
This page took 0.264951 seconds and 4 git commands to generate.