]> git.pld-linux.org Git - packages/gnustep-make.git/blame - gnustep-make.spec
- rel 3
[packages/gnustep-make.git] / gnustep-make.spec
CommitLineData
96cc0725 1#
2fe4a509 2Summary: GNUstep Makefile package
0bbf2562 3Summary(pl.UTF-8): Pakiet GNUstep Makefile
2fe4a509 4Name: gnustep-make
f61b7eed 5Version: 2.0.1
ca47709b 6Release: 3
2fe4a509 7License: GPL
00ab4777 8Group: Applications/System
2fe4a509 9Source0: ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
f61b7eed 10# Source0-md5: f268733ea23f53e211e3977e27b46098
27a0a5f2 11Source1: %{name}-fslayout-pld
c39bf0c0 12Patch0: %{name}-no-LD_LIBRARY_PATH.patch
38354bae 13URL: http://www.gnustep.org/
12a05b0a 14BuildRequires: autoconf >= 2.57
240eeb6c 15BuildRequires: automake
1bd304b0
JB
16# texi2html >= 1.61 (with -init_file) is included in tetex >= 3
17BuildRequires: tetex >= 1:3.0
240eeb6c 18BuildRequires: tetex-dvips
256e2a15 19BuildRequires: tetex-format-latex
20BuildRequires: tetex-format-plain
240eeb6c 21BuildRequires: texinfo-texi2dvi
8a5449c5 22Requires: gnustep-dirs
38354bae 23Conflicts: gnustep-core
240eeb6c 24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38354bae 25
26%description
2fe4a509 27This package contains the basic tools needed to run GNUstep
0085f907 28applications.
38354bae 29
f4573326
JR
30%description -l pl.UTF-8
31Ten pakiet zawiera podstawowe narzędzia potrzebne do uruchamiania
4a75428a
JB
32aplikacji GNUstep.
33
38354bae 34%package devel
2fe4a509 35Summary: Files needed to develop applications with gnustep-make
0bbf2562 36Summary(pl.UTF-8): Pliki potrzebne do tworzenia aplikacji przy użyciu gnustep-make
2fe4a509 37Group: Development/Tools
ced298ba 38Requires: %{name} = %{version}-%{release}
38354bae 39
793c5a86 40%description devel
38354bae 41The makefile package is a simplistic, powerful and extensible way to
2fe4a509 42write makefiles for a GNUstep-based project. It allows the user to
38354bae 43write a GNUstep-based project without having to deal with the complex
44issues associated with the configuration and installation of the core
2fe4a509 45GNUstep libraries. It also allows the user to easily create
0085f907 46cross-compiled binaries.
38354bae 47
f4573326
JR
48%description devel -l pl.UTF-8
49Pakiet makefile jest prostą, wydajną i rozszerzalną metodą pisania
50makefile'i do projektów opartych o GNUstep. Pozwala użytkownikowi na
51tworzenie projektów z pominięciem skomplikowanych szczegółów
4a75428a 52konfiguracji i instalacji podstawowych bibliotek GNUstep. Pozwala
f4573326 53także łatwo tworzyć kompilowane skrośnie binaria.
4a75428a 54
38354bae 55%prep
6fddef2e 56%setup -q
12a05b0a 57%patch0 -p1
27a0a5f2 58cp %{SOURCE1} FilesystemLayouts/pld
38354bae 59
60%build
240eeb6c 61cp -f /usr/share/automake/config.* .
78ae97b8 62%{__autoconf}
240eeb6c 63%configure \
12a05b0a 64 --with-library-combo=gnu-gnu-gnu \
27a0a5f2 65 --with-layout=pld \
2f90c56d 66 --with-tar=tar
ebd5cf4e 67
0aeec892 68%{__make}
96cc0725 69
f61b7eed 70#GNUSTEP_MAKEFILES=`pwd` %{__make} -C Documentation
6fddef2e 71
38354bae 72%install
73rm -rf $RPM_BUILD_ROOT
12a05b0a 74
2eb7a8e9
JB
75%{__make} install \
76 special_prefix=$RPM_BUILD_ROOT
0085f907 77
0085f907 78install -d $RPM_BUILD_ROOT/etc/profile.d
38354bae 79# Create profile files
0b1ce7cb 80cat > $RPM_BUILD_ROOT/etc/profile.d/GNUstep.sh << EOF
38354bae 81#!/bin/sh
f61b7eed 82. %{_datadir}/GNUstep/Makefiles/GNUstep.sh
392606b2 83
3d9fe212 84if [ ! -d \$GNUSTEP_USER_ROOT ]; then
85 mkdir \$GNUSTEP_USER_ROOT
86 chmod +rwx \$GNUSTEP_USER_ROOT
392606b2 87fi
38354bae 88EOF
89
0b1ce7cb 90cat > $RPM_BUILD_ROOT/etc/profile.d/GNUstep.csh << EOF
38354bae 91#!/bin/csh
f61b7eed 92source %{_datadir}Makefiles/GNUstep.csh
392606b2 93
3d9fe212 94test -d \$GNUSTEP_USER_ROOT
95if (\$status != 0) then
96 mkdir \$GNUSTEP_USER_ROOT
97 chmod +rwx \$GNUSTEP_USER_ROOT
392606b2 98endif
0085f907 99EOF
38354bae 100
ca47709b
JR
101# Remove excessive escaping and fix lib/lib64 dir
102sed -i -e 's|"/usr"|/usr|g' -e 's|/lib|/%{_lib}|g' $RPM_BUILD_ROOT/etc/GNUstep/GNUstep.conf
9ee4a4eb 103
0b1ce7cb 104# not (yet?) supported by rpm-compress-doc
bd894211
JB
105find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
106 -type f ! -name '*.html' ! -name '*.css' ! -name '*.gz' | xargs gzip -9nf
793c5a86 107
38354bae 108%clean
109rm -rf $RPM_BUILD_ROOT
110
2eb7a8e9
JB
111%pre
112if [ -d %{_prefix}/System/Makefiles -a ! -L %{_prefix}/System/Makefiles ]; then
113 [ -d %{_prefix}/System/Library ] || install -d %{_prefix}/System/Library
114 mv -f %{_prefix}/System/Makefiles %{_prefix}/System/Library
115 ln -sf Library/Makefiles %{_prefix}/System/Makefiles
116 echo 'Reinstall gnustep-make and gnustep-make-devel if some files are missing.' >&2
117fi
118
78ae97b8 119%files
0085f907 120%defattr(644,root,root,755)
0b1ce7cb 121%doc ChangeLog
1bd304b0
JB
122%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/GNUstep.sh
123%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/GNUstep.csh
f61b7eed 124%attr(755,root,root) %{_bindir}/*
0b1ce7cb 125
12a05b0a
JB
126%dir %{_sysconfdir}/GNUstep
127%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/GNUstep/GNUstep.conf
128
2eb7a8e9 129# GNUstep top-level
f61b7eed 130%dir %{_datadir}/GNUstep
0085f907 131
2eb7a8e9 132# System/Library folder
f61b7eed 133%dir %{_datadir}/GNUstep/Makefiles
2eb7a8e9 134
0f859fa9 135%if %{with doc}
2eb7a8e9
JB
136%dir %{_prefix}/System/Library/Documentation/Developer
137%dir %{_prefix}/System/Library/Documentation/Developer/Make
138%{_prefix}/System/Library/Documentation/Developer/Make/ReleaseNotes
139%dir %{_prefix}/System/Library/Documentation/User
140%{_prefix}/System/Library/Documentation/User/GNUstep
141%dir %{_prefix}/System/Library/Documentation/info
142%{_prefix}/System/Library/Documentation/info/*.info*
143%dir %{_prefix}/System/Library/Documentation/man
c272ca7d
JB
144%dir %{_prefix}/System/Library/Documentation/man/man1
145%{_prefix}/System/Library/Documentation/man/man1/openapp.1*
bd894211 146%dir %{_prefix}/System/Library/Documentation/man/man7
c272ca7d 147%{_prefix}/System/Library/Documentation/man/man7/GNUstep.7*
2fbe8919 148%endif
2eb7a8e9 149
f61b7eed 150%attr(755,root,root) %{_datadir}/GNUstep/Makefiles/config.*
151%{_datadir}/GNUstep/Makefiles/tar-exclude-list
152%attr(755,root,root) %{_datadir}/GNUstep/Makefiles/*.sh
153%attr(755,root,root) %{_datadir}/GNUstep/Makefiles/*.csh
78ae97b8 154
0085f907
JB
155%files devel
156%defattr(644,root,root,755)
0f859fa9 157%if %{with doc}
2eb7a8e9
JB
158%docdir %{_prefix}/System/Library/Documentation
159%{_prefix}/System/Library/Documentation/Developer/Make/Manual
2fbe8919 160%endif
2eb7a8e9 161
f61b7eed 162%{_datadir}/GNUstep/Makefiles/*.make
163%{_datadir}/GNUstep/Makefiles/*.template
164%{_datadir}/GNUstep/Makefiles/Instance
165%{_datadir}/GNUstep/Makefiles/Master
166%{_datadir}/GNUstep/Makefiles/gnustep-make-help
167
168%attr(755,root,root) %{_datadir}/GNUstep/Makefiles/install-sh
169%attr(755,root,root) %{_datadir}/GNUstep/Makefiles/mkinstalldirs
This page took 0.053165 seconds and 4 git commands to generate.