]> git.pld-linux.org Git - packages/gnustep-base.git/blame - gnustep-base.spec
- added Rev and Date CVS keywords
[packages/gnustep-base.git] / gnustep-base.spec
CommitLineData
f2c36225 1#
a1765662 2# Conditional build:
a91f1e86 3%bcond_without doc # don't generate documentation (bootstrap build w/o gnustep-base)
a1765662 4#
09f07d06 5%define ver 1.19
776d94ab 6Summary: GNUstep Base library package
3bae497f 7Summary(pl.UTF-8): Podstawowa biblioteka GNUstep
776d94ab 8Name: gnustep-base
de5b077c 9Version: %{ver}.1
f2c36225 10Release: 6
a1765662 11License: LGPL/GPL
30ff75eb 12Group: Libraries
776d94ab 13Source0: ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
de5b077c 14# Source0-md5: 100e433a7e0624a6e4e5727b87e48c82
aed1ee97 15Source1: %{name}.init
2c5ee7c2 16Source2: %{name}.sysconfig
b032aafd 17Patch0: %{name}-pass-arguments.patch
f2f9d7e3 18Patch1: %{name}-ac.patch
b993d150 19URL: http://www.gnustep.org/
a2dbe50d 20%{?with_doc:BuildRequires: docbook-dtd41-sgml}
9a75922c
JB
21BuildRequires: gcc-objc
22BuildRequires: gmp-devel
72cd19bf 23BuildRequires: gnustep-make-devel >= 1.11.2
9e9cc6e4 24BuildRequires: libffi-devel
aed1ee97 25BuildRequires: libxml2-devel >= 2.3.0
9e9cc6e4 26BuildRequires: libxslt-devel >= 1.1.21
c273ed87 27BuildRequires: openssl-devel >= 0.9.7d
f2f9d7e3 28BuildRequires: texinfo-texi2dvi
9a75922c 29BuildRequires: zlib-devel
81d534d8 30Requires(post): /sbin/ldconfig
a2dbe50d 31Requires(post,preun): /sbin/chkconfig
81d534d8
ER
32Requires(triggerpostun): sed >= 4.0
33Requires: glibc >= 6:2.3.5-7.6
72cd19bf 34Requires: gnustep-make >= 1.11.2
aed1ee97
JB
35# with gdomap in /etc/services
36Requires: setup >= 2.4.3
9a75922c
JB
37Conflicts: gnustep-core
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
b993d150 40%description
776d94ab 41The GNUstep Base Library is a library of general-purpose,
42non-graphical Objective C objects. For example, it includes classes
43for strings, object collections, byte streams, typed coders,
44invocations, notifications, notification dispatchers, moments in time,
45network ports, remote object messaging support (distributed objects),
9a75922c 46event loops, and random number generators.
b993d150 47
51f24a62
JR
48%description -l pl.UTF-8
49Podstawowa biblioteka GNUstep jest biblioteką innych niż graficzne
50obiektów ogólnego przeznaczenia dla Objective C. Zawiera np. klasy dla
51stringów, kolekcji, strumieni, koderów typów, powiadamiania, portów
52sieci, obiektów rozproszonych, pętli zdarzeń, generatorów liczb
129467cf
JB
53losowych.
54
b993d150 55%package devel
129467cf 56Summary: GNUstep Base headers
3bae497f 57Summary(pl.UTF-8): Pliki nagłówkowe podstawowej biblioteki GNUstep
776d94ab 58Group: Development/Libraries
5f741c7a 59Requires: %{name} = %{version}-%{release}
a1765662
JB
60Requires: ffcall-devel
61Requires: gcc-objc
62Requires: gmp-devel
72cd19bf 63Requires: gnustep-make-devel >= 1.11.2
a1765662
JB
64Requires: libxml2-devel
65Requires: zlib-devel
776d94ab 66Conflicts: gnustep-core
b993d150 67
68%description devel
776d94ab 69Header files required to build applications against the GNUstep Base
9a75922c 70library.
b993d150 71
51f24a62
JR
72%description devel -l pl.UTF-8
73Pliki nagłówkowe potrzebne do budowania aplikacji używających
129467cf
JB
74podstawowej biblioteki GNUstep.
75
b993d150 76%prep
e372fffb 77%setup -q
81fa6835 78%patch0 -p1
f2f9d7e3 79%patch1 -p1
b993d150 80
81%build
f2f9d7e3
PS
82%{__autoconf} -Iconfig
83
cd237fcd 84# don't assume that GNUstep.sh is imported in environment
9e9cc6e4 85export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
cd237fcd 86export GNUSTEP_FLATTENED=yes
72cd19bf 87
3de239d6
JB
88# gnustep can use one of 3 ways of getting argc,argv,env:
89# - /proc (default on Linux) - gnustep programs won't run in procless system
90# - fake-main hack (main is secretly renamed and wrapped)
91# - pass-arguments (program must call NSProcessInfo initialize)
1dd53227 92GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
3de239d6 93%configure \
9e9cc6e4
JR
94 --enable-pass-arguments \
95 --enable-libffi \
96 --disable-ffcall
e806eebd 97
cd237fcd 98# fake GUI_MAKE_LOADED to avoid linking with gnustep-gui
f2f9d7e3 99%{__make} -j1 \
1dd53227 100 GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
cd237fcd 101 GUI_MAKE_LOADED=yes \
a91f1e86 102 GNUSTEP_MAKEFILES=`gnustep-config --variable=GNUSTEP_MAKEFILES` \
a1765662 103 messages=yes
b993d150 104
8191a52b 105%if %{with doc}
1289291f 106export LD_LIBRARY_PATH=`pwd`/Source/obj
4041ff2d
SS
107# with __make -j2:
108# mkdir: cannot create directory `../Documentation/BaseTools': File exists
109# make[1]: *** [../Documentation/BaseTools] Error 1
110# make[1]: *** Waiting for unfinished jobs....
9a75922c 111# requires already installed gnustep-base
4041ff2d 112%{__make} -j1 -C Documentation \
1dd53227 113 GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
a91f1e86 114 GNUSTEP_MAKEFILES=`gnustep-config --variable=GNUSTEP_MAKEFILES`
f2f9d7e3 115%{__make} -j1 -C Documentation/manual \
1dd53227 116 GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
a91f1e86 117 GNUSTEP_MAKEFILES=`gnustep-config --variable=GNUSTEP_MAKEFILES`
a1765662 118%endif
9a75922c 119
b993d150 120%install
121rm -rf $RPM_BUILD_ROOT
74575d9d 122install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/sysconfig}
9e9cc6e4
JR
123
124export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
cd237fcd 125export GNUSTEP_FLATTENED=yes
72cd19bf 126
f2f9d7e3 127%{__make} -j1 install \
1dd53227 128 GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
9e9cc6e4
JR
129 DESTDIR=$RPM_BUILD_ROOT
130
74575d9d 131install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/gnustep
9e9cc6e4
JR
132install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/gnustep
133
134echo 'GMT' > $RPM_BUILD_ROOT%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/localtime
135
136# Fix .so symlink
137(cd $RPM_BUILD_ROOT%{_libdir} ; ln -sf libgnustep-base.so.*.*.* libgnustep-base.so)
b993d150 138
8191a52b 139%if %{with doc}
f2f9d7e3 140%{__make} -j1 -C Documentation install \
1dd53227 141 GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
9e9cc6e4
JR
142 DESTDIR=$RPM_BUILD_ROOT
143
f2f9d7e3 144%{__make} -j1 -C Documentation/manual install \
1dd53227 145 GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
9e9cc6e4
JR
146 DESTDIR=$RPM_BUILD_ROOT
147
a1765662 148# not (yet?) supported by rpm-compress-doc
9e9cc6e4 149find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
1289291f 150 -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
a1765662 151%endif
9a75922c 152
129467cf
JB
153%clean
154rm -rf $RPM_BUILD_ROOT
155
b993d150 156%post
b993d150 157/sbin/ldconfig
be3ce200 158/sbin/chkconfig --add gnustep
9a75922c
JB
159if [ -f /var/lock/subsys/gnustep ]; then
160 /etc/rc.d/init.d/gnustep restart 1>&2
161else
162 echo "Run \"/etc/rc.d/init.d/gnustep start\" to start gnustep services."
163fi
b993d150 164
165%preun
9a75922c
JB
166if [ "$1" = "0" ]; then
167 if [ -f /var/lock/subsys/gnustep ]; then
168 /etc/rc.d/init.d/gnustep stop 1>&2
169 fi
170 /sbin/chkconfig --del gnustep
b993d150 171fi
172
81d534d8 173%postun -p /sbin/ldconfig
b993d150 174
81d534d8 175%triggerpostun -- %{name} < 1.11.0-1.1
345013a9 176sed -i -e "/^%(echo %{_prefix}/Libraries/ | sed -e 's,/,\\/,g')$/d" /etc/ld.so.conf
aed1ee97 177
9a75922c 178%files
776d94ab 179%defattr(644,root,root,755)
a1765662 180%doc ChangeLog*
9e9cc6e4
JR
181%if %{with doc}
182%docdir %{_datadir}/GNUstep/Documentation
183%{_datadir}/GNUstep/Documentation/*.jpg
184%{_datadir}/GNUstep/Documentation/index.html
185%{_datadir}/GNUstep/Documentation/style.css
8f9f379a 186%dir %{_datadir}/GNUstep/Documentation
9e9cc6e4
JR
187%dir %{_datadir}/GNUstep/Documentation/Developer
188%dir %{_datadir}/GNUstep/Documentation/Developer/Base
189%{_datadir}/GNUstep/Documentation/Developer/Base/ReleaseNotes
190%endif
191
74575d9d 192%attr(754,root,root) /etc/rc.d/init.d/gnustep
2c5ee7c2 193%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/gnustep
9a75922c 194
9e9cc6e4
JR
195%dir %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/SSL.bundle
196%attr(755,root,root) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/SSL.bundle/SSL
197%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/SSL.bundle/Resources
198
199%dir %{_libdir}/GNUstep/DTDs
200%{_libdir}/GNUstep/DTDs/*.dtd
201%{_libdir}/GNUstep/DTDs/*.rnc
202
203%dir %{_libdir}/GNUstep/Libraries
204%dir %{_libdir}/GNUstep/Libraries/gnustep-base
205%dir %{_libdir}/GNUstep/Libraries/gnustep-base/Versions
206%dir %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}
207%dir %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources
208%dir %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages
209%dir %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones
210
211%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/*.plist
212%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/English.lproj
213%lang(eo) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Esperanto.lproj
214%lang(fr) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/French.lproj
215%lang(de) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/German.lproj
216%lang(it) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Italian.lproj
217%lang(ko) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Korean.lproj
218%lang(es) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Spanish.lproj
219%lang(zh_TW) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/TraditionalChinese.lproj
220%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Locale.*
221%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/English
222%lang(nl) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Dutch
223%lang(eo) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Esperanto
224%lang(fr) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/French
225%lang(de) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/German
226%lang(hu) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Hungarian
227%lang(it) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Italian
228%lang(ko) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Korean
229%lang(ru) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Russian
230%lang(sk) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Slovak
231%lang(es) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Spanish
232%lang(zh_TW) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/TraditionalChinese
233%lang(uk) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Ukrainian
234
235%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/GNUmakefile
236%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/GNUstep_zones
237%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/README
238%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/abbreviations
239%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/regions
240%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/zones
241%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/*.m
242%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/*.plist
243%config(noreplace) %verify(not md5 mtime size) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/localtime
244
245%attr(755,root,root) %{_libdir}/libgnustep-base.so.*.*.*
09f07d06 246%attr(755,root,root) %ghost %{_libdir}/libgnustep-base.so.%{ver}
aed1ee97 247
9a75922c 248# is suid necessary here??? it runs as daemon...
9e9cc6e4
JR
249#%attr(4755,root,root) %{_bindir}/gdomap
250%attr(755,root,root) %{_bindir}/*
251
252%{_mandir}/man1/*.1*
253%{_mandir}/man8/*.8*
9a75922c
JB
254
255%files devel
776d94ab 256%defattr(644,root,root,755)
a91f1e86 257%dir %{_datadir}/GNUstep/Makefiles/Additional
258%{_datadir}/GNUstep/Makefiles/Additional/base.make
8191a52b 259%if %{with doc}
9e9cc6e4
JR
260%docdir %{_datadir}/GNUstep/Documentation
261%{_datadir}/GNUstep/Documentation/Developer/Base/General
262%{_datadir}/GNUstep/Documentation/Developer/Base/ProgrammingManual
263%{_datadir}/GNUstep/Documentation/Developer/Base/Reference
264%{_datadir}/GNUstep/Documentation/Developer/BaseAdditions
265%{_datadir}/GNUstep/Documentation/Developer/CodingStandards
266%{_datadir}/GNUstep/Documentation/Developer/Tools
267%{_infodir}/*.info*
aed1ee97
JB
268%endif
269
9e9cc6e4
JR
270%{_includedir}/Foundation
271%{_includedir}/GNUstepBase
272%{_includedir}/gnustep
273
274%attr(755,root,root) %{_libdir}/libgnustep-base.so
aed1ee97 275
9e9cc6e4
JR
276%dir %{_datadir}/GNUstep/Makefiles/Additional
277%{_datadir}/GNUstep/Makefiles/Additional/base.make
This page took 0.072022 seconds and 4 git commands to generate.