]> git.pld-linux.org Git - packages/gnustep-base.git/blame - gnustep-base.spec
- release 4
[packages/gnustep-base.git] / gnustep-base.spec
CommitLineData
a1765662 1# Conditional build:
a91f1e86 2%bcond_without doc # don't generate documentation (bootstrap build w/o gnustep-base)
a1765662 3#
09f07d06 4%define ver 1.19
776d94ab 5Summary: GNUstep Base library package
3bae497f 6Summary(pl.UTF-8): Podstawowa biblioteka GNUstep
776d94ab 7Name: gnustep-base
de5b077c 8Version: %{ver}.1
cbc859c5 9Release: 4
a1765662 10License: LGPL/GPL
30ff75eb 11Group: Libraries
776d94ab 12Source0: ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
de5b077c 13# Source0-md5: 100e433a7e0624a6e4e5727b87e48c82
aed1ee97 14Source1: %{name}.init
2c5ee7c2 15Source2: %{name}.sysconfig
b032aafd 16Patch0: %{name}-pass-arguments.patch
f2f9d7e3 17Patch1: %{name}-ac.patch
b993d150 18URL: http://www.gnustep.org/
a2dbe50d 19%{?with_doc:BuildRequires: docbook-dtd41-sgml}
9a75922c
JB
20BuildRequires: gcc-objc
21BuildRequires: gmp-devel
72cd19bf 22BuildRequires: gnustep-make-devel >= 1.11.2
9e9cc6e4 23BuildRequires: libffi-devel
aed1ee97 24BuildRequires: libxml2-devel >= 2.3.0
9e9cc6e4 25BuildRequires: libxslt-devel >= 1.1.21
c273ed87 26BuildRequires: openssl-devel >= 0.9.7d
f2f9d7e3 27BuildRequires: texinfo-texi2dvi
9a75922c 28BuildRequires: zlib-devel
81d534d8 29Requires(post): /sbin/ldconfig
a2dbe50d 30Requires(post,preun): /sbin/chkconfig
81d534d8
ER
31Requires(triggerpostun): sed >= 4.0
32Requires: glibc >= 6:2.3.5-7.6
72cd19bf 33Requires: gnustep-make >= 1.11.2
aed1ee97
JB
34# with gdomap in /etc/services
35Requires: setup >= 2.4.3
9a75922c
JB
36Conflicts: gnustep-core
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
b993d150 39%description
776d94ab 40The GNUstep Base Library is a library of general-purpose,
41non-graphical Objective C objects. For example, it includes classes
42for strings, object collections, byte streams, typed coders,
43invocations, notifications, notification dispatchers, moments in time,
44network ports, remote object messaging support (distributed objects),
9a75922c 45event loops, and random number generators.
b993d150 46
51f24a62
JR
47%description -l pl.UTF-8
48Podstawowa biblioteka GNUstep jest biblioteką innych niż graficzne
49obiektów ogólnego przeznaczenia dla Objective C. Zawiera np. klasy dla
50stringów, kolekcji, strumieni, koderów typów, powiadamiania, portów
51sieci, obiektów rozproszonych, pętli zdarzeń, generatorów liczb
129467cf
JB
52losowych.
53
b993d150 54%package devel
129467cf 55Summary: GNUstep Base headers
3bae497f 56Summary(pl.UTF-8): Pliki nagłówkowe podstawowej biblioteki GNUstep
776d94ab 57Group: Development/Libraries
5f741c7a 58Requires: %{name} = %{version}-%{release}
a1765662
JB
59Requires: ffcall-devel
60Requires: gcc-objc
61Requires: gmp-devel
72cd19bf 62Requires: gnustep-make-devel >= 1.11.2
a1765662
JB
63Requires: libxml2-devel
64Requires: zlib-devel
776d94ab 65Conflicts: gnustep-core
b993d150 66
67%description devel
776d94ab 68Header files required to build applications against the GNUstep Base
9a75922c 69library.
b993d150 70
51f24a62
JR
71%description devel -l pl.UTF-8
72Pliki nagłówkowe potrzebne do budowania aplikacji używających
129467cf
JB
73podstawowej biblioteki GNUstep.
74
b993d150 75%prep
e372fffb 76%setup -q
81fa6835 77%patch0 -p1
f2f9d7e3 78%patch1 -p1
b993d150 79
80%build
f2f9d7e3
PS
81%{__autoconf} -Iconfig
82
cd237fcd 83# don't assume that GNUstep.sh is imported in environment
9e9cc6e4 84export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
cd237fcd 85export GNUSTEP_FLATTENED=yes
72cd19bf 86
3de239d6
JB
87# gnustep can use one of 3 ways of getting argc,argv,env:
88# - /proc (default on Linux) - gnustep programs won't run in procless system
89# - fake-main hack (main is secretly renamed and wrapped)
90# - pass-arguments (program must call NSProcessInfo initialize)
1dd53227 91GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
3de239d6 92%configure \
9e9cc6e4
JR
93 --enable-pass-arguments \
94 --enable-libffi \
95 --disable-ffcall
e806eebd 96
cd237fcd 97# fake GUI_MAKE_LOADED to avoid linking with gnustep-gui
f2f9d7e3 98%{__make} -j1 \
1dd53227 99 GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
cd237fcd 100 GUI_MAKE_LOADED=yes \
a91f1e86 101 GNUSTEP_MAKEFILES=`gnustep-config --variable=GNUSTEP_MAKEFILES` \
a1765662 102 messages=yes
b993d150 103
8191a52b 104%if %{with doc}
1289291f 105export LD_LIBRARY_PATH=`pwd`/Source/obj
4041ff2d
SS
106# with __make -j2:
107# mkdir: cannot create directory `../Documentation/BaseTools': File exists
108# make[1]: *** [../Documentation/BaseTools] Error 1
109# make[1]: *** Waiting for unfinished jobs....
9a75922c 110# requires already installed gnustep-base
4041ff2d 111%{__make} -j1 -C Documentation \
1dd53227 112 GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
a91f1e86 113 GNUSTEP_MAKEFILES=`gnustep-config --variable=GNUSTEP_MAKEFILES`
f2f9d7e3 114%{__make} -j1 -C Documentation/manual \
1dd53227 115 GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
a91f1e86 116 GNUSTEP_MAKEFILES=`gnustep-config --variable=GNUSTEP_MAKEFILES`
a1765662 117%endif
9a75922c 118
b993d150 119%install
120rm -rf $RPM_BUILD_ROOT
74575d9d 121install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/sysconfig}
9e9cc6e4
JR
122
123export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
cd237fcd 124export GNUSTEP_FLATTENED=yes
72cd19bf 125
f2f9d7e3 126%{__make} -j1 install \
1dd53227 127 GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
9e9cc6e4
JR
128 DESTDIR=$RPM_BUILD_ROOT
129
74575d9d 130install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/gnustep
9e9cc6e4
JR
131install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/gnustep
132
133echo 'GMT' > $RPM_BUILD_ROOT%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/localtime
134
135# Fix .so symlink
136(cd $RPM_BUILD_ROOT%{_libdir} ; ln -sf libgnustep-base.so.*.*.* libgnustep-base.so)
b993d150 137
8191a52b 138%if %{with doc}
f2f9d7e3 139%{__make} -j1 -C Documentation install \
1dd53227 140 GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
9e9cc6e4
JR
141 DESTDIR=$RPM_BUILD_ROOT
142
f2f9d7e3 143%{__make} -j1 -C Documentation/manual install \
1dd53227 144 GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
9e9cc6e4
JR
145 DESTDIR=$RPM_BUILD_ROOT
146
a1765662 147# not (yet?) supported by rpm-compress-doc
9e9cc6e4 148find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
1289291f 149 -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
a1765662 150%endif
9a75922c 151
129467cf
JB
152%clean
153rm -rf $RPM_BUILD_ROOT
154
b993d150 155%post
b993d150 156/sbin/ldconfig
be3ce200 157/sbin/chkconfig --add gnustep
9a75922c
JB
158if [ -f /var/lock/subsys/gnustep ]; then
159 /etc/rc.d/init.d/gnustep restart 1>&2
160else
161 echo "Run \"/etc/rc.d/init.d/gnustep start\" to start gnustep services."
162fi
b993d150 163
164%preun
9a75922c
JB
165if [ "$1" = "0" ]; then
166 if [ -f /var/lock/subsys/gnustep ]; then
167 /etc/rc.d/init.d/gnustep stop 1>&2
168 fi
169 /sbin/chkconfig --del gnustep
b993d150 170fi
171
81d534d8 172%postun -p /sbin/ldconfig
b993d150 173
81d534d8 174%triggerpostun -- %{name} < 1.11.0-1.1
345013a9 175sed -i -e "/^%(echo %{_prefix}/Libraries/ | sed -e 's,/,\\/,g')$/d" /etc/ld.so.conf
aed1ee97 176
9a75922c 177%files
776d94ab 178%defattr(644,root,root,755)
a1765662 179%doc ChangeLog*
9e9cc6e4
JR
180%if %{with doc}
181%docdir %{_datadir}/GNUstep/Documentation
182%{_datadir}/GNUstep/Documentation/*.jpg
183%{_datadir}/GNUstep/Documentation/index.html
184%{_datadir}/GNUstep/Documentation/style.css
8f9f379a 185%dir %{_datadir}/GNUstep/Documentation
9e9cc6e4
JR
186%dir %{_datadir}/GNUstep/Documentation/Developer
187%dir %{_datadir}/GNUstep/Documentation/Developer/Base
188%{_datadir}/GNUstep/Documentation/Developer/Base/ReleaseNotes
189%endif
190
74575d9d 191%attr(754,root,root) /etc/rc.d/init.d/gnustep
2c5ee7c2 192%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/gnustep
9a75922c 193
9e9cc6e4
JR
194%dir %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/SSL.bundle
195%attr(755,root,root) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/SSL.bundle/SSL
196%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/SSL.bundle/Resources
197
198%dir %{_libdir}/GNUstep/DTDs
199%{_libdir}/GNUstep/DTDs/*.dtd
200%{_libdir}/GNUstep/DTDs/*.rnc
201
202%dir %{_libdir}/GNUstep/Libraries
203%dir %{_libdir}/GNUstep/Libraries/gnustep-base
204%dir %{_libdir}/GNUstep/Libraries/gnustep-base/Versions
205%dir %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}
206%dir %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources
207%dir %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages
208%dir %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones
209
210%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/*.plist
211%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/English.lproj
212%lang(eo) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Esperanto.lproj
213%lang(fr) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/French.lproj
214%lang(de) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/German.lproj
215%lang(it) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Italian.lproj
216%lang(ko) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Korean.lproj
217%lang(es) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Spanish.lproj
218%lang(zh_TW) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/TraditionalChinese.lproj
219%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Locale.*
220%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/English
221%lang(nl) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Dutch
222%lang(eo) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Esperanto
223%lang(fr) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/French
224%lang(de) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/German
225%lang(hu) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Hungarian
226%lang(it) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Italian
227%lang(ko) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Korean
228%lang(ru) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Russian
229%lang(sk) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Slovak
230%lang(es) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Spanish
231%lang(zh_TW) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/TraditionalChinese
232%lang(uk) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/Languages/Ukrainian
233
234%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/GNUmakefile
235%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/GNUstep_zones
236%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/README
237%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/abbreviations
238%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/regions
239%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/zones
240%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/*.m
241%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/*.plist
242%config(noreplace) %verify(not md5 mtime size) %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{ver}/Resources/NSTimeZones/localtime
243
244%attr(755,root,root) %{_libdir}/libgnustep-base.so.*.*.*
09f07d06 245%attr(755,root,root) %ghost %{_libdir}/libgnustep-base.so.%{ver}
aed1ee97 246
9a75922c 247# is suid necessary here??? it runs as daemon...
9e9cc6e4
JR
248#%attr(4755,root,root) %{_bindir}/gdomap
249%attr(755,root,root) %{_bindir}/*
250
251%{_mandir}/man1/*.1*
252%{_mandir}/man8/*.8*
9a75922c
JB
253
254%files devel
776d94ab 255%defattr(644,root,root,755)
a91f1e86 256%dir %{_datadir}/GNUstep/Makefiles/Additional
257%{_datadir}/GNUstep/Makefiles/Additional/base.make
8191a52b 258%if %{with doc}
9e9cc6e4
JR
259%docdir %{_datadir}/GNUstep/Documentation
260%{_datadir}/GNUstep/Documentation/Developer/Base/General
261%{_datadir}/GNUstep/Documentation/Developer/Base/ProgrammingManual
262%{_datadir}/GNUstep/Documentation/Developer/Base/Reference
263%{_datadir}/GNUstep/Documentation/Developer/BaseAdditions
264%{_datadir}/GNUstep/Documentation/Developer/CodingStandards
265%{_datadir}/GNUstep/Documentation/Developer/Tools
266%{_infodir}/*.info*
aed1ee97
JB
267%endif
268
9e9cc6e4
JR
269%{_includedir}/Foundation
270%{_includedir}/GNUstepBase
271%{_includedir}/gnustep
272
273%attr(755,root,root) %{_libdir}/libgnustep-base.so
aed1ee97 274
9e9cc6e4
JR
275%dir %{_datadir}/GNUstep/Makefiles/Additional
276%{_datadir}/GNUstep/Makefiles/Additional/base.make
This page took 0.070433 seconds and 4 git commands to generate.