]> git.pld-linux.org Git - packages/gnome-speech.git/blame - gnome-speech.spec
- requires jdk to build
[packages/gnome-speech.git] / gnome-speech.spec
CommitLineData
39088490 1# TODO:
94eb16c5 2# - build other speech plugins?
8bb49eaf 3#
94eb16c5 4# Conditional build:
02da6cd6 5%bcond_without java # don't build java subpackage
94eb16c5 6#
ef7e2865
MB
7%ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
8%undefine with_java
9%endif
39088490 10Summary: GNOME Speech - text-to-speech convertion
897ce7ef 11Summary(pl.UTF-8): GNOME Speech - przekształcanie tekstu na mowę
39088490 12Name: gnome-speech
bc18a931 13Version: 0.4.11
d9fba16c 14Release: 1
dddded48 15License: LGPL
39088490 16Group: Libraries
02da6cd6 17Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-speech/0.4/%{name}-%{version}.tar.bz2
bc18a931 18# Source0-md5: feb95274bd7788e5db0dd7284cc14b8b
ce3ce238 19Patch0: %{name}-jar_dir.patch
39088490 20URL: http://developer.gnome.org/projects/gap/
ef7e2865 21BuildRequires: ORBit2-devel >= 1:2.14.7
39088490 22BuildRequires: autoconf
d5e2de3f 23BuildRequires: automake
ef7e2865 24BuildRequires: espeak-devel
bc18a931
MB
25BuildRequires: gnome-common >= 2.18.0
26BuildRequires: gtk-doc >= 1.8
8bb49eaf 27%if %{with java}
ef7e2865 28BuildRequires: java-access-bridge >= 1.18.0
2e3b42e2 29BuildRequires: jdk
8bb49eaf 30%endif
bc18a931 31BuildRequires: libbonobo-devel >= 2.18.0
d5e2de3f 32BuildRequires: libtool
c0362701 33BuildRequires: pkgconfig
39088490 34Requires: festival >= 1.4.2
39088490 35Provides: gnome_speech
ff83b710 36Obsoletes: gnome_speech
39088490 37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
40GNOME Speech purpose is to provide a simple general API for producing
41text-to-speech output.
42
af0a6e92
JR
43%description -l pl.UTF-8
44Celem GNOME Speech jest udostępnienie prostego, ogólnego API do
45przekształcania tekstu na mowę.
39088490 46
47%package devel
48Summary: Development files for gnome_speech
897ce7ef 49Summary(pl.UTF-8): Pliki programistyczne dla gnome_speech
39088490 50Group: Development/Libraries
5eb1ec29 51Requires: %{name} = %{version}-%{release}
bc18a931 52Requires: libbonobo-devel >= 2.18.0
6ad58c93 53Provides: gnome_speech-devel
ff83b710 54Obsoletes: gnome_speech-devel
6ad58c93 55
39088490 56%description devel
3facb58c 57GNOME Speech files needed for development.
39088490 58
af0a6e92 59%description devel -l pl.UTF-8
3facb58c 60Pliki GNOME Speech potrzebne do programowania.
39088490 61
5eb1ec29 62%package static
63Summary: Static gnome-speech library
897ce7ef 64Summary(pl.UTF-8): Statyczna biblioteka gnome-speech
5eb1ec29 65Group: Development/Libraries
66Requires: %{name}-devel = %{version}-%{release}
67
68%description static
69Static gnome-speech library.
70
af0a6e92 71%description static -l pl.UTF-8
5eb1ec29 72Statyczna biblioteka gnome-speech.
73
8bb49eaf 74%package java
75Summary: Java classes for gnome-speech
897ce7ef 76Summary(pl.UTF-8): Klasy Java dla gnome-speech
8bb49eaf 77Group: Development/Libraries
78
79%description java
80Java classes for gnome-speech.
81
af0a6e92 82%description java -l pl.UTF-8
8bb49eaf 83Klasy Java dla gnome-speech.
84
39088490 85%prep
86%setup -q
2e601b01 87%patch0 -p1
39088490 88
89%build
90%{__libtoolize}
53355092 91%{__aclocal}
ff83b710 92%{__autoheader}
39088490 93%{__automake}
94%{__autoconf}
5eb1ec29 95%configure \
96 --enable-static \
97 --enable-gtk-doc \
ef7e2865 98 --with-speech-dispatcher \
2346c615 99 %{?with_java:--with-jab-dir=%{_javadir}}
306fcbc5 100%{__make}
39088490 101
102%install
103rm -rf $RPM_BUILD_ROOT
97567c18 104
39088490 105%{__make} install \
106 orbittypelibdir=%{_libdir}/orbit-2.0 \
107 DESTDIR=$RPM_BUILD_ROOT
108
109# no *.la for orbit modules
5eb1ec29 110rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.{la,a}
39088490 111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post -p /sbin/ldconfig
116%postun -p /sbin/ldconfig
117
118%files
119%defattr(644,root,root,755)
ef7e2865 120%attr(755,root,root) %{_bindir}/espeak-synthesis-driver
39088490 121%attr(755,root,root) %{_bindir}/festival-synthesis-driver
ef7e2865 122%attr(755,root,root) %{_bindir}/speechd-synthesis-driver
39088490 123%attr(755,root,root) %{_bindir}/test-speech
124%attr(755,root,root) %{_libdir}/libgnomespeech.so.*.*.*
5eb1ec29 125%attr(755,root,root) %{_libdir}/orbit-2.0/*.so*
ef7e2865
MB
126%{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_Espeak.server
127%{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_Festival.server
128%{_libdir}/bonobo/servers/GNOME_Speech_SynthDriver_Speech_Dispatcher.server
39088490 129
130%files devel
131%defattr(644,root,root,755)
132%attr(755,root,root) %{_libdir}/libgnomespeech.so
133%{_libdir}/libgnomespeech.la
134%{_includedir}/gnome-speech-1.0
135%{_datadir}/idl/gnome-speech-1.0
136%{_pkgconfigdir}/*.pc
5eb1ec29 137
138%files static
139%defattr(644,root,root,755)
140%{_libdir}/lib*.a
8bb49eaf 141
142%if %{with java}
143%files java
144%defattr(644,root,root,755)
2346c615 145%{_javadir}/*.jar
8bb49eaf 146%endif
This page took 0.613814 seconds and 4 git commands to generate.