]> git.pld-linux.org Git - packages/ghc-utf8-string.git/blame - ghc-utf8-string.spec
- release 3
[packages/ghc-utf8-string.git] / ghc-utf8-string.spec
CommitLineData
7ed0ca22
JR
1%define pkgname utf8-string
2Summary: Support for reading and writing UTF8 Strings
3Name: ghc-%{pkgname}
4Version: 0.3.6
09a6071d 5Release: 3
7ed0ca22
JR
6License: BSD
7Group: Development/Languages
8Source0: http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
9# Source0-md5: be8c5ef52a0824babdc89d60c1e9b600
10URL: http://hackage.haskell.org/package/%{pkgname}/
431dcf85 11BuildRequires: ghc >= 6.12.3
5cccf93e 12%requires_releq ghc
7ed0ca22
JR
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
431dcf85 15%define ghcdir ghc-%(/usr/bin/ghc --numeric-version)
7ed0ca22
JR
16
17%description
18A UTF8 layer for IO and Strings. The utf8-string package
19provides operations for encoding UTF8 strings to Word8 lists
20and back, and for reading and writing UTF8 without truncation.
21
22%prep
23%setup -q -n %{pkgname}-%{version}
24
25%build
26./Setup.lhs configure -v2 \
27 --prefix=%{_prefix} \
28 --libdir=%{_libdir} \
29 --libexecdir=%{_libexecdir} \
7ed0ca22
JR
30 --docdir=%{_docdir}/%{name}-%{version}
31
32./Setup.lhs build
33./Setup.lhs haddock --executables
34
35%install
36rm -rf $RPM_BUILD_ROOT
431dcf85
JR
37install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
38
7ed0ca22
JR
39./Setup.lhs copy --destdir=$RPM_BUILD_ROOT
40
41# work around automatic haddock docs installation
42rm -rf %{name}-%{version}-doc
43cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
44
45./Setup.lhs register \
431dcf85 46 --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
7ed0ca22
JR
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%post
431dcf85 52/usr/bin/ghc-pkg recache
7ed0ca22
JR
53
54%postun
431dcf85 55/usr/bin/ghc-pkg recache
7ed0ca22
JR
56
57%files
58%defattr(644,root,root,755)
59%doc %{name}-%{version}-doc/html
431dcf85
JR
60%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
61%{_libdir}/%{ghcdir}/%{pkgname}-%{version}
This page took 0.080643 seconds and 4 git commands to generate.