]> git.pld-linux.org Git - packages/ghc-semigroups.git/blame - ghc-semigroups.spec
rebuild with ghc 8.10.7
[packages/ghc-semigroups.git] / ghc-semigroups.spec
CommitLineData
c3f35d1a
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname semigroups
6Summary: Anything that associates
7Summary(pl.UTF-8): Wszystko, co łączne
8Name: ghc-%{pkgname}
6ef1a3be 9Version: 0.19.1
30fbbeca 10Release: 2
c3f35d1a
JB
11License: BSD
12Group: Development/Languages
13#Source0Download: http://hackage.haskell.org/package/semigroups
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
6ef1a3be 15# Source0-md5: 5c60017c5afb9d6b84c18a8cee6cba84
c3f35d1a
JB
16URL: http://hackage.haskell.org/package/semigroups
17BuildRequires: ghc >= 6.12.3
18BuildRequires: ghc-base >= 3
c3f35d1a 19BuildRequires: ghc-bytestring >= 0.9
c3f35d1a 20BuildRequires: ghc-containers >= 0.3
6ef1a3be
JR
21BuildRequires: ghc-deepseq >= 1.1
22BuildRequires: ghc-hashable >= 1.2.5.0
23BuildRequires: ghc-tagged >= 0.4.4
24BuildRequires: ghc-template-haskell >= 2.5.0.0
c3f35d1a 25BuildRequires: ghc-text >= 0.10
6ef1a3be
JR
26BuildRequires: ghc-transformers >= 0.2
27BuildRequires: ghc-transformers-compat >= 0.5
c3f35d1a 28BuildRequires: ghc-unordered-containers >= 0.2
c3f35d1a
JB
29%if %{with prof}
30BuildRequires: ghc-prof >= 6.12.3
31BuildRequires: ghc-base-prof >= 3
c3f35d1a 32BuildRequires: ghc-bytestring-prof >= 0.9
c3f35d1a 33BuildRequires: ghc-containers-prof >= 0.3
6ef1a3be
JR
34BuildRequires: ghc-deepseq-prof >= 1.1
35BuildRequires: ghc-hashable-prof >= 1.2.5.0
36BuildRequires: ghc-tagged-prof >= 0.4.4
37BuildRequires: ghc-template-haskell-prof >= 2.5.0.0
c3f35d1a 38BuildRequires: ghc-text-prof >= 0.10
6ef1a3be
JR
39BuildRequires: ghc-transformers-prof >= 0.2
40BuildRequires: ghc-transformers-compat-prof >= 0.5
c3f35d1a 41BuildRequires: ghc-unordered-containers-prof >= 0.2
c3f35d1a
JB
42%endif
43BuildRequires: rpmbuild(macros) >= 1.608
44Requires(post,postun): /usr/bin/ghc-pkg
45%requires_eq ghc
46Requires: ghc-base >= 3
c3f35d1a 47Requires: ghc-bytestring >= 0.9
c3f35d1a 48Requires: ghc-containers >= 0.3
6ef1a3be
JR
49Requires: ghc-deepseq >= 1.1
50Requires: ghc-hashable >= 1.2.5.0
51Requires: ghc-tagged >= 0.4.4
52Requires: ghc-template-haskell >= 2.5.0.0
c3f35d1a 53Requires: ghc-text >= 0.10
6ef1a3be
JR
54Requires: ghc-transformers >= 0.2
55Requires: ghc-transformers-compat >= 0.5
c3f35d1a 56Requires: ghc-unordered-containers >= 0.2
c3f35d1a
JB
57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59# debuginfo is not useful for ghc
60%define _enable_debug_packages 0
61
62# don't compress haddock files
63%define _noautocompressdoc *.haddock
64
65%description
66In mathematics, a semigroup is an algebraic structure consisting of a
67set together with an associative binary operation. A semigroup
68generalizes a monoid in that there might not exist an identity
69element. It also (originally) generalized a group (a monoid with all
70inverses) to a type where every element did not have to have an
71inverse, thus the name semigroup.
72
73%description -l pl.UTF-8
74W matematyce półgrupa (semigroup) to struktura algebraiczna składająca
75się ze zbioru wraz z działaniem dwuargumentowym łącznym. Półgrupa jest
76uogólnieniem monoidu, w którym może nie istnieć element neutralny.
77Pierwotnie była także uogólnieniem grupy (monoidu ze wszystkimi
78elementami odwrotnymi) do typu, w którym każdy element nie musiał mieć
79elementu odwrotnego - stąd nazwa półgrupa.
80
81%package prof
82Summary: Profiling %{pkgname} library for GHC
83Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
84Group: Development/Libraries
85Requires: %{name} = %{version}-%{release}
86Requires: ghc-base-prof >= 3
c3f35d1a 87Requires: ghc-bytestring-prof >= 0.9
c3f35d1a 88Requires: ghc-containers-prof >= 0.3
6ef1a3be
JR
89Requires: ghc-deepseq-prof >= 1.1
90Requires: ghc-hashable-prof >= 1.2.5.0
91Requires: ghc-tagged-prof >= 0.4.4
92Requires: ghc-template-haskell-prof >= 2.5.0.0
c3f35d1a 93Requires: ghc-text-prof >= 0.10
6ef1a3be
JR
94Requires: ghc-transformers-prof >= 0.2
95Requires: ghc-transformers-compat-prof >= 0.5
c3f35d1a 96Requires: ghc-unordered-containers-prof >= 0.2
c3f35d1a
JB
97
98%description prof
99Profiling %{pkgname} library for GHC. Should be installed when
100GHC's profiling subsystem is needed.
101
102%description prof -l pl.UTF-8
103Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
104kiedy potrzebujemy systemu profilującego z GHC.
105
106%package doc
107Summary: HTML documentation for ghc %{pkgname} package
108Summary(pl.UTF-8): Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
109Group: Documentation
110
111%description doc
112HTML documentation for ghc %{pkgname} package.
113
114%description doc -l pl.UTF-8
115Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
116
117%prep
118%setup -q -n %{pkgname}-%{version}
119
120%build
121runhaskell Setup.lhs configure -v2 \
122 %{?with_prof:--enable-library-profiling} \
123 --prefix=%{_prefix} \
124 --libdir=%{_libdir} \
125 --libexecdir=%{_libexecdir} \
126 --docdir=%{_docdir}/%{name}-%{version}
127
128runhaskell Setup.lhs build
129runhaskell Setup.lhs haddock --executables
130
131%install
132rm -rf $RPM_BUILD_ROOT
133install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
134
135runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
136
137# work around automatic haddock docs installation
138%{__rm} -rf %{name}-%{version}-doc
139cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
140%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
141
142runhaskell Setup.lhs register \
143 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%post
149%ghc_pkg_recache
150
151%postun
152%ghc_pkg_recache
153
154%files
155%defattr(644,root,root,755)
156%doc LICENSE README.markdown
157%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
158%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
6ef1a3be
JR
159%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSsemigroups-%{version}-*.so
160%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSsemigroups-%{version}-*.a
161%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSsemigroups-%{version}-*_p.a
c3f35d1a 162%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data
6ef1a3be
JR
163%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Semigroup
164%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Semigroup/*.hi
165%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Semigroup/*.dyn_hi
c3f35d1a
JB
166
167%if %{with prof}
168%files prof
169%defattr(644,root,root,755)
6ef1a3be
JR
170%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSsemigroups-%{version}-*_p.a
171%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Semigroup/*.p_hi
c3f35d1a
JB
172%endif
173
174%files doc
175%defattr(644,root,root,755)
176%doc %{name}-%{version}-doc/*
This page took 0.07991 seconds and 4 git commands to generate.