]> git.pld-linux.org Git - packages/fluidsynth.git/blame - fluidsynth.spec
- updated URL, fixed libinstpatch BR
[packages/fluidsynth.git] / fluidsynth.spec
CommitLineData
5fadb22d 1#
2# Conditional build:
e389d9b2
JB
3%bcond_without lash # LASH support (GPL)
4%bcond_with midishare # MidiShare support
2566f65e 5%bcond_without portaudio # portaudio support
e389d9b2 6%bcond_without readline # readline line editing (GPL)
c26a125b 7%bcond_without systemd # systemd notify support
13cb656b 8#
a02834be 9Summary: FluidSynth - a software, real-time synthesizer
c832e2f0 10Summary(pl.UTF-8): FluidSynth - programowy syntezator działający w czasie rzeczywistym
43d51d96 11Name: fluidsynth
ac3050b2 12Version: 2.1.9
c26a125b 13Release: 1
e2b99d1e
JB
14%if %{with lash} || %{with readline}
15License: GPL v2+ (enforced by lash/readline), LGPL v2+ (fluidsynth itself)
e389d9b2 16%else
c0296b5f 17License: LGPL v2+
e389d9b2 18%endif
43d51d96 19Group: Applications/Sound
c2d1ce44
JB
20#Source0Download: https://github.com/FluidSynth/fluidsynth/releases
21Source0: https://github.com/FluidSynth/fluidsynth/archive/v%{version}/%{name}-%{version}.tar.gz
ac3050b2 22# Source0-md5: 6d822ec9352398ccbc16994e56a37d02
e71a1b9b 23URL: https://www.fluidsynth.org/
f6e767e3 24BuildRequires: SDL2-devel >= 2
c0296b5f 25BuildRequires: alsa-lib-devel >= 0.9.1
2566f65e 26BuildRequires: cmake >= 3.1.0
c0296b5f 27BuildRequires: dbus-devel >= 1.0.0
2a60fc6b 28BuildRequires: gettext-tools
c0296b5f 29BuildRequires: glib2-devel >= 1:2.6.5
43d51d96 30BuildRequires: jack-audio-connection-kit-devel
f9c8cc03 31BuildRequires: ladspa-devel
e389d9b2 32%{?with_lash:BuildRequires: lash-devel >= 0.3}
e2b99d1e
JB
33# OpenMP 4.0
34BuildRequires: libgomp-devel >= 6:4.9
e71a1b9b 35BuildRequires: libinstpatch-devel >= 1.1.0
e690dbbd 36BuildRequires: libsndfile-devel >= 1.0.18
e389d9b2 37%{?with_midishare:BuildRequires: midishare-devel}
4737413f 38BuildRequires: pkgconfig
2566f65e 39%{?with_portaudio:BuildRequires: portaudio-devel >= 19}
e690dbbd 40BuildRequires: pulseaudio-devel >= 0.9.8
ecf407a5 41%{?with_readline:BuildRequires: readline-devel}
7e677f47 42BuildRequires: rpmbuild(macros) >= 1.213
c26a125b 43%{?with_systemd:BuildRequires: systemd-devel >= 1:209}
c0296b5f
JB
44Requires: alsa-lib >= 0.9.1
45Requires: glib2 >= 1:2.6.5
46Requires: libsndfile >= 1.0.18
cbc84b11 47Suggests: soundfont-fluid
43d51d96 48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
51Fluid Synth is a software, real-time synthesizer based on the
52Soundfont 2 specifications.
53
b01c0090
JR
54%description -l pl.UTF-8
55Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
51d3a7f0 56oparty na specyfikacji Soundfont 2.
43d51d96 57
58%package devel
59Summary: Development files for the FluidSynth
c832e2f0 60Summary(pl.UTF-8): Pliki nagłówkowe dla FluidSynth
43d51d96 61Group: Development/Libraries
e3ebd3aa 62Requires: %{name} = %{version}-%{release}
c0296b5f
JB
63Requires: alsa-lib-devel >= 0.9.1
64Requires: dbus-devel >= 1.0.0
65Requires: glib2-devel >= 1:2.6.5
e690dbbd 66Requires: jack-audio-connection-kit-devel
e389d9b2 67%{?with_lash:Requires: lash-devel >= 0.3}
e690dbbd 68Requires: libsndfile-devel >= 1.0.18
2566f65e 69%{?with_midishare:Requires: midishare-devel}
c18887e9 70%{?with_portaudio:Requires: portaudio-devel >= 19}
e690dbbd 71Requires: pulseaudio-devel >= 0.9.8
2566f65e 72%{?with_readline:Requires: readline-devel}
08a54b0d 73Obsoletes: fluidsynth-static < 2
43d51d96 74
75%description devel
76This package contains the header files necessary to develop
51d3a7f0 77applications using FluidSynth.
43d51d96 78
b01c0090
JR
79%description devel -l pl.UTF-8
80Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
81kompilacji aplikacji korzystających z bibliotek FluidSynth.
43d51d96 82
43d51d96 83%prep
0afc704e 84%setup -q
43d51d96 85
86%build
2566f65e
JK
87mkdir -p build
88cd build
e2b99d1e 89%cmake .. \
2566f65e
JK
90 -Denable-midishare=%{with midishare} \
91 -Denable-lash=%{with lash} \
92 -Denable-portaudio=%{with portaudio} \
c26a125b
JB
93 -Denable-readline=%{with readline} \
94 %{!?with_systemd:-Denable-systemd=OFF}
fde40a28 95
c2d1ce44
JB
96# define missing in autotools suite
97echo '#define DEFAULT_SOUNDFONT "%{_datadir}/soundfonts/default.sf2"' >> src/config.h
98
43d51d96 99%{__make}
100
101%install
102rm -rf $RPM_BUILD_ROOT
43d51d96 103
2566f65e 104cd build
9b5cb572
PG
105%{__make} install \
106 DESTDIR=$RPM_BUILD_ROOT
43d51d96 107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
51d3a7f0
JB
111%post -p /sbin/ldconfig
112%postun -p /sbin/ldconfig
113
43d51d96 114%files
115%defattr(644,root,root,755)
c26a125b 116%doc AUTHORS README.md THANKS TODO
9e796385
KK
117%attr(755,root,root) %{_bindir}/fluidsynth
118%attr(755,root,root) %{_libdir}/libfluidsynth.so.*.*.*
2566f65e 119%attr(755,root,root) %ghost %{_libdir}/libfluidsynth.so.2
9e796385 120%{_mandir}/man1/fluidsynth.1*
5fadb22d 121
122%files devel
43d51d96 123%defattr(644,root,root,755)
9e796385 124%attr(755,root,root) %{_libdir}/libfluidsynth.so
9e796385 125%{_includedir}/fluidsynth.h
ef862a88 126%{_includedir}/fluidsynth
fde40a28 127%{_pkgconfigdir}/fluidsynth.pc
This page took 0.048599 seconds and 4 git commands to generate.