]> git.pld-linux.org Git - packages/cryptsetup.git/blame - cryptsetup.spec
- patrys: udevsettle was deprecated a year ago
[packages/cryptsetup.git] / cryptsetup.spec
CommitLineData
5eb10616
JB
1#
2# Conditonal build:
d07d45f7 3%bcond_without initrd # don't build initrd version
5eb10616 4#
d7593791 5%define realname cryptsetup
2488c838 6Summary: LUKS for dm-crypt implemented in cryptsetup
29f5822a 7Summary(pl.UTF-8): LUKS dla dm-crypta zaimplementowany w cryptsetup
6351d6a5 8Name: cryptsetup-luks
f5ec273c 9Version: 1.0.6
d07d45f7 10Release: 4
d7593791 11License: GPL v2
6351d6a5 12Group: Base
d7593791 13Source0: http://luks.endorphin.org/source/%{realname}-%{version}.tar.bz2
f5ec273c 14# Source0-md5: 00d452eb7a76e39f5749545d48934a10
5eb10616 15Patch1: %{name}-nostatic.patch
5616104c 16URL: http://luks.endorphin.org/
5fe93676
JB
17BuildRequires: autoconf
18BuildRequires: automake
0b90291e 19BuildRequires: device-mapper-devel
5fe93676 20BuildRequires: gettext-devel
0b90291e
JB
21BuildRequires: libgcrypt-devel >= 1.1.42
22BuildRequires: libselinux-devel
23BuildRequires: libsepol-devel
d172f920 24BuildRequires: libtool
0b90291e
JB
25BuildRequires: libuuid-devel
26BuildRequires: popt-devel
d07d45f7 27%if %{with initrd}
5eb10616 28BuildRequires: device-mapper-static >= 1.02.07
a6fd3218 29BuildRequires: libgcrypt-static >= 1.1.42
30BuildRequires: libgpg-error-static
31BuildRequires: libselinux-static
8d9e50de 32BuildRequires: libsepol-static
a6fd3218 33BuildRequires: libuuid-static
34BuildRequires: popt-static
5eb10616 35%endif
c0cc5702 36Provides: cryptsetup = %{version}
12cca230 37Obsoletes: cryptsetup
6351d6a5 38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%define _sbindir /sbin
8bf4e8eb 41%define _noautoreqdep libcryptsetup.so.0
6351d6a5 42
43%description
6e98e6fb 44LUKS is the upcoming standard for Linux hard disk encryption. By
45providing a standard on-disk-format, it does not only facilitate
46compatibility among distributions, but also provide secure management
47of multiple user passwords. In contrast to existing solution, LUKS
48stores all setup necessary setup information in the partition header,
49enabling the user to transport or migrate his data seamlessly.
6351d6a5 50
6e98e6fb 51This package contains implementation of LUKS for dm-crypt implemented
52in cryptsetup.
6351d6a5 53
77f30028
JR
54%description -l pl.UTF-8
55LUKS to nadchodzący standard linuksowego szyfrowania twardego dysku.
56Dostarczając standardowy format danych na dysku nie tylko ułatwia
57utrzymanie kompatybilności między dystrybucjami, ale także dostarcza
58bezpieczne zarządzanie wieloma hasłami użytkowników. W przeciwieństwie
59do istniejącego rozwiązania LUKS przechowuje wszystkie potrzebne
60informacje o konfiguracji w nagłówku partycji, pozwalając
61użytkownikowi przenosić lub migrować dane w sposób przezroczysty.
12cca230 62
77f30028 63Ten pakiet zawiera implementację LUKS dla dm-crytpa zaimplementowaną w
12cca230
JB
64cryptsetup.
65
6351d6a5 66%package devel
67Summary: Header files for cryptsetup library
29f5822a 68Summary(pl.UTF-8): Pliki nagłówkowe biblioteki cryptsetup
6351d6a5 69Group: Development/Libraries
70Requires: %{name} = %{version}-%{release}
71Requires: device-mapper-devel
72Requires: libgcrypt-devel >= 1.1.42
12cca230 73Obsoletes: cryptsetup-devel
6351d6a5 74
75%description devel
76Header files for cryptsetup library.
77
77f30028
JR
78%description devel -l pl.UTF-8
79Pliki nagłówkowe biblioteki cryptsetup.
6351d6a5 80
81%package static
82Summary: Static cryptsetup library
29f5822a 83Summary(pl.UTF-8): Statyczna biblioteka cryptsetup
6351d6a5 84Group: Development/Libraries
85Requires: %{name}-devel = %{version}-%{release}
fca9458b 86Obsoletes: cryptsetup-static
6351d6a5 87
88%description static
89Static version of cryptsetup library.
90
77f30028 91%description static -l pl.UTF-8
6351d6a5 92Statyczna wersja biblioteki cryptsetup.
93
d07d45f7
ER
94%package initrd
95Summary: LUKS for dm-crypt implemented in cryptsetup - initrd version
96Group: Base
97
98%description initrd
99This package contains implementation of LUKS for dm-crypt implemented
100in cryptsetup - staticaly linked for initrd.
101
6351d6a5 102%prep
d7593791 103%setup -q -n %{realname}-%{version}
5eb10616 104%patch1 -p1
6351d6a5 105
106%build
8d9e50de 107%{__gettextize}
d7593791 108%{__libtoolize}
8d9e50de 109%{__aclocal} -I m4
110%{__autoconf}
d7593791 111%{__autoheader}
8d9e50de 112%{__automake}
d07d45f7
ER
113
114%if %{with initrd}
a6fd3218 115%configure \
d6925a9f 116 --disable-shared-library \
5eb10616 117 --enable-static \
d6925a9f
ER
118 --enable-static-cryptsetup \
119 --disable-nls
d07d45f7
ER
120%{__make}
121mv src/cryptsetup cryptsetup-initrd
122%{__make} clean
123%endif
124
125%configure \
126 --enable-static
6351d6a5 127%{__make}
128
129%install
130rm -rf $RPM_BUILD_ROOT
131
132%{__make} install \
133 DESTDIR=$RPM_BUILD_ROOT
134
135install -d $RPM_BUILD_ROOT/%{_lib}
d7593791
JB
136mv -f $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so.* $RPM_BUILD_ROOT/%{_lib}
137ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcryptsetup.so.*.*.*) \
6351d6a5 138 $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so
139
d07d45f7
ER
140%if %{with initrd}
141install cryptsetup-initrd $RPM_BUILD_ROOT%{_sbindir}
142%endif
143
d7593791 144%find_lang %{realname}
6351d6a5 145
146%clean
147rm -rf $RPM_BUILD_ROOT
148
149%post -p /sbin/ldconfig
150%postun -p /sbin/ldconfig
151
d7593791 152%files -f %{realname}.lang
6351d6a5 153%defattr(644,root,root,755)
d7593791 154%doc AUTHORS ChangeLog TODO
6351d6a5 155%attr(755,root,root) %{_sbindir}/cryptsetup
156%attr(755,root,root) /%{_lib}/libcryptsetup.so.*.*.*
d7593791
JB
157%attr(755,root,root) %ghost /%{_lib}/libcryptsetup.so.0
158%{_mandir}/man8/cryptsetup.8*
6351d6a5 159
160%files devel
161%defattr(644,root,root,755)
162%attr(755,root,root) %{_libdir}/libcryptsetup.so
163%{_libdir}/libcryptsetup.la
d7593791 164%{_includedir}/libcryptsetup.h
6351d6a5 165
a6fd3218 166%files static
167%defattr(644,root,root,755)
168%{_libdir}/libcryptsetup.a
d07d45f7
ER
169
170%if %{with initrd}
171%files initrd
172%defattr(644,root,root,755)
173%attr(755,root,root) %{_sbindir}/cryptsetup-initrd
174%endif
This page took 0.086775 seconds and 4 git commands to generate.