]> git.pld-linux.org Git - packages/crossmingw32-pangomm.git/blame - crossmingw32-pangomm.spec
added filterout_c for -f* options
[packages/crossmingw32-pangomm.git] / crossmingw32-pangomm.spec
CommitLineData
d12a0496
JB
1Summary: A C++ interface for pango library - cross MinGW32 version
2Summary(pl.UTF-8): Interfejs C++ dla biblioteki pango - wersja skrośna MinGW32
7ef93766 3Name: crossmingw32-pangomm
accc7186 4Version: 2.28.4
ab466ace 5Release: 4
7ef93766
JB
6License: LGPL v2+
7Group: Development/Libraries
5e1672ab 8Source0: http://ftp.gnome.org/pub/GNOME/sources/pangomm/2.28/pangomm-%{version}.tar.xz
accc7186 9# Source0-md5: f4fe0905ee56e1ff0205005e61d2a66f
7ef93766
JB
10URL: http://www.gtkmm.org/
11BuildRequires: autoconf >= 2.59
b684277f 12BuildRequires: automake >= 1:1.11
7ef93766
JB
13BuildRequires: crossmingw32-cairomm >= 1.6.3
14BuildRequires: crossmingw32-gcc-c++
d12a0496 15BuildRequires: crossmingw32-glibmm >= 2.22.0
b5bb7627 16BuildRequires: crossmingw32-pango >= 1.24.0
accc7186 17BuildRequires: libtool >= 2:2.0
b775d524 18BuildRequires: mm-common >= 0.9.5
7ef93766 19BuildRequires: pkgconfig >= 1:0.15
b684277f 20BuildRequires: rpmbuild(macros) >= 1.446
5e1672ab
JB
21BuildRequires: tar >= 1:1.22
22BuildRequires: xz
7ef93766 23Requires: crossmingw32-cairomm >= 1.6.3
d02042ea 24Requires: crossmingw32-glibmm >= 2.22.0
b5bb7627 25Requires: crossmingw32-pango >= 1.24.0
7ef93766
JB
26Provides: crossmingw32-gtkmm-pango
27Obsoletes: crossmingw32-gtkmm-pango
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%define no_install_post_strip 1
31
32%define target i386-mingw32
33%define target_platform i386-pc-mingw32
34
35%define _sysprefix /usr
36%define _prefix %{_sysprefix}/%{target}
37%define _libdir %{_prefix}/lib
38%define _pkgconfigdir %{_prefix}/lib/pkgconfig
39%define _dlldir /usr/share/wine/windows/system
40%define __cc %{target}-gcc
41%define __cxx %{target}-g++
42df9968 42%define __pkgconfig_provides %{nil}
0902db15 43%define __pkgconfig_requires %{nil}
7ef93766
JB
44
45%ifnarch %{ix86}
46# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
47%define optflags -O2
48%endif
ab466ace 49# -z options are invalid for mingw linker, most of -f options are Linux-specific
7ef93766 50%define filterout_ld -Wl,-z,.*
ab466ace 51%define filterout_c -f[-a-z0-9=]*
7ef93766
JB
52
53%description
d12a0496 54A C++ interface for pango library - cross MinGW32 version.
7ef93766
JB
55
56%description -l pl.UTF-8
d12a0496 57Interfejs C++ dla biblioteki pango - wersja skrośna MinGW32.
7ef93766
JB
58
59%package static
d12a0496
JB
60Summary: Static pangomm library (cross MinGW32 version)
61Summary(pl.UTF-8): Statyczna biblioteka pangomm (wersja skrośna MinGW32)
7ef93766
JB
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64Provides: crossmingw32-gtkmm-pango-static
65Obsoletes: crossmingw32-gtkmm-pango-static
66
67%description static
d12a0496 68Static pangomm library (cross MinGW32 version).
7ef93766
JB
69
70%description static -l pl.UTF-8
d12a0496 71Statyczna biblioteka pangomm (wersja skrośna MinGW32).
7ef93766
JB
72
73%package dll
74Summary: DLL pangomm library for Windows
75Summary(pl.UTF-8): Biblioteka DLL pangomm dla Windows
76Group: Applications/Emulators
77Requires: crossmingw32-cairomm-dll >= 1.6.3
d02042ea 78Requires: crossmingw32-glibmm-dll >= 2.22.0
b5bb7627 79Requires: crossmingw32-pango-dll >= 1.24.0
7ef93766
JB
80Requires: wine
81Provides: crossmingw32-gtkmm-pango-dll
82Obsoletes: crossmingw32-gtkmm-pango-dll
83
84%description dll
85DLL pangomm library for Windows.
86
87%description dll -l pl.UTF-8
88Biblioteka DLL pangomm dla Windows.
89
90%prep
91%setup -q -n pangomm-%{version}
92
93%build
b684277f 94export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig:%{_npkgconfigdir}
7ef93766 95%{__libtoolize}
aa1fb165 96%{__aclocal} -I build
7ef93766
JB
97%{__autoconf}
98%{__autoheader}
99%{__automake}
100%configure \
101 --target=%{target} \
102 --host=%{target} \
aa1fb165 103 --disable-documentation \
5a97095e 104 --disable-silent-rules \
7ef93766
JB
105 --enable-static
106
107%{__make}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111
112%{__make} install \
113 DESTDIR=$RPM_BUILD_ROOT
114
115install -d $RPM_BUILD_ROOT%{_dlldir}
116mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
117
118%if 0%{!?debug:1}
119%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
120%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
121%endif
122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%files
127%defattr(644,root,root,755)
128%doc AUTHORS ChangeLog NEWS README
129%{_libdir}/libpangomm-1.4.dll.a
130%{_libdir}/libpangomm-1.4.la
131%{_libdir}/pangomm-1.4
132%{_includedir}/pangomm-1.4
133%{_pkgconfigdir}/pangomm-1.4.pc
134
135%files static
136%defattr(644,root,root,755)
137%{_libdir}/libpangomm-1.4.a
138
139%files dll
140%defattr(644,root,root,755)
141%{_dlldir}/libpangomm-1.4-*.dll
This page took 0.043691 seconds and 4 git commands to generate.