]> git.pld-linux.org Git - packages/crossmingw32-fontconfig.git/blame - crossmingw32-fontconfig.spec
- added filterout_c for -f* options
[packages/crossmingw32-fontconfig.git] / crossmingw32-fontconfig.spec
CommitLineData
210c62f9 1%define realname fontconfig
770b3887
JB
2Summary: Font configuration and customization tools - cross MinGW32 versoin
3Summary(pl.UTF-8): Narzędzia do konfigurowania fontów - wersja skrośna dla MinGW32
210c62f9 4Name: crossmingw32-%{realname}
63eafe20 5Version: 2.10.2
6145ff55 6Release: 1
7License: MIT
2279380a 8Group: Development/Libraries
210c62f9 9Source0: http://fontconfig.org/release/%{realname}-%{version}.tar.gz
63eafe20 10# Source0-md5: 025e08b3d7fe45c433de5718e441ed15
210c62f9
JB
11Patch0: %{realname}-blacklist.patch
12Patch1: %{realname}-bitstream-cyberbit.patch
6145ff55 13URL: http://fontconfig.org/
63eafe20 14BuildRequires: autoconf >= 2.61
6145ff55 15BuildRequires: automake
16BuildRequires: crossmingw32-expat
17BuildRequires: crossmingw32-freetype >= 2.1.5
2279380a
JB
18BuildRequires: crossmingw32-gcc
19BuildRequires: libtool
c16afa79 20BuildRequires: pkgconfig >= 1:0.15
2279380a 21Requires: crossmingw32-expat
6145ff55 22Requires: crossmingw32-freetype >= 2.1.5
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%define no_install_post_strip 1
26
27%define target i386-mingw32
28%define target_platform i386-pc-mingw32
6145ff55 29
30%define _sysprefix /usr
31%define _prefix %{_sysprefix}/%{target}
5dbd50b4
JB
32%define _libdir %{_prefix}/lib
33%define _pkgconfigdir %{_prefix}/lib/pkgconfig
2279380a 34%define _dlldir /usr/share/wine/windows/system
6145ff55 35%define __cc %{target}-gcc
36%define __cxx %{target}-g++
37
4dd4b193
JB
38%ifnarch %{ix86}
39# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
40%define optflags -O2
41%endif
c839221c 42# -z options are invalid for mingw linker, most of -f options are Linux-specific
4dd4b193 43%define filterout_ld -Wl,-z,.*
c839221c 44%define filterout_c -f[-a-z0-9=]*
4dd4b193 45
6145ff55 46%description
47Fontconfig is designed to locate fonts within the system and select
48them according to requirements specified by applications.
49
2279380a 50This package contains the cross version for Win32.
6145ff55 51
52%description -l pl.UTF-8
53Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
54systemie i wybierania ich w zależności od potrzeb aplikacji.
55
2279380a
JB
56Paket ten zawiera wersję skrośną dla Win32.
57
58%package static
770b3887
JB
59Summary: Static freetype library (cross MinGW32 version)
60Summary(pl.UTF-8): Statyczna biblioteka freetype (wersja skrośna MinGW32)
2279380a
JB
61Group: Development/Libraries
62Requires: %{name} = %{version}-%{release}
63
64%description static
770b3887 65Static freetype library (cross MinGW32 version).
2279380a
JB
66
67%description static -l pl.UTF-8
770b3887 68Statyczna biblioteka freetype (wersja skrośna MinGW32).
6145ff55 69
2279380a
JB
70%package dll
71Summary: DLL freetype library for Windows
72Summary(pl.UTF-8): Biblioteka DLL freetype dla Windows
73Group: Applications/Emulators
74Requires: crossmingw32-expat-dll
75Requires: crossmingw32-freetype-dll >= 2.1.5
76Requires: wine
6145ff55 77
2279380a
JB
78%description dll
79DLL freetype library for Windows.
80
81%description dll -l pl.UTF-8
82Biblioteka DLL freetype dla Windows.
6145ff55 83
84%prep
210c62f9 85%setup -q -n %{realname}-%{version}
db2135b4 86%patch0 -p1
db2135b4 87%patch1 -p1
6145ff55 88
89%build
c16afa79 90export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
6145ff55 91%{__libtoolize}
63eafe20 92%{__aclocal} -I m4
6145ff55 93%{__autoconf}
94%{__autoheader}
95%{__automake}
96%configure \
6145ff55 97 --target=%{target} \
9702f257 98 --host=%{target} \
99 --with-arch=%{target} \
6749a5ab
JB
100 --with-freetype-config="pkg-config freetype2" \
101 --disable-docs \
102 --disable-silent-rules
6145ff55 103
104%{__make}
105
106%install
107rm -rf $RPM_BUILD_ROOT
6145ff55 108
1ba03cbc 109%{__make} -j1 install \
6145ff55 110 DESTDIR=$RPM_BUILD_ROOT
111
2279380a
JB
112install -d $RPM_BUILD_ROOT%{_dlldir}
113mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
114
115%if 0%{!?debug:1}
116%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
117%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
118%endif
119
2279380a 120# runtime
79c66389
JB
121%{__rm} -r $RPM_BUILD_ROOT/etc/fonts \
122 $RPM_BUILD_ROOT%{_datadir}/{fontconfig,xml/fontconfig}
6145ff55 123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
6145ff55 127%files
128%defattr(644,root,root,755)
2279380a
JB
129%doc AUTHORS COPYING ChangeLog README
130%{_libdir}/libfontconfig.dll.a
131%{_libdir}/libfontconfig.la
132%{_libdir}/fontconfig.def
9702f257 133%dir %{_includedir}/fontconfig
134%{_includedir}/fontconfig/*.h
6145ff55 135%{_pkgconfigdir}/fontconfig.pc
2279380a
JB
136
137%files static
138%defattr(644,root,root,755)
139%{_libdir}/libfontconfig.a
140
141%files dll
142%defattr(644,root,root,755)
143%{_dlldir}/libfontconfig-*.dll
This page took 0.124762 seconds and 4 git commands to generate.