]> git.pld-linux.org Git - packages/crossmingw32-fontconfig.git/blame - crossmingw32-fontconfig.spec
- updated to 2.11.0
[packages/crossmingw32-fontconfig.git] / crossmingw32-fontconfig.spec
CommitLineData
210c62f9 1%define realname fontconfig
770b3887
JB
2Summary: Font configuration and customization tools - cross MinGW32 versoin
3Summary(pl.UTF-8): Narzędzia do konfigurowania fontów - wersja skrośna dla MinGW32
210c62f9 4Name: crossmingw32-%{realname}
c77e5fc8 5Version: 2.11.0
1e50c018 6Release: 1
6145ff55 7License: MIT
2279380a 8Group: Development/Libraries
34984086 9Source0: http://fontconfig.org/release/%{realname}-%{version}.tar.bz2
c77e5fc8 10# Source0-md5: 000bd4baf7aefa828e03414d0c8c7dc5
5efa4a16 11Patch0: %{realname}-bitstream-cyberbit.patch
6145ff55 12URL: http://fontconfig.org/
63eafe20 13BuildRequires: autoconf >= 2.61
1e50c018 14BuildRequires: automake >= 1:1.11
6145ff55 15BuildRequires: crossmingw32-expat
16BuildRequires: crossmingw32-freetype >= 2.1.5
2279380a
JB
17BuildRequires: crossmingw32-gcc
18BuildRequires: libtool
c16afa79 19BuildRequires: pkgconfig >= 1:0.15
c77e5fc8 20BuildRequires: sed >= 4.0
2279380a 21Requires: crossmingw32-expat
6145ff55 22Requires: crossmingw32-freetype >= 2.1.5
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%define no_install_post_strip 1
26
27%define target i386-mingw32
28%define target_platform i386-pc-mingw32
6145ff55 29
30%define _sysprefix /usr
31%define _prefix %{_sysprefix}/%{target}
5dbd50b4
JB
32%define _libdir %{_prefix}/lib
33%define _pkgconfigdir %{_prefix}/lib/pkgconfig
2279380a 34%define _dlldir /usr/share/wine/windows/system
6145ff55 35%define __cc %{target}-gcc
36%define __cxx %{target}-g++
20a217ae 37%define __pkgconfig_provides %{nil}
f205dcde 38%define __pkgconfig_requires %{nil}
6145ff55 39
4dd4b193
JB
40%ifnarch %{ix86}
41# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
42%define optflags -O2
43%endif
c839221c 44# -z options are invalid for mingw linker, most of -f options are Linux-specific
4dd4b193 45%define filterout_ld -Wl,-z,.*
c839221c 46%define filterout_c -f[-a-z0-9=]*
4dd4b193 47
6145ff55 48%description
49Fontconfig is designed to locate fonts within the system and select
50them according to requirements specified by applications.
51
2279380a 52This package contains the cross version for Win32.
6145ff55 53
54%description -l pl.UTF-8
55Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
56systemie i wybierania ich w zależności od potrzeb aplikacji.
57
2279380a
JB
58Paket ten zawiera wersję skrośną dla Win32.
59
60%package static
770b3887
JB
61Summary: Static freetype library (cross MinGW32 version)
62Summary(pl.UTF-8): Statyczna biblioteka freetype (wersja skrośna MinGW32)
2279380a
JB
63Group: Development/Libraries
64Requires: %{name} = %{version}-%{release}
65
66%description static
770b3887 67Static freetype library (cross MinGW32 version).
2279380a
JB
68
69%description static -l pl.UTF-8
770b3887 70Statyczna biblioteka freetype (wersja skrośna MinGW32).
6145ff55 71
2279380a
JB
72%package dll
73Summary: DLL freetype library for Windows
74Summary(pl.UTF-8): Biblioteka DLL freetype dla Windows
75Group: Applications/Emulators
76Requires: crossmingw32-expat-dll
77Requires: crossmingw32-freetype-dll >= 2.1.5
78Requires: wine
6145ff55 79
2279380a
JB
80%description dll
81DLL freetype library for Windows.
82
83%description dll -l pl.UTF-8
84Biblioteka DLL freetype dla Windows.
6145ff55 85
86%prep
210c62f9 87%setup -q -n %{realname}-%{version}
db2135b4 88%patch0 -p1
6145ff55 89
c77e5fc8
JB
90# uses POSIX-specific dirent interfaces
91%{__sed} -i -e 's/test-migration//' test/Makefile.am
92
6145ff55 93%build
c16afa79 94export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
6145ff55 95%{__libtoolize}
63eafe20 96%{__aclocal} -I m4
6145ff55 97%{__autoconf}
98%{__autoheader}
99%{__automake}
100%configure \
6145ff55 101 --target=%{target} \
9702f257 102 --host=%{target} \
103 --with-arch=%{target} \
6749a5ab
JB
104 --with-freetype-config="pkg-config freetype2" \
105 --disable-docs \
106 --disable-silent-rules
6145ff55 107
108%{__make}
109
110%install
111rm -rf $RPM_BUILD_ROOT
6145ff55 112
1ba03cbc 113%{__make} -j1 install \
6145ff55 114 DESTDIR=$RPM_BUILD_ROOT
115
2279380a
JB
116install -d $RPM_BUILD_ROOT%{_dlldir}
117mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
118
119%if 0%{!?debug:1}
120%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
121%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
122%endif
123
2279380a 124# runtime
79c66389
JB
125%{__rm} -r $RPM_BUILD_ROOT/etc/fonts \
126 $RPM_BUILD_ROOT%{_datadir}/{fontconfig,xml/fontconfig}
6145ff55 127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
6145ff55 131%files
132%defattr(644,root,root,755)
2279380a
JB
133%doc AUTHORS COPYING ChangeLog README
134%{_libdir}/libfontconfig.dll.a
135%{_libdir}/libfontconfig.la
136%{_libdir}/fontconfig.def
9702f257 137%dir %{_includedir}/fontconfig
138%{_includedir}/fontconfig/*.h
6145ff55 139%{_pkgconfigdir}/fontconfig.pc
2279380a
JB
140
141%files static
142%defattr(644,root,root,755)
143%{_libdir}/libfontconfig.a
144
145%files dll
146%defattr(644,root,root,755)
147%{_dlldir}/libfontconfig-*.dll
This page took 0.047543 seconds and 4 git commands to generate.