]> git.pld-linux.org Git - packages/cronie.git/blame - cronie.spec
- rel 4; systemd service
[packages/cronie.git] / cronie.spec
CommitLineData
955f0d7d
ER
1# TODO
2# - update paths in manuals (create .in files and send upstream)
3# - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
64e4eafc
ER
4# - syslog output (-s) writes two bytes of garbage to syslog instead of actual data:
5# Mar 3 09:30:01 ravenous CROND[2528]: 4ÿ
9088c091
AM
6#
7# Conditional build:
946518b7 8%bcond_without inotify # without inotify support
0d2f2c46
ER
9%if "%{pld_release}" == "ac"
10%bcond_with selinux # without SELinux support
11%bcond_with audit # without audit support
12%else
13%bcond_without selinux # without SELinux support
828712ad 14%bcond_without audit # without audit support
0d2f2c46
ER
15%endif
16
9088c091
AM
17Summary: Cron daemon for executing programs at set times
18Name: cronie
eb52456a 19Version: 1.4.8
6dd99ede 20Release: 4
fd39f74d 21License: MIT and BSD and GPL v2
9088c091 22Group: Daemons
fd39f74d 23Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
eb52456a 24# Source0-md5: 9b1d2ce6db8d1883e06635f437170657
9088c091
AM
25Source1: %{name}.init
26Source2: cron.logrotate
27Source3: cron.sysconfig
28Source4: %{name}.crontab
29Source5: %{name}.pam
bb090c53 30Source6: %{name}.upstart
6dd99ede 31Source7: crond.service
f440f0d0 32Patch0: inotify-nosys.patch
9c2aa177 33Patch1: %{name}-nosyscrontab.patch
cb620710 34Patch2: sendmail-path.patch
9088c091 35URL: https://fedorahosted.org/cronie/
828712ad
ER
36%{?with_audit:BuildRequires: audit-libs-devel}
37BuildRequires: autoconf
38BuildRequires: automake
9088c091
AM
39%{?with_selinux:BuildRequires: libselinux-devel}
40BuildRequires: pam-devel
0d2f2c46 41BuildRequires: rpm >= 4.4.9-56
bb090c53 42BuildRequires: rpmbuild(macros) >= 1.561
9088c091
AM
43Requires(post): fileutils
44Requires(post,preun): /sbin/chkconfig
9088c091
AM
45Requires(postun): /usr/sbin/groupdel
46Requires(pre): /usr/bin/getgid
47Requires(pre): /usr/sbin/groupadd
48Requires: /bin/run-parts
9088c091 49Requires: psmisc >= 20.1
bb090c53 50Requires: rc-scripts >= 0.4.3.0
f440f0d0 51%{?with_inotify:Requires: uname(release) >= 2.6.13}
9088c091
AM
52Provides: crondaemon
53Provides: crontabs = 1.7
54Provides: group(crontab)
0d2f2c46 55%if "%{pld_release}" == "th"
bf8f51cd 56Provides: vixie-cron = 4.3-1
daf76cdc 57%endif
9088c091
AM
58Obsoletes: crondaemon
59Obsoletes: crontabs
0d2f2c46 60%if "%{pld_release}" == "th"
bf8f51cd 61Obsoletes: vixie-cron < 4.3-1
daf76cdc 62%endif
9088c091
AM
63BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65%description
84a870a4
AM
66Cronie contains the standard UNIX daemon crond that runs specified
67programs at scheduled times and related tools. It is based on the
68original cron and has security and configuration enhancements like the
69ability to use pam and SELinux.
9088c091
AM
70
71%package anacron
84a870a4
AM
72Summary: Utility for running regular jobs
73Group: Base
74Provides: anacron = 2.4
75Obsoletes: anacron <= 2.3
9088c091
AM
76
77%description anacron
84a870a4
AM
78Anacron becames part of cronie. Anacron is used only for running
79regular jobs. The default settings execute regular jobs by anacron,
80however this could be overloaded in settings.
9088c091 81
bb090c53
JK
82%package upstart
83Summary: Upstart job description for Cronie
84Summary(pl.UTF-8): Opis zadania Upstart dla Cronie
85Group: Daemons
86Requires: %{name} = %{version}-%{release}
87Requires: upstart >= 0.6
88
89%description upstart
90Upstart job description for Cronie.
91
92%description upstart -l pl.UTF-8
93Opis zadania Upstart dla Cronie.
94
6dd99ede
BZ
95%package systemd
96Summary: systemd units for cronie
97Group: Base
98Requires: %{name} = %{version}-%{release}
99
100%description systemd
101systemd units for cronie.
102
9088c091
AM
103%prep
104%setup -q
f440f0d0 105%patch0 -p1
9c2aa177 106%patch1 -p1
cb620710 107%patch2 -p1
9088c091
AM
108
109%build
828712ad
ER
110%{__aclocal}
111%{__autoconf}
112%{__autoheader}
113%{__automake}
9088c091 114%configure \
d39ca4fd 115 SYSCRONTAB=/etc/crontab \
695ed2ed 116 SYS_CROND_DIR=/etc/cron.d \
72768a3d 117 --sysconfdir=/etc/cron \
9088c091 118 --with-pam \
45b0067d 119 --with%{!?with_selinux:out}-selinux \
828712ad 120 --with%{!?with_audit:out}-audit \
946518b7 121 --with%{!?with_inotify:out}-inotify \
5ab1b510
ER
122 --enable-pie \
123 --enable-relro \
9088c091
AM
124 --enable-anacron
125
126%{__make}
127
128%install
129rm -rf $RPM_BUILD_ROOT
6dd99ede 130install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir},/lib/systemd/system}\
bb090c53 131 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig,init} \
9088c091
AM
132 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
133
134%{__make} install \
0d2f2c46 135 pamdir=/etc/pam.d \
9088c091
AM
136 DESTDIR=$RPM_BUILD_ROOT
137
fd39f74d
ER
138install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
139cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
140cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
141cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
142cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
143cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
bb090c53 144cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
6dd99ede 145cp -a %{SOURCE7} $RPM_BUILD_ROOT/lib/systemd/system/crond.service
9088c091
AM
146
147touch $RPM_BUILD_ROOT/var/log/cron
148
149cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
150# cron.allow This file describes the names of the users which are
151# allowed to use the local cron daemon
152root
153EOF
154
155cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
156# cron.deny This file describes the names of the users which are
157# NOT allowed to use the local cron daemon
158EOF
159
160%clean
161rm -rf $RPM_BUILD_ROOT
162
163%pre
164%groupadd -g 117 -r -f crontab
165
166%post
fd39f74d 167if [ ! -f /var/log/cron ]; then
7ff8f944 168 install -m 660 -g crontab /dev/null /var/log/cron
fd39f74d 169fi
9088c091 170/sbin/chkconfig --add crond
9088c091
AM
171%service crond restart "Cron Daemon"
172
173%preun
174if [ "$1" = "0" ]; then
175 %service crond stop
176 /sbin/chkconfig --del crond
177fi
178
179%postun
180if [ "$1" = "0" ]; then
181 %groupremove crontab
182fi
183
8609ee66 184%triggerun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
185# Prevent preun from crond from working
186chmod a-x /etc/rc.d/init.d/crond
187
8609ee66 188%triggerpostun -- hc-cron,fcron,vixie-cron
77af6cfd
AM
189# Restore what triggerun removed
190chmod 754 /etc/rc.d/init.d/crond
8609ee66
ER
191# reinstall crond init.d links, which could be different
192/sbin/chkconfig --del crond
77af6cfd
AM
193/sbin/chkconfig --add crond
194
bb090c53
JK
195%post upstart
196%upstart_post crond
197
198%postun upstart
199%upstart_postun crond
200
9088c091
AM
201%files
202%defattr(644,root,root,755)
203%doc AUTHORS ChangeLog README
204%attr(750,root,crontab) %dir %{_sysconfdir}/cron*
205%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
206%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
207%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
208%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
209%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
210%attr(754,root,root) /etc/rc.d/init.d/crond
211%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
212%attr(755,root,root) %{_sbindir}/crond
213%attr(2755,root,crontab) %{_bindir}/crontab
214
215%{_mandir}/man8/crond.8*
216%{_mandir}/man8/cron.8*
217%{_mandir}/man5/crontab.5*
218%{_mandir}/man1/crontab.1*
219
220%attr(1730,root,crontab) /var/spool/cron
221%attr(660,root,crontab) %ghost /var/log/cron
222
223%files anacron
224%defattr(644,root,root,755)
225%attr(755,root,root) %{_sbindir}/anacron
84a870a4 226%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
9088c091
AM
227%{_mandir}/man5/anacrontab.5*
228%{_mandir}/man8/anacron.8*
d07a95b8
AM
229
230%attr(1730,root,crontab) /var/spool/anacron
bb090c53 231
c69c0f5a 232%if "%{pld_release}" != "ti"
bb090c53
JK
233%files upstart
234%defattr(644,root,root,755)
235%config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
c69c0f5a 236%endif
6dd99ede
BZ
237
238%files systemd
239%defattr(644,root,root,755)
240/lib/systemd/system/crond.service
This page took 0.07082 seconds and 4 git commands to generate.