]> git.pld-linux.org Git - packages/createrepo_c.git/blame - createrepo_c.spec
- added no-c23 patch (don't require C23 unnamed parameters compiler feature)
[packages/createrepo_c.git] / createrepo_c.spec
CommitLineData
cb0b4095 1# TODO:
cb0b4095 2# - drpm support?
eb85e3be
JB
3#
4# Conditional build:
d04b5509
JR
5%bcond_with rpm5 # build with rpm5, tests may fail (rpm.org vs rpm5 compat problems?)
6%bcond_without tests # make tests
7ab42891 7
eb85e3be
JB
8Summary: Creates a common metadata repository
9Summary(pl.UTF-8): Tworzenie wspólnego repozytorium metadanych
10Name: createrepo_c
6c555e93
JP
11Version: 0.21.1
12Release: 1
eb85e3be
JB
13License: GPL v2+
14Group: Applications/System
807f0e8d
JB
15#Source0Download: https://github.com/rpm-software-management/createrepo_c/releases
16Source0: https://github.com/rpm-software-management/createrepo_c/archive/%{version}/%{name}-%{version}.tar.gz
6c555e93 17# Source0-md5: 1c7de898d4c13901aae8b672bd1e812e
eb85e3be 18Patch0: %{name}-rpm5.patch
9aa7d4d3 19Patch1: %{name}-no-c23.patch
807f0e8d 20URL: https://github.com/rpm-software-management/createrepo_c
e2180175 21BuildRequires: bash-completion-devel >= 1:2.0
eb85e3be 22BuildRequires: bzip2-devel
6c555e93 23BuildRequires: cmake >= 2.8.12
eb85e3be
JB
24BuildRequires: curl-devel
25BuildRequires: doxygen
cb0b4095 26#BuildRequires: drpm-devel
eb85e3be 27BuildRequires: glib2-devel >= 1:2.22.0
317621c2 28BuildRequires: libmagic-devel >= 5.40-2
e2180175 29BuildRequires: libmodulemd-devel
eb85e3be
JB
30BuildRequires: libxml2-devel >= 2
31BuildRequires: openssl-devel
6c555e93 32BuildRequires: pkgconfig
eb85e3be 33%{?with_tests:BuildRequires: python-nose}
807f0e8d 34BuildRequires: python3-devel >= 1:3.2
6a19adf5 35BuildRequires: python3-modules
807f0e8d 36%{?with_tests:BuildRequires: python3-nose}
88265fc4 37BuildRequires: rpm-build >= 4.6
d04b5509 38BuildRequires: rpm-devel
eb85e3be 39BuildRequires: rpm-pythonprov
7fe79feb 40BuildRequires: rpmbuild(macros) >= 1.673
e2180175 41BuildRequires: sphinx-pdg
eb85e3be 42BuildRequires: sqlite3-devel >= 3
eb85e3be 43BuildRequires: xz-devel
e2180175 44BuildRequires: zchunk-devel
eb85e3be 45BuildRequires: zlib-devel
317621c2 46%{?with_tests:BuildRequires: zchunk}
eb85e3be
JB
47Requires: %{name}-libs = %{version}-%{release}
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
51C implementation of Createrepo. This utility will generate a common
52metadata repository from a directory of RPM packages.
53
54%description -l pl.UTF-8
55Implementacja w C programu Createrepo. To narzędzie generuje wspólne
56repozytorium metadanych z katalogu pakietów RPM.
57
58%package libs
59Summary: Library for repodata manipulation
60Summary(pl.UTF-8): Biblioteka do operacji na danych repozytorium
61Group: Libraries
62Requires: glib2 >= 1:2.22.0
63
64%description libs
65This package contains the createrepo_c library for applications to
66easy manipulate with a repodata.
67
68%description libs -l pl.UTF-8
69Ten pakiet zawiera bibliotekę createrepo_c, pozwalającą aplikacjom na
70łatwe operowanie na danych repozytorium (repodata).
71
72%package devel
73Summary: Header files for createrepo_c library
74Summary(pl.UTF-8): Pliki nagłówkowe biblioteki createrepo_c
75Group: Development/Libraries
76Requires: %{name}-libs = %{version}-%{release}
77Requires: bzip2-devel
78Requires: curl-devel
79Requires: expat-devel
80Requires: glib2-devel >= 1:2.22.0
81Requires: libmagic-devel
82Requires: libxml2-devel >= 2
d04b5509 83Requires: rpm-devel
eb85e3be
JB
84Requires: sqlite3-devel >= 3
85Requires: xz-devel
86Requires: zlib-devel
87
88%description devel
89This package contains the createrepo_c C header files. These
90development files are for easy manipulation with a repodata.
91
92%description devel -l pl.UTF-8
7ab42891
ER
93Ten pakiet zawiera pliki nagłówkowe C biblioteki createrepo_c. Mają na
94celu łatwe operowanie na danych repozytorium (repodata).
eb85e3be
JB
95
96%package apidocs
97Summary: API documentation for createrepo_c library
98Summary(pl.UTF-8): Dokumentacja API biblioteki createrepo_c
99Group: Documentation
88265fc4 100BuildArch: noarch
eb85e3be
JB
101
102%description apidocs
103API documentation for createrepo_c library.
104
105%description apidocs -l pl.UTF-8
106Dokumentacja API biblioteki createrepo_c.
107
807f0e8d
JB
108%package -n python3-createrepo_c
109Summary: Python 3 bindings for the createrepo_c library
110Summary(pl.UTF-8): Wiązania Pythona 3 do biblioteki createrepo_c
111Group: Development/Languages/Python
112Requires: %{name}-libs = %{version}-%{release}
317621c2 113Obsoletes: python-createrepo_c < 0.17.6
807f0e8d
JB
114
115%description -n python3-createrepo_c
116Python 3 bindings for the createrepo_c library.
117
118%description -n python3-createrepo_c -l pl.UTF-8
119Wiązania Pythona 3 do biblioteki createrepo_c.
eb85e3be
JB
120
121%package -n bash-completion-createrepo_c
122Summary: Bash completion for createrepo_c commands
123Summary(pl.UTF-8): Bashowe uzupełnianie dla poleceń createrepo_c
124Group: Applications/Shells
125Requires: %{name} = %{version}-%{release}
b5b52576 126Requires: bash-completion >= 1:2.0
88265fc4 127BuildArch: noarch
eb85e3be
JB
128
129%description -n bash-completion-createrepo_c
130Bash completion for createrepo_c commands (createrepo_c, mergerepo_c,
131modifyrepo_c).
132
133%description -n bash-completion-createrepo_c -l pl.UTF-8
134Bashowe uzupełnianie dla poleceń createrepo_c (createrepo_c,
135mergerepo_c, modifyrepo_c).
136
137%prep
807f0e8d 138%setup -q
d04b5509 139%{?with_rpm5:%patch0 -p1}
9aa7d4d3 140%patch1 -p1
eb85e3be
JB
141
142%build
317621c2 143install -d build
807f0e8d 144cd build
807f0e8d 145%cmake .. \
7fe79feb 146 -DBASHCOMP_DIR=%{bash_compdir} \
807f0e8d
JB
147 -DPYTHON_DESIRED=3
148
149%{__make}
317621c2 150%{__make} doc
807f0e8d
JB
151
152%if %{with tests}
153%{__make} tests
154%{__make} test \
155 ARGS="-V"
156%endif
eb85e3be
JB
157
158%install
159rm -rf $RPM_BUILD_ROOT
160
317621c2 161%{__make} -C build install \
807f0e8d 162 DESTDIR=$RPM_BUILD_ROOT
9aa7d4d3 163
807f0e8d
JB
164%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/createrepo_c
165%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/createrepo_c
eb85e3be
JB
166
167%clean
168rm -rf $RPM_BUILD_ROOT
169
170%post libs -p /sbin/ldconfig
171%postun libs -p /sbin/ldconfig
172
173%files
174%defattr(644,root,root,755)
175%attr(755,root,root) %{_bindir}/createrepo_c
176%attr(755,root,root) %{_bindir}/mergerepo_c
177%attr(755,root,root) %{_bindir}/modifyrepo_c
807f0e8d 178%attr(755,root,root) %{_bindir}/sqliterepo_c
eb85e3be
JB
179%{_mandir}/man8/createrepo_c.8*
180%{_mandir}/man8/mergerepo_c.8*
7ab42891 181%{_mandir}/man8/modifyrepo_c.8*
807f0e8d 182%{_mandir}/man8/sqliterepo_c.8*
eb85e3be
JB
183
184%files libs
185%defattr(644,root,root,755)
186%doc AUTHORS README.md
187%attr(755,root,root) %{_libdir}/libcreaterepo_c.so.*.*.*
188%attr(755,root,root) %ghost %{_libdir}/libcreaterepo_c.so.0
189
190%files devel
191%defattr(644,root,root,755)
192%attr(755,root,root) %{_libdir}/libcreaterepo_c.so
193%{_pkgconfigdir}/createrepo_c.pc
194%{_includedir}/createrepo_c
195
196%files apidocs
197%defattr(644,root,root,755)
807f0e8d 198%doc build/doc/html
eb85e3be 199
807f0e8d
JB
200%files -n python3-createrepo_c
201%defattr(644,root,root,755)
202%dir %{py3_sitedir}/createrepo_c
203%attr(755,root,root) %{py3_sitedir}/createrepo_c/_createrepo_c.so
204%{py3_sitedir}/createrepo_c/__init__.py
205%{py3_sitedir}/createrepo_c/__pycache__
317621c2 206%{py3_sitedir}/createrepo_c-%{version}-py*.egg-info
807f0e8d 207
eb85e3be
JB
208%files -n bash-completion-createrepo_c
209%defattr(644,root,root,755)
bd7532a4
JB
210%{bash_compdir}/createrepo_c
211%{bash_compdir}/mergerepo_c
212%{bash_compdir}/modifyrepo_c
213%{bash_compdir}/sqliterepo_c
This page took 0.218006 seconds and 4 git commands to generate.