]> git.pld-linux.org Git - packages/createrepo_c.git/blame - createrepo_c.spec
noarch apidocs and bash completion
[packages/createrepo_c.git] / createrepo_c.spec
CommitLineData
cb0b4095 1# TODO:
cb0b4095 2# - drpm support?
eb85e3be
JB
3#
4# Conditional build:
d04b5509
JR
5%bcond_with rpm5 # build with rpm5, tests may fail (rpm.org vs rpm5 compat problems?)
6%bcond_without tests # make tests
7ab42891 7
eb85e3be
JB
8Summary: Creates a common metadata repository
9Summary(pl.UTF-8): Tworzenie wspólnego repozytorium metadanych
10Name: createrepo_c
317621c2 11Version: 0.17.6
9ef133ce 12Release: 3
eb85e3be
JB
13License: GPL v2+
14Group: Applications/System
807f0e8d
JB
15#Source0Download: https://github.com/rpm-software-management/createrepo_c/releases
16Source0: https://github.com/rpm-software-management/createrepo_c/archive/%{version}/%{name}-%{version}.tar.gz
317621c2 17# Source0-md5: 7d9eda50ab16f4e004d7b6a608179346
eb85e3be 18Patch0: %{name}-rpm5.patch
807f0e8d 19URL: https://github.com/rpm-software-management/createrepo_c
eb85e3be
JB
20BuildRequires: bzip2-devel
21BuildRequires: check-devel
22BuildRequires: cmake >= 2.6
23BuildRequires: curl-devel
24BuildRequires: doxygen
cb0b4095 25#BuildRequires: drpm-devel
eb85e3be
JB
26BuildRequires: expat-devel
27BuildRequires: glib2-devel >= 1:2.22.0
317621c2 28BuildRequires: libmagic-devel >= 5.40-2
eb85e3be
JB
29BuildRequires: libxml2-devel >= 2
30BuildRequires: openssl-devel
eb85e3be 31%{?with_tests:BuildRequires: python-nose}
807f0e8d
JB
32BuildRequires: python3-devel >= 1:3.2
33%{?with_tests:BuildRequires: python3-nose}
88265fc4 34BuildRequires: rpm-build >= 4.6
d04b5509 35BuildRequires: rpm-devel
eb85e3be 36BuildRequires: rpm-pythonprov
7fe79feb 37BuildRequires: rpmbuild(macros) >= 1.673
16c66ee9 38BuildRequires: sphinx-pdg-2
eb85e3be 39BuildRequires: sqlite3-devel >= 3
eb85e3be
JB
40BuildRequires: xz-devel
41BuildRequires: zlib-devel
317621c2 42%{?with_tests:BuildRequires: zchunk}
eb85e3be
JB
43Requires: %{name}-libs = %{version}-%{release}
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
47C implementation of Createrepo. This utility will generate a common
48metadata repository from a directory of RPM packages.
49
50%description -l pl.UTF-8
51Implementacja w C programu Createrepo. To narzędzie generuje wspólne
52repozytorium metadanych z katalogu pakietów RPM.
53
54%package libs
55Summary: Library for repodata manipulation
56Summary(pl.UTF-8): Biblioteka do operacji na danych repozytorium
57Group: Libraries
58Requires: glib2 >= 1:2.22.0
59
60%description libs
61This package contains the createrepo_c library for applications to
62easy manipulate with a repodata.
63
64%description libs -l pl.UTF-8
65Ten pakiet zawiera bibliotekę createrepo_c, pozwalającą aplikacjom na
66łatwe operowanie na danych repozytorium (repodata).
67
68%package devel
69Summary: Header files for createrepo_c library
70Summary(pl.UTF-8): Pliki nagłówkowe biblioteki createrepo_c
71Group: Development/Libraries
72Requires: %{name}-libs = %{version}-%{release}
73Requires: bzip2-devel
74Requires: curl-devel
75Requires: expat-devel
76Requires: glib2-devel >= 1:2.22.0
77Requires: libmagic-devel
78Requires: libxml2-devel >= 2
d04b5509 79Requires: rpm-devel
eb85e3be
JB
80Requires: sqlite3-devel >= 3
81Requires: xz-devel
82Requires: zlib-devel
83
84%description devel
85This package contains the createrepo_c C header files. These
86development files are for easy manipulation with a repodata.
87
88%description devel -l pl.UTF-8
7ab42891
ER
89Ten pakiet zawiera pliki nagłówkowe C biblioteki createrepo_c. Mają na
90celu łatwe operowanie na danych repozytorium (repodata).
eb85e3be
JB
91
92%package apidocs
93Summary: API documentation for createrepo_c library
94Summary(pl.UTF-8): Dokumentacja API biblioteki createrepo_c
95Group: Documentation
88265fc4 96BuildArch: noarch
eb85e3be
JB
97
98%description apidocs
99API documentation for createrepo_c library.
100
101%description apidocs -l pl.UTF-8
102Dokumentacja API biblioteki createrepo_c.
103
807f0e8d
JB
104%package -n python3-createrepo_c
105Summary: Python 3 bindings for the createrepo_c library
106Summary(pl.UTF-8): Wiązania Pythona 3 do biblioteki createrepo_c
107Group: Development/Languages/Python
108Requires: %{name}-libs = %{version}-%{release}
317621c2 109Obsoletes: python-createrepo_c < 0.17.6
807f0e8d
JB
110
111%description -n python3-createrepo_c
112Python 3 bindings for the createrepo_c library.
113
114%description -n python3-createrepo_c -l pl.UTF-8
115Wiązania Pythona 3 do biblioteki createrepo_c.
eb85e3be
JB
116
117%package -n bash-completion-createrepo_c
118Summary: Bash completion for createrepo_c commands
119Summary(pl.UTF-8): Bashowe uzupełnianie dla poleceń createrepo_c
120Group: Applications/Shells
121Requires: %{name} = %{version}-%{release}
bd7532a4 122Requires: bash-completion >= 2.0
88265fc4 123BuildArch: noarch
eb85e3be
JB
124
125%description -n bash-completion-createrepo_c
126Bash completion for createrepo_c commands (createrepo_c, mergerepo_c,
127modifyrepo_c).
128
129%description -n bash-completion-createrepo_c -l pl.UTF-8
130Bashowe uzupełnianie dla poleceń createrepo_c (createrepo_c,
131mergerepo_c, modifyrepo_c).
132
133%prep
807f0e8d 134%setup -q
d04b5509 135%{?with_rpm5:%patch0 -p1}
eb85e3be
JB
136
137%build
317621c2 138install -d build
807f0e8d 139cd build
807f0e8d 140%cmake .. \
7fe79feb 141 -DBASHCOMP_DIR=%{bash_compdir} \
807f0e8d
JB
142 -DPYTHON_DESIRED=3
143
144%{__make}
317621c2 145%{__make} doc
807f0e8d
JB
146
147%if %{with tests}
148%{__make} tests
149%{__make} test \
150 ARGS="-V"
151%endif
eb85e3be
JB
152
153%install
154rm -rf $RPM_BUILD_ROOT
155
317621c2 156%{__make} -C build install \
807f0e8d
JB
157 DESTDIR=$RPM_BUILD_ROOT
158%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/createrepo_c
159%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/createrepo_c
eb85e3be
JB
160
161%clean
162rm -rf $RPM_BUILD_ROOT
163
164%post libs -p /sbin/ldconfig
165%postun libs -p /sbin/ldconfig
166
167%files
168%defattr(644,root,root,755)
169%attr(755,root,root) %{_bindir}/createrepo_c
170%attr(755,root,root) %{_bindir}/mergerepo_c
171%attr(755,root,root) %{_bindir}/modifyrepo_c
807f0e8d 172%attr(755,root,root) %{_bindir}/sqliterepo_c
eb85e3be
JB
173%{_mandir}/man8/createrepo_c.8*
174%{_mandir}/man8/mergerepo_c.8*
7ab42891 175%{_mandir}/man8/modifyrepo_c.8*
807f0e8d 176%{_mandir}/man8/sqliterepo_c.8*
eb85e3be
JB
177
178%files libs
179%defattr(644,root,root,755)
180%doc AUTHORS README.md
181%attr(755,root,root) %{_libdir}/libcreaterepo_c.so.*.*.*
182%attr(755,root,root) %ghost %{_libdir}/libcreaterepo_c.so.0
183
184%files devel
185%defattr(644,root,root,755)
186%attr(755,root,root) %{_libdir}/libcreaterepo_c.so
187%{_pkgconfigdir}/createrepo_c.pc
188%{_includedir}/createrepo_c
189
190%files apidocs
191%defattr(644,root,root,755)
807f0e8d 192%doc build/doc/html
eb85e3be 193
807f0e8d
JB
194%files -n python3-createrepo_c
195%defattr(644,root,root,755)
196%dir %{py3_sitedir}/createrepo_c
197%attr(755,root,root) %{py3_sitedir}/createrepo_c/_createrepo_c.so
198%{py3_sitedir}/createrepo_c/__init__.py
199%{py3_sitedir}/createrepo_c/__pycache__
317621c2 200%{py3_sitedir}/createrepo_c-%{version}-py*.egg-info
807f0e8d 201
eb85e3be
JB
202%files -n bash-completion-createrepo_c
203%defattr(644,root,root,755)
bd7532a4
JB
204%{bash_compdir}/createrepo_c
205%{bash_compdir}/mergerepo_c
206%{bash_compdir}/modifyrepo_c
207%{bash_compdir}/sqliterepo_c
This page took 0.135215 seconds and 4 git commands to generate.