]> git.pld-linux.org Git - packages/createrepo_c.git/blame - createrepo_c.spec
- added python patch (fix build after recent python packaging changes)
[packages/createrepo_c.git] / createrepo_c.spec
CommitLineData
eb85e3be
JB
1# TODO: tests fail (rpm.org vs rpm5 compat problems?)
2#
3# Conditional build:
16c66ee9 4%bcond_with tests # make tests
7ab42891
ER
5
6%define gitrev 7ef96a6
eb85e3be
JB
7Summary: Creates a common metadata repository
8Summary(pl.UTF-8): Tworzenie wspólnego repozytorium metadanych
9Name: createrepo_c
7ab42891
ER
10Version: 0.4.0
11Release: 1
eb85e3be
JB
12License: GPL v2+
13Group: Applications/System
14# git clone https://github.com/Tojaj/createrepo_c
7ab42891
ER
15Source0: http://pkgs.fedoraproject.org/repo/pkgs/createrepo_c/%{name}-%{gitrev}.tar.xz/606d117677ab85e5a9ec15896db644c2/createrepo_c-%{gitrev}.tar.xz
16# Source0-md5: 606d117677ab85e5a9ec15896db644c2
eb85e3be 17Patch0: %{name}-rpm5.patch
16c66ee9 18Patch1: %{name}-python.patch
eb85e3be
JB
19URL: https://github.com/Tojaj/createrepo_c
20BuildRequires: bzip2-devel
21BuildRequires: check-devel
22BuildRequires: cmake >= 2.6
23BuildRequires: curl-devel
24BuildRequires: doxygen
25BuildRequires: expat-devel
26BuildRequires: glib2-devel >= 1:2.22.0
27BuildRequires: libmagic-devel
28BuildRequires: libxml2-devel >= 2
29BuildRequires: openssl-devel
30BuildRequires: python-devel >= 2
31%{?with_tests:BuildRequires: python-nose}
32BuildRequires: rpm-devel >= 5
33BuildRequires: rpm-pythonprov
34BuildRequires: rpmbuild(macros) >= 1.219
16c66ee9 35BuildRequires: sphinx-pdg-2
eb85e3be
JB
36BuildRequires: sqlite3-devel >= 3
37BuildRequires: tar >= 1:1.22
38BuildRequires: xz
39BuildRequires: xz-devel
40BuildRequires: zlib-devel
41Requires: %{name}-libs = %{version}-%{release}
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45C implementation of Createrepo. This utility will generate a common
46metadata repository from a directory of RPM packages.
47
48%description -l pl.UTF-8
49Implementacja w C programu Createrepo. To narzędzie generuje wspólne
50repozytorium metadanych z katalogu pakietów RPM.
51
52%package libs
53Summary: Library for repodata manipulation
54Summary(pl.UTF-8): Biblioteka do operacji na danych repozytorium
55Group: Libraries
56Requires: glib2 >= 1:2.22.0
57
58%description libs
59This package contains the createrepo_c library for applications to
60easy manipulate with a repodata.
61
62%description libs -l pl.UTF-8
63Ten pakiet zawiera bibliotekę createrepo_c, pozwalającą aplikacjom na
64łatwe operowanie na danych repozytorium (repodata).
65
66%package devel
67Summary: Header files for createrepo_c library
68Summary(pl.UTF-8): Pliki nagłówkowe biblioteki createrepo_c
69Group: Development/Libraries
70Requires: %{name}-libs = %{version}-%{release}
71Requires: bzip2-devel
72Requires: curl-devel
73Requires: expat-devel
74Requires: glib2-devel >= 1:2.22.0
75Requires: libmagic-devel
76Requires: libxml2-devel >= 2
77Requires: rpm-devel >= 5
78Requires: sqlite3-devel >= 3
79Requires: xz-devel
80Requires: zlib-devel
81
82%description devel
83This package contains the createrepo_c C header files. These
84development files are for easy manipulation with a repodata.
85
86%description devel -l pl.UTF-8
7ab42891
ER
87Ten pakiet zawiera pliki nagłówkowe C biblioteki createrepo_c. Mają na
88celu łatwe operowanie na danych repozytorium (repodata).
eb85e3be
JB
89
90%package apidocs
91Summary: API documentation for createrepo_c library
92Summary(pl.UTF-8): Dokumentacja API biblioteki createrepo_c
93Group: Documentation
94
95%description apidocs
96API documentation for createrepo_c library.
97
98%description apidocs -l pl.UTF-8
99Dokumentacja API biblioteki createrepo_c.
100
101%package -n python-createrepo_c
102Summary: Python bindings for the createrepo_c library
103Summary(pl.UTF-8): Wiązania Pythona do biblioteki createrepo_c
104Group: Development/Languages/Python
105Requires: %{name}-libs = %{version}-%{release}
106
107%description -n python-createrepo_c
108Python bindings for the createrepo_c library.
109
110%description -n python-createrepo_c -l pl.UTF-8
111Wiązania Pythona do biblioteki createrepo_c.
112
113%package -n bash-completion-createrepo_c
114Summary: Bash completion for createrepo_c commands
115Summary(pl.UTF-8): Bashowe uzupełnianie dla poleceń createrepo_c
116Group: Applications/Shells
117Requires: %{name} = %{version}-%{release}
118Requires: bash-completion
119
120%description -n bash-completion-createrepo_c
121Bash completion for createrepo_c commands (createrepo_c, mergerepo_c,
122modifyrepo_c).
123
124%description -n bash-completion-createrepo_c -l pl.UTF-8
125Bashowe uzupełnianie dla poleceń createrepo_c (createrepo_c,
126mergerepo_c, modifyrepo_c).
127
128%prep
129%setup -q -n %{name}
130%patch0 -p1
16c66ee9 131%patch1 -p1
eb85e3be
JB
132
133%build
134%cmake .
16c66ee9 135
eb85e3be
JB
136%{__make}
137%{__make} doc
138
139%if %{with tests}
140%{__make} tests
141%{__make} test \
142 ARGS="-V"
143%endif
144
145%install
146rm -rf $RPM_BUILD_ROOT
147
148%{__make} install \
149 DESTDIR=$RPM_BUILD_ROOT
150
151%py_comp $RPM_BUILD_ROOT%{py_sitedir}/createrepo_c
152%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/createrepo_c
153%py_postclean
154
155%clean
156rm -rf $RPM_BUILD_ROOT
157
158%post libs -p /sbin/ldconfig
159%postun libs -p /sbin/ldconfig
160
161%files
162%defattr(644,root,root,755)
163%attr(755,root,root) %{_bindir}/createrepo_c
164%attr(755,root,root) %{_bindir}/mergerepo_c
165%attr(755,root,root) %{_bindir}/modifyrepo_c
166%{_mandir}/man8/createrepo_c.8*
167%{_mandir}/man8/mergerepo_c.8*
7ab42891 168%{_mandir}/man8/modifyrepo_c.8*
eb85e3be
JB
169
170%files libs
171%defattr(644,root,root,755)
172%doc AUTHORS README.md
173%attr(755,root,root) %{_libdir}/libcreaterepo_c.so.*.*.*
174%attr(755,root,root) %ghost %{_libdir}/libcreaterepo_c.so.0
175
176%files devel
177%defattr(644,root,root,755)
178%attr(755,root,root) %{_libdir}/libcreaterepo_c.so
179%{_pkgconfigdir}/createrepo_c.pc
180%{_includedir}/createrepo_c
181
182%files apidocs
183%defattr(644,root,root,755)
184%doc doc/html
185
186%files -n python-createrepo_c
187%defattr(644,root,root,755)
188%dir %{py_sitedir}/createrepo_c
189%attr(755,root,root) %{py_sitedir}/createrepo_c/_createrepo_cmodule.so
190%{py_sitedir}/createrepo_c/__init__.py[co]
191
192%files -n bash-completion-createrepo_c
193%defattr(644,root,root,755)
194/etc/bash_completion.d/createrepo_c.bash
This page took 0.188487 seconds and 4 git commands to generate.