]> git.pld-linux.org Git - packages/createrepo_c.git/blame - createrepo_c.spec
- new; ported to rpm5, but tests fail
[packages/createrepo_c.git] / createrepo_c.spec
CommitLineData
eb85e3be
JB
1# TODO: tests fail (rpm.org vs rpm5 compat problems?)
2#
3# Conditional build:
4%bcond_without tests # make tests
5#
6Summary: Creates a common metadata repository
7Summary(pl.UTF-8): Tworzenie wspólnego repozytorium metadanych
8Name: createrepo_c
9Version: 0.2.1
10%define snap 20131129
11Release: 0.%{snap}.1
12License: GPL v2+
13Group: Applications/System
14# git clone https://github.com/Tojaj/createrepo_c
15Source0: createrepo_c.tar.xz
16# Source0-md5: afc0dabd7f75f2ad2d34a07966ee87ce
17Patch0: %{name}-rpm5.patch
18URL: https://github.com/Tojaj/createrepo_c
19BuildRequires: bzip2-devel
20BuildRequires: check-devel
21BuildRequires: cmake >= 2.6
22BuildRequires: curl-devel
23BuildRequires: doxygen
24BuildRequires: expat-devel
25BuildRequires: glib2-devel >= 1:2.22.0
26BuildRequires: libmagic-devel
27BuildRequires: libxml2-devel >= 2
28BuildRequires: openssl-devel
29BuildRequires: python-devel >= 2
30%{?with_tests:BuildRequires: python-nose}
31BuildRequires: rpm-devel >= 5
32BuildRequires: rpm-pythonprov
33BuildRequires: rpmbuild(macros) >= 1.219
34BuildRequires: sqlite3-devel >= 3
35BuildRequires: tar >= 1:1.22
36BuildRequires: xz
37BuildRequires: xz-devel
38BuildRequires: zlib-devel
39Requires: %{name}-libs = %{version}-%{release}
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
43C implementation of Createrepo. This utility will generate a common
44metadata repository from a directory of RPM packages.
45
46%description -l pl.UTF-8
47Implementacja w C programu Createrepo. To narzędzie generuje wspólne
48repozytorium metadanych z katalogu pakietów RPM.
49
50%package libs
51Summary: Library for repodata manipulation
52Summary(pl.UTF-8): Biblioteka do operacji na danych repozytorium
53Group: Libraries
54Requires: glib2 >= 1:2.22.0
55
56%description libs
57This package contains the createrepo_c library for applications to
58easy manipulate with a repodata.
59
60%description libs -l pl.UTF-8
61Ten pakiet zawiera bibliotekę createrepo_c, pozwalającą aplikacjom na
62łatwe operowanie na danych repozytorium (repodata).
63
64%package devel
65Summary: Header files for createrepo_c library
66Summary(pl.UTF-8): Pliki nagłówkowe biblioteki createrepo_c
67Group: Development/Libraries
68Requires: %{name}-libs = %{version}-%{release}
69Requires: bzip2-devel
70Requires: curl-devel
71Requires: expat-devel
72Requires: glib2-devel >= 1:2.22.0
73Requires: libmagic-devel
74Requires: libxml2-devel >= 2
75Requires: rpm-devel >= 5
76Requires: sqlite3-devel >= 3
77Requires: xz-devel
78Requires: zlib-devel
79
80%description devel
81This package contains the createrepo_c C header files. These
82development files are for easy manipulation with a repodata.
83
84%description devel -l pl.UTF-8
85Ten pakiet zawiera pliki nagłówkowe C biblioteki createrepo_c. Mają
86na celu łatwe operowanie na danych repozytorium (repodata).
87
88%package apidocs
89Summary: API documentation for createrepo_c library
90Summary(pl.UTF-8): Dokumentacja API biblioteki createrepo_c
91Group: Documentation
92
93%description apidocs
94API documentation for createrepo_c library.
95
96%description apidocs -l pl.UTF-8
97Dokumentacja API biblioteki createrepo_c.
98
99%package -n python-createrepo_c
100Summary: Python bindings for the createrepo_c library
101Summary(pl.UTF-8): Wiązania Pythona do biblioteki createrepo_c
102Group: Development/Languages/Python
103Requires: %{name}-libs = %{version}-%{release}
104
105%description -n python-createrepo_c
106Python bindings for the createrepo_c library.
107
108%description -n python-createrepo_c -l pl.UTF-8
109Wiązania Pythona do biblioteki createrepo_c.
110
111%package -n bash-completion-createrepo_c
112Summary: Bash completion for createrepo_c commands
113Summary(pl.UTF-8): Bashowe uzupełnianie dla poleceń createrepo_c
114Group: Applications/Shells
115Requires: %{name} = %{version}-%{release}
116Requires: bash-completion
117
118%description -n bash-completion-createrepo_c
119Bash completion for createrepo_c commands (createrepo_c, mergerepo_c,
120modifyrepo_c).
121
122%description -n bash-completion-createrepo_c -l pl.UTF-8
123Bashowe uzupełnianie dla poleceń createrepo_c (createrepo_c,
124mergerepo_c, modifyrepo_c).
125
126%prep
127%setup -q -n %{name}
128%patch0 -p1
129
130%build
131%cmake .
132%{__make}
133%{__make} doc
134
135%if %{with tests}
136%{__make} tests
137%{__make} test \
138 ARGS="-V"
139%endif
140
141%install
142rm -rf $RPM_BUILD_ROOT
143
144%{__make} install \
145 DESTDIR=$RPM_BUILD_ROOT
146
147%py_comp $RPM_BUILD_ROOT%{py_sitedir}/createrepo_c
148%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/createrepo_c
149%py_postclean
150
151%clean
152rm -rf $RPM_BUILD_ROOT
153
154%post libs -p /sbin/ldconfig
155%postun libs -p /sbin/ldconfig
156
157%files
158%defattr(644,root,root,755)
159%attr(755,root,root) %{_bindir}/createrepo_c
160%attr(755,root,root) %{_bindir}/mergerepo_c
161%attr(755,root,root) %{_bindir}/modifyrepo_c
162%{_mandir}/man8/createrepo_c.8*
163%{_mandir}/man8/mergerepo_c.8*
164
165%files libs
166%defattr(644,root,root,755)
167%doc AUTHORS README.md
168%attr(755,root,root) %{_libdir}/libcreaterepo_c.so.*.*.*
169%attr(755,root,root) %ghost %{_libdir}/libcreaterepo_c.so.0
170
171%files devel
172%defattr(644,root,root,755)
173%attr(755,root,root) %{_libdir}/libcreaterepo_c.so
174%{_pkgconfigdir}/createrepo_c.pc
175%{_includedir}/createrepo_c
176
177%files apidocs
178%defattr(644,root,root,755)
179%doc doc/html
180
181%files -n python-createrepo_c
182%defattr(644,root,root,755)
183%dir %{py_sitedir}/createrepo_c
184%attr(755,root,root) %{py_sitedir}/createrepo_c/_createrepo_cmodule.so
185%{py_sitedir}/createrepo_c/__init__.py[co]
186
187%files -n bash-completion-createrepo_c
188%defattr(644,root,root,755)
189/etc/bash_completion.d/createrepo_c.bash
This page took 0.06805 seconds and 4 git commands to generate.