]> git.pld-linux.org Git - packages/clisp.git/blame - clisp.spec
- rel 1
[packages/clisp.git] / clisp.spec
CommitLineData
3cd314f5 1# TODO:
e69735d7 2# - unpackaged files (see the end of spec)
4cbc7eda
MK
3# - there is newer clisp release available at https://gitlab.com/gnu-clisp/clisp.git
4# and in some distros (ie. Fedora/Rawhide)
bfd7e11e 5#
79f0f74b 6# Conditional build:
cdd858ea 7%bcond_with tests # run test suite `make check' (uses network, won't pass on vserver)
bfd7e11e 8#
59f7b327 9Summary: Common Lisp (ANSI CL) implementation
2b164edd
ER
10Summary(pl.UTF-8): Implementacja Common Lisp (ANSI CL)
11Summary(pt_BR.UTF-8): Implementação do Common Lisp (ANSI CL)
59f7b327 12Name: clisp
0313730c 13Version: 2.50
c272397b 14Release: 1
e69735d7 15License: GPL v2
59f7b327 16Group: Development/Languages
0313730c
JR
17Source0: https://gitlab.com/gnu-clisp/clisp/-/archive/clisp-%{version}/clisp-clisp-%{version}.tar.bz2
18# Source0-md5: e1813423a98973c2a43b3690c563c024
59f7b327 19Patch0: %{name}-shell.patch
3a2acc05 20Patch1: x32.patch
59f7b327 21URL: http://clisp.cons.org/
3cd314f5 22BuildRequires: ffcall-devel
770760d8 23BuildRequires: gettext-tools
afc85770 24BuildRequires: libsigsegv >= 2.4
10afc298 25BuildRequires: ncurses-devel
05dfe0ce 26BuildRequires: readline-devel
a84435bf
JB
27BuildRequires: xorg-lib-libX11-devel
28BuildRequires: xorg-lib-libXpm-devel
29BuildRequires: xorg-proto-xextproto-devel
59f7b327 30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
df1563da 32%define specflags_ppc -DNO_GENERATIONAL_GC
33%define specflags_ppc64 -DNO_GENERATIONAL_GC
34
59f7b327 35%description
36Common Lisp is a high-level, all-purpose programming language. CLISP
37is a Common Lisp implementation by Bruno Haible of Karlsruhe
38University and Michael Stoll of Munich University, both in Germany. It
39mostly supports Common Lisp as described in the ANSI CL standard. It
40runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
41500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
42Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
43needs only 2 MB of RAM.
44
45It is free software and may be distributed under the terms of GNU GPL,
46while it is possible to distribute commercial applications compiled
47with CLISP.
48
49The user interface comes in German, English, French and Spanish. CLISP
50includes an interpreter, a compiler, a large subset of CLOS, a foreign
51language interface and a socket interface. An X11 interface is
52available through CLX and Garnet.
53
9a5b73ba
JR
54%description -l pl.UTF-8
55Common Lisp to wysokopoziomowy język programowania ogólnego
56przeznaczenia. CLISP to implementacja Common Lisp, której autorami są
66d98f1f 57Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
9a5b73ba
JR
58University (oba w Niemczech). W większości wspiera Common Lisp opisany
59w standardzie ANSI CL. Działa na mikrokomputerach (DOS, OS/2, Windows
60NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a także stacjach
66d98f1f
JB
61uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
62AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
63
9a5b73ba 64To jest oprogramowanie wolnodostępne, na licencji GNU GPL, możliwe
66d98f1f
JB
65jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
66
9a5b73ba
JR
67Interfejs użytkownika dostępny jest po niemiecku, angielsku, francusku
68i hiszpańsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
69CLOS, interfejs do innych języków oraz interfejs do gniazdek.
70Interfejs X11 jest dostępny poprzez CLX i Garnet.
66d98f1f 71
9a5b73ba
JR
72%description -l pt_BR.UTF-8
73Common Lisp é uma linguagem de programação de propósito geral de alto
74nível. CLISP é uma implementação do Common Lisp feita por Bruno
3b8ff915 75Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
9a5b73ba
JR
76Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
77o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
78software livre, distribuído sob os termos da GNU GPL.
3b8ff915 79
4bbd9b00
JB
80%package -n emacs-clisp-mode
81Summary: CLISP mode for Emacs
82Summary(pl.UTF-8): Tryb edycji CLISP dla Emacsa
83Group: Applications/Editors
84Requires: emacs-common
85
86%description -n emacs-clisp-mode
87CLISP mode for Emacs.
88
89%description -n emacs-clisp-mode -l pl.UTF-8
90Tryb edycji CLISP dla Emacsa.
91
92%package -n vim-syntax-lisp
93Summary: LISP syntax highlighting for Vim
94Summary(pl.UTF-8): Podświetlanie składni LISP-a w Vimie
95Group: Applications/Editors
96Requires: vim-rt
97
98%description -n vim-syntax-lisp
99LISP syntax highlighting for Vim.
100
101%description -n vim-syntax-lisp -l pl.UTF-8
102Podświetlanie składni LISP-a w Vimie.
103
59f7b327 104%prep
0313730c 105%setup -q -n clisp-clisp-%{version}
59f7b327 106%patch0 -p1
3a2acc05 107%patch1 -p1
05dfe0ce
JB
108
109# changing default -O to optflags causes memory fault on amd64
110# - so something is broken... code or compiler
0c5f0ead
JB
111# -fno-strict-aliasing seems to fix crashes on amd64 but doesn't fix
112# random crashes on sparc (which occur with default CFLAGS)
113#%{__perl} -pi -e "s@' -O2?([^0])@' %{rpmcflags} -fno-strict-aliasing\$1@" src/makemake.in
59f7b327 114
115%build
5ce91178 116%ifarch ppc ppc64
117ulimit -s unlimited
118%else
df1563da 119ulimit -s 32768
5ce91178 120%endif
fdf4594b 121
79f0f74b 122CC="%{__cc}" \
72f0b7ac 123%ifarch sparc sparcv9 sparc64
124CFLAGS="%{rpmcflags} -DSAFETY=3" \
125%else
01570cfa
JR
126%ifarch %{ix86} x32
127CFLAGS="%{rpmcflags} -falign-functions=4" \
128%else
df1563da 129CFLAGS="%{rpmcflags}" \
72f0b7ac 130%endif
01570cfa 131%endif
79f0f74b 132./configure \
ffbf3c1c 133%ifarch x32
01570cfa 134 --host=%{_target_platform} \
ffbf3c1c 135%endif
00fbe0f1 136 --prefix=%{_prefix}
f404e321 137
59f7b327 138cd src
139./makemake \
140 --prefix=%{_prefix} \
141 --with-readline \
142 --with-gettext \
143 --with-dynamic-ffi \
e4912e71 144 --fsstnd=redhat \
5d55e2b8 145 --with-module=bindings/glibc \
e4912e71 146 --with-module=clx/new-clx \
59f7b327 147 >Makefile
a6fd4b7b 148%{__make} -j1 config.lisp \
3cd314f5 149 TOPDIR=clisp
a6fd4b7b 150%{__make} -j1 \
3cd314f5
ŁK
151 libdir=%{_libdir} \
152 TOPDIR=clisp
bfd7e11e 153
a6fd4b7b 154%{?with_tests:%{__make} -j1 check}
59f7b327 155
156%install
157rm -rf $RPM_BUILD_ROOT
05dfe0ce 158
a6fd4b7b 159%{__make} -j1 -C src install \
59f7b327 160 DESTDIR=$RPM_BUILD_ROOT \
05dfe0ce 161 libdir=%{_libdir} \
2eb6106d 162 docdir=%{_docdir}/%{name}-%{version} \
3cd314f5
ŁK
163 mandir=%{_mandir} \
164 TOPDIR=clisp
05dfe0ce 165
2eb6106d
JB
166# already packaged as man/html/pdf
167%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/doc/clisp*.{1,ps}
59f7b327 168
2eb6106d 169# clisp and clisplow domains
085d3d70 170%find_lang %{name} --all-name
171
59f7b327 172%clean
173rm -rf $RPM_BUILD_ROOT
174
085d3d70 175%files -f %{name}.lang
59f7b327 176%defattr(644,root,root,755)
177%attr(755,root,root) %{_bindir}/clisp
2eb6106d 178%attr(755,root,root) %{_bindir}/clisp-link
bb3deaa0 179%doc %{_docdir}/%{name}-%{version}
59f7b327 180%dir %{_libdir}/clisp
181%dir %{_libdir}/clisp/base
182%{_libdir}/clisp/base/*.[aho]
183%{_libdir}/clisp/base/lispinit.mem
184%attr(755,root,root) %{_libdir}/clisp/base/lisp.run
185%{_libdir}/clisp/base/makevars
2eb6106d
JB
186%{_libdir}/clisp/bindings
187%{_libdir}/clisp/build-aux
188%{_libdir}/clisp/clx
59f7b327 189%{_libdir}/clisp/data
2eb6106d
JB
190%dir %{_libdir}/clisp/dynmod
191%{_libdir}/clisp/dynmod/*.lisp
192%attr(755,root,root) %{_libdir}/clisp/dynmod/lib-*.so
59f7b327 193%{_libdir}/clisp/linkkit
2eb6106d
JB
194%{_aclocaldir}/clisp.m4
195%{_mandir}/man1/clisp.1*
196%{_mandir}/man1/clisp-link.1*
4bbd9b00
JB
197
198%files -n emacs-clisp-mode
199%defattr(644,root,root,755)
200%{_lispdir}/clhs.el
201%{_lispdir}/clisp-coding.el
202%{_lispdir}/clisp-ffi.el
203%{_lispdir}/clisp-indent.el
204%{_lispdir}/clisp-indent.lisp
205
206%files -n vim-syntax-lisp
207%defattr(644,root,root,755)
208%{_datadir}/vim/vimfiles/after/syntax/lisp.vim
This page took 0.050718 seconds and 4 git commands to generate.