]> git.pld-linux.org Git - packages/clisp.git/blame - clisp.spec
- release 8
[packages/clisp.git] / clisp.spec
CommitLineData
3cd314f5
ŁK
1# TODO:
2# - review alpha patch
e69735d7 3# - unpackaged files (see the end of spec)
bfd7e11e 4#
79f0f74b 5# Conditional build:
cdd858ea 6%bcond_with tests # run test suite `make check' (uses network, won't pass on vserver)
bfd7e11e 7#
59f7b327 8Summary: Common Lisp (ANSI CL) implementation
2b164edd
ER
9Summary(pl.UTF-8): Implementacja Common Lisp (ANSI CL)
10Summary(pt_BR.UTF-8): Implementação do Common Lisp (ANSI CL)
59f7b327 11Name: clisp
258f532d 12Version: 2.49
61462d9b 13Release: 8
e69735d7 14License: GPL v2
59f7b327 15Group: Development/Languages
258f532d
JR
16Source0: http://download.sourceforge.net/clisp/%{name}-%{version}.tar.bz2
17# Source0-md5: 1962b99d5e530390ec3829236d168649
59f7b327 18Patch0: %{name}-shell.patch
5a8ba3e7 19Patch1: %{name}-alpha.patch
b8509756 20Patch2: %{name}-glibc.patch
138982f9
AM
21# https://sourceforge.net/p/clisp/bugs/688/attachment/patch-modules_readline_readline.lisp
22Patch3: %{name}-readline.patch
01570cfa 23Patch4: x32.patch
59f7b327 24URL: http://clisp.cons.org/
3cd314f5 25BuildRequires: ffcall-devel
770760d8 26BuildRequires: gettext-tools
afc85770 27BuildRequires: libsigsegv >= 2.4
10afc298 28BuildRequires: ncurses-devel
05dfe0ce 29BuildRequires: readline-devel
a84435bf
JB
30BuildRequires: xorg-lib-libX11-devel
31BuildRequires: xorg-lib-libXpm-devel
32BuildRequires: xorg-proto-xextproto-devel
59f7b327 33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
df1563da 35%define specflags_ppc -DNO_GENERATIONAL_GC
36%define specflags_ppc64 -DNO_GENERATIONAL_GC
37
59f7b327 38%description
39Common Lisp is a high-level, all-purpose programming language. CLISP
40is a Common Lisp implementation by Bruno Haible of Karlsruhe
41University and Michael Stoll of Munich University, both in Germany. It
42mostly supports Common Lisp as described in the ANSI CL standard. It
43runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
44500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
45Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
46needs only 2 MB of RAM.
47
48It is free software and may be distributed under the terms of GNU GPL,
49while it is possible to distribute commercial applications compiled
50with CLISP.
51
52The user interface comes in German, English, French and Spanish. CLISP
53includes an interpreter, a compiler, a large subset of CLOS, a foreign
54language interface and a socket interface. An X11 interface is
55available through CLX and Garnet.
56
9a5b73ba
JR
57%description -l pl.UTF-8
58Common Lisp to wysokopoziomowy język programowania ogólnego
59przeznaczenia. CLISP to implementacja Common Lisp, której autorami są
66d98f1f 60Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
9a5b73ba
JR
61University (oba w Niemczech). W większości wspiera Common Lisp opisany
62w standardzie ANSI CL. Działa na mikrokomputerach (DOS, OS/2, Windows
63NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a także stacjach
66d98f1f
JB
64uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
65AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
66
9a5b73ba 67To jest oprogramowanie wolnodostępne, na licencji GNU GPL, możliwe
66d98f1f
JB
68jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
69
9a5b73ba
JR
70Interfejs użytkownika dostępny jest po niemiecku, angielsku, francusku
71i hiszpańsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
72CLOS, interfejs do innych języków oraz interfejs do gniazdek.
73Interfejs X11 jest dostępny poprzez CLX i Garnet.
66d98f1f 74
9a5b73ba
JR
75%description -l pt_BR.UTF-8
76Common Lisp é uma linguagem de programação de propósito geral de alto
77nível. CLISP é uma implementação do Common Lisp feita por Bruno
3b8ff915 78Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
9a5b73ba
JR
79Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
80o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
81software livre, distribuído sob os termos da GNU GPL.
3b8ff915 82
59f7b327 83%prep
84%setup -q
85%patch0 -p1
2eb6106d 86%patch1 -p1
3c8d6648 87%patch2 -p1
138982f9 88%patch3 -p0
01570cfa 89%patch4 -p1
05dfe0ce
JB
90
91# changing default -O to optflags causes memory fault on amd64
92# - so something is broken... code or compiler
0c5f0ead
JB
93# -fno-strict-aliasing seems to fix crashes on amd64 but doesn't fix
94# random crashes on sparc (which occur with default CFLAGS)
95#%{__perl} -pi -e "s@' -O2?([^0])@' %{rpmcflags} -fno-strict-aliasing\$1@" src/makemake.in
59f7b327 96
97%build
5ce91178 98%ifarch ppc ppc64
99ulimit -s unlimited
100%else
df1563da 101ulimit -s 32768
5ce91178 102%endif
fdf4594b 103
79f0f74b 104CC="%{__cc}" \
72f0b7ac 105%ifarch sparc sparcv9 sparc64
106CFLAGS="%{rpmcflags} -DSAFETY=3" \
107%else
01570cfa
JR
108%ifarch %{ix86} x32
109CFLAGS="%{rpmcflags} -falign-functions=4" \
110%else
df1563da 111CFLAGS="%{rpmcflags}" \
72f0b7ac 112%endif
01570cfa 113%endif
79f0f74b 114./configure \
ffbf3c1c 115%ifarch x32
01570cfa 116 --host=%{_target_platform} \
ffbf3c1c 117%endif
00fbe0f1 118 --prefix=%{_prefix}
f404e321 119
59f7b327 120cd src
121./makemake \
122 --prefix=%{_prefix} \
123 --with-readline \
124 --with-gettext \
125 --with-dynamic-ffi \
e4912e71 126 --fsstnd=redhat \
59f7b327 127 --with-module=wildcard \
5d55e2b8 128 --with-module=bindings/glibc \
e4912e71 129 --with-module=clx/new-clx \
59f7b327 130 >Makefile
a6fd4b7b 131%{__make} -j1 config.lisp \
3cd314f5 132 TOPDIR=clisp
a6fd4b7b 133%{__make} -j1 \
3cd314f5
ŁK
134 libdir=%{_libdir} \
135 TOPDIR=clisp
bfd7e11e 136
a6fd4b7b 137%{?with_tests:%{__make} -j1 check}
59f7b327 138
139%install
140rm -rf $RPM_BUILD_ROOT
05dfe0ce 141
a6fd4b7b 142%{__make} -j1 -C src install \
59f7b327 143 DESTDIR=$RPM_BUILD_ROOT \
05dfe0ce 144 libdir=%{_libdir} \
2eb6106d 145 docdir=%{_docdir}/%{name}-%{version} \
3cd314f5
ŁK
146 mandir=%{_mandir} \
147 TOPDIR=clisp
05dfe0ce 148
2eb6106d
JB
149# already packaged as man/html/pdf
150%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/doc/clisp*.{1,ps}
59f7b327 151
2eb6106d 152# clisp and clisplow domains
085d3d70 153%find_lang %{name} --all-name
154
59f7b327 155%clean
156rm -rf $RPM_BUILD_ROOT
157
085d3d70 158%files -f %{name}.lang
59f7b327 159%defattr(644,root,root,755)
160%attr(755,root,root) %{_bindir}/clisp
2eb6106d 161%attr(755,root,root) %{_bindir}/clisp-link
bb3deaa0 162%doc %{_docdir}/%{name}-%{version}
59f7b327 163%dir %{_libdir}/clisp
164%dir %{_libdir}/clisp/base
165%{_libdir}/clisp/base/*.[aho]
166%{_libdir}/clisp/base/lispinit.mem
167%attr(755,root,root) %{_libdir}/clisp/base/lisp.run
168%{_libdir}/clisp/base/makevars
2eb6106d
JB
169%{_libdir}/clisp/bindings
170%{_libdir}/clisp/build-aux
171%{_libdir}/clisp/clx
59f7b327 172%{_libdir}/clisp/data
2eb6106d
JB
173%dir %{_libdir}/clisp/dynmod
174%{_libdir}/clisp/dynmod/*.lisp
175%attr(755,root,root) %{_libdir}/clisp/dynmod/lib-*.so
59f7b327 176%{_libdir}/clisp/linkkit
2eb6106d
JB
177%{_libdir}/clisp/wildcard
178%{_aclocaldir}/clisp.m4
179%{_mandir}/man1/clisp.1*
180%{_mandir}/man1/clisp-link.1*
181
182# TODO:
183#%{_datadir}/emacs/site-lisp/clhs.el
184#%{_datadir}/emacs/site-lisp/clisp-coding.el
185#%{_datadir}/emacs/site-lisp/clisp-ffi.el
186#%{_datadir}/emacs/site-lisp/clisp-indent.el
187#%{_datadir}/emacs/site-lisp/clisp-indent.lisp
188#%{_datadir}/vim/vimfiles/after/syntax/lisp.vim
This page took 0.106324 seconds and 4 git commands to generate.