]> git.pld-linux.org Git - packages/clisp.git/blame - clisp.spec
- rel 4; builds with readline 7; likely software depending on clisp will need rebuild
[packages/clisp.git] / clisp.spec
CommitLineData
3cd314f5
ŁK
1# TODO:
2# - review alpha patch
bfd7e11e 3#
79f0f74b 4# Conditional build:
cdd858ea 5%bcond_with tests # run test suite `make check' (uses network, won't pass on vserver)
bfd7e11e 6#
59f7b327 7Summary: Common Lisp (ANSI CL) implementation
2b164edd
ER
8Summary(pl.UTF-8): Implementacja Common Lisp (ANSI CL)
9Summary(pt_BR.UTF-8): Implementação do Common Lisp (ANSI CL)
59f7b327 10Name: clisp
258f532d 11Version: 2.49
138982f9 12Release: 4
59f7b327 13License: GPL
14Group: Development/Languages
258f532d
JR
15Source0: http://download.sourceforge.net/clisp/%{name}-%{version}.tar.bz2
16# Source0-md5: 1962b99d5e530390ec3829236d168649
59f7b327 17Patch0: %{name}-shell.patch
5a8ba3e7 18Patch1: %{name}-alpha.patch
b8509756 19Patch2: %{name}-glibc.patch
138982f9
AM
20# https://sourceforge.net/p/clisp/bugs/688/attachment/patch-modules_readline_readline.lisp
21Patch3: %{name}-readline.patch
59f7b327 22URL: http://clisp.cons.org/
3cd314f5 23BuildRequires: ffcall-devel
770760d8 24BuildRequires: gettext-tools
afc85770 25BuildRequires: libsigsegv >= 2.4
10afc298 26BuildRequires: ncurses-devel
05dfe0ce 27BuildRequires: readline-devel
a84435bf
JB
28BuildRequires: xorg-lib-libX11-devel
29BuildRequires: xorg-lib-libXpm-devel
30BuildRequires: xorg-proto-xextproto-devel
59f7b327 31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
df1563da 33%define specflags_ppc -DNO_GENERATIONAL_GC
34%define specflags_ppc64 -DNO_GENERATIONAL_GC
35
59f7b327 36%description
37Common Lisp is a high-level, all-purpose programming language. CLISP
38is a Common Lisp implementation by Bruno Haible of Karlsruhe
39University and Michael Stoll of Munich University, both in Germany. It
40mostly supports Common Lisp as described in the ANSI CL standard. It
41runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
42500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
43Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
44needs only 2 MB of RAM.
45
46It is free software and may be distributed under the terms of GNU GPL,
47while it is possible to distribute commercial applications compiled
48with CLISP.
49
50The user interface comes in German, English, French and Spanish. CLISP
51includes an interpreter, a compiler, a large subset of CLOS, a foreign
52language interface and a socket interface. An X11 interface is
53available through CLX and Garnet.
54
9a5b73ba
JR
55%description -l pl.UTF-8
56Common Lisp to wysokopoziomowy język programowania ogólnego
57przeznaczenia. CLISP to implementacja Common Lisp, której autorami są
66d98f1f 58Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
9a5b73ba
JR
59University (oba w Niemczech). W większości wspiera Common Lisp opisany
60w standardzie ANSI CL. Działa na mikrokomputerach (DOS, OS/2, Windows
61NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a także stacjach
66d98f1f
JB
62uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
63AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
64
9a5b73ba 65To jest oprogramowanie wolnodostępne, na licencji GNU GPL, możliwe
66d98f1f
JB
66jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
67
9a5b73ba
JR
68Interfejs użytkownika dostępny jest po niemiecku, angielsku, francusku
69i hiszpańsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
70CLOS, interfejs do innych języków oraz interfejs do gniazdek.
71Interfejs X11 jest dostępny poprzez CLX i Garnet.
66d98f1f 72
9a5b73ba
JR
73%description -l pt_BR.UTF-8
74Common Lisp é uma linguagem de programação de propósito geral de alto
75nível. CLISP é uma implementação do Common Lisp feita por Bruno
3b8ff915 76Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
9a5b73ba
JR
77Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
78o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
79software livre, distribuído sob os termos da GNU GPL.
3b8ff915 80
59f7b327 81%prep
82%setup -q
83%patch0 -p1
2eb6106d 84%patch1 -p1
3c8d6648 85%patch2 -p1
138982f9 86%patch3 -p0
05dfe0ce
JB
87
88# changing default -O to optflags causes memory fault on amd64
89# - so something is broken... code or compiler
0c5f0ead
JB
90# -fno-strict-aliasing seems to fix crashes on amd64 but doesn't fix
91# random crashes on sparc (which occur with default CFLAGS)
92#%{__perl} -pi -e "s@' -O2?([^0])@' %{rpmcflags} -fno-strict-aliasing\$1@" src/makemake.in
59f7b327 93
94%build
fdf4594b 95
5ce91178 96%ifarch ppc ppc64
97ulimit -s unlimited
98%else
df1563da 99ulimit -s 32768
5ce91178 100%endif
fdf4594b 101
79f0f74b 102CC="%{__cc}" \
72f0b7ac 103%ifarch sparc sparcv9 sparc64
104CFLAGS="%{rpmcflags} -DSAFETY=3" \
105%else
df1563da 106CFLAGS="%{rpmcflags}" \
72f0b7ac 107%endif
79f0f74b 108./configure \
00fbe0f1 109 --prefix=%{_prefix}
f404e321 110
59f7b327 111cd src
112./makemake \
113 --prefix=%{_prefix} \
114 --with-readline \
115 --with-gettext \
116 --with-dynamic-ffi \
e4912e71 117 --fsstnd=redhat \
59f7b327 118 --with-module=wildcard \
5d55e2b8 119 --with-module=bindings/glibc \
e4912e71 120 --with-module=clx/new-clx \
59f7b327 121 >Makefile
a6fd4b7b 122%{__make} -j1 config.lisp \
3cd314f5 123 TOPDIR=clisp
a6fd4b7b 124%{__make} -j1 \
3cd314f5
ŁK
125 libdir=%{_libdir} \
126 TOPDIR=clisp
bfd7e11e 127
a6fd4b7b 128%{?with_tests:%{__make} -j1 check}
59f7b327 129
130%install
131rm -rf $RPM_BUILD_ROOT
05dfe0ce 132
a6fd4b7b 133%{__make} -j1 -C src install \
59f7b327 134 DESTDIR=$RPM_BUILD_ROOT \
05dfe0ce 135 libdir=%{_libdir} \
2eb6106d 136 docdir=%{_docdir}/%{name}-%{version} \
3cd314f5
ŁK
137 mandir=%{_mandir} \
138 TOPDIR=clisp
05dfe0ce 139
2eb6106d
JB
140# already packaged as man/html/pdf
141%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/doc/clisp*.{1,ps}
59f7b327 142
2eb6106d 143# clisp and clisplow domains
085d3d70 144%find_lang %{name} --all-name
145
59f7b327 146%clean
147rm -rf $RPM_BUILD_ROOT
148
085d3d70 149%files -f %{name}.lang
59f7b327 150%defattr(644,root,root,755)
151%attr(755,root,root) %{_bindir}/clisp
2eb6106d 152%attr(755,root,root) %{_bindir}/clisp-link
bb3deaa0 153%doc %{_docdir}/%{name}-%{version}
59f7b327 154%dir %{_libdir}/clisp
155%dir %{_libdir}/clisp/base
156%{_libdir}/clisp/base/*.[aho]
157%{_libdir}/clisp/base/lispinit.mem
158%attr(755,root,root) %{_libdir}/clisp/base/lisp.run
159%{_libdir}/clisp/base/makevars
2eb6106d
JB
160%{_libdir}/clisp/bindings
161%{_libdir}/clisp/build-aux
162%{_libdir}/clisp/clx
59f7b327 163%{_libdir}/clisp/data
2eb6106d
JB
164%dir %{_libdir}/clisp/dynmod
165%{_libdir}/clisp/dynmod/*.lisp
166%attr(755,root,root) %{_libdir}/clisp/dynmod/lib-*.so
59f7b327 167%{_libdir}/clisp/linkkit
2eb6106d
JB
168%{_libdir}/clisp/wildcard
169%{_aclocaldir}/clisp.m4
170%{_mandir}/man1/clisp.1*
171%{_mandir}/man1/clisp-link.1*
172
173# TODO:
174#%{_datadir}/emacs/site-lisp/clhs.el
175#%{_datadir}/emacs/site-lisp/clisp-coding.el
176#%{_datadir}/emacs/site-lisp/clisp-ffi.el
177#%{_datadir}/emacs/site-lisp/clisp-indent.el
178#%{_datadir}/emacs/site-lisp/clisp-indent.lisp
179#%{_datadir}/vim/vimfiles/after/syntax/lisp.vim
This page took 0.288131 seconds and 4 git commands to generate.