]> git.pld-linux.org Git - packages/clisp.git/blame - clisp.spec
- up to 2.50
[packages/clisp.git] / clisp.spec
CommitLineData
3cd314f5
ŁK
1# TODO:
2# - review alpha patch
e69735d7 3# - unpackaged files (see the end of spec)
4cbc7eda
MK
4# - there is newer clisp release available at https://gitlab.com/gnu-clisp/clisp.git
5# and in some distros (ie. Fedora/Rawhide)
bfd7e11e 6#
79f0f74b 7# Conditional build:
cdd858ea 8%bcond_with tests # run test suite `make check' (uses network, won't pass on vserver)
bfd7e11e 9#
59f7b327 10Summary: Common Lisp (ANSI CL) implementation
2b164edd
ER
11Summary(pl.UTF-8): Implementacja Common Lisp (ANSI CL)
12Summary(pt_BR.UTF-8): Implementação do Common Lisp (ANSI CL)
59f7b327 13Name: clisp
0313730c
JR
14Version: 2.50
15Release: 0.1
e69735d7 16License: GPL v2
59f7b327 17Group: Development/Languages
0313730c
JR
18Source0: https://gitlab.com/gnu-clisp/clisp/-/archive/clisp-%{version}/clisp-clisp-%{version}.tar.bz2
19# Source0-md5: e1813423a98973c2a43b3690c563c024
59f7b327 20Patch0: %{name}-shell.patch
3a2acc05 21Patch1: x32.patch
59f7b327 22URL: http://clisp.cons.org/
3cd314f5 23BuildRequires: ffcall-devel
770760d8 24BuildRequires: gettext-tools
afc85770 25BuildRequires: libsigsegv >= 2.4
10afc298 26BuildRequires: ncurses-devel
05dfe0ce 27BuildRequires: readline-devel
a84435bf
JB
28BuildRequires: xorg-lib-libX11-devel
29BuildRequires: xorg-lib-libXpm-devel
30BuildRequires: xorg-proto-xextproto-devel
59f7b327 31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
df1563da 33%define specflags_ppc -DNO_GENERATIONAL_GC
34%define specflags_ppc64 -DNO_GENERATIONAL_GC
35
59f7b327 36%description
37Common Lisp is a high-level, all-purpose programming language. CLISP
38is a Common Lisp implementation by Bruno Haible of Karlsruhe
39University and Michael Stoll of Munich University, both in Germany. It
40mostly supports Common Lisp as described in the ANSI CL standard. It
41runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
42500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
43Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
44needs only 2 MB of RAM.
45
46It is free software and may be distributed under the terms of GNU GPL,
47while it is possible to distribute commercial applications compiled
48with CLISP.
49
50The user interface comes in German, English, French and Spanish. CLISP
51includes an interpreter, a compiler, a large subset of CLOS, a foreign
52language interface and a socket interface. An X11 interface is
53available through CLX and Garnet.
54
9a5b73ba
JR
55%description -l pl.UTF-8
56Common Lisp to wysokopoziomowy język programowania ogólnego
57przeznaczenia. CLISP to implementacja Common Lisp, której autorami są
66d98f1f 58Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
9a5b73ba
JR
59University (oba w Niemczech). W większości wspiera Common Lisp opisany
60w standardzie ANSI CL. Działa na mikrokomputerach (DOS, OS/2, Windows
61NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a także stacjach
66d98f1f
JB
62uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
63AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
64
9a5b73ba 65To jest oprogramowanie wolnodostępne, na licencji GNU GPL, możliwe
66d98f1f
JB
66jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
67
9a5b73ba
JR
68Interfejs użytkownika dostępny jest po niemiecku, angielsku, francusku
69i hiszpańsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
70CLOS, interfejs do innych języków oraz interfejs do gniazdek.
71Interfejs X11 jest dostępny poprzez CLX i Garnet.
66d98f1f 72
9a5b73ba
JR
73%description -l pt_BR.UTF-8
74Common Lisp é uma linguagem de programação de propósito geral de alto
75nível. CLISP é uma implementação do Common Lisp feita por Bruno
3b8ff915 76Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
9a5b73ba
JR
77Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
78o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
79software livre, distribuído sob os termos da GNU GPL.
3b8ff915 80
59f7b327 81%prep
0313730c 82%setup -q -n clisp-clisp-%{version}
59f7b327 83%patch0 -p1
3a2acc05 84%patch1 -p1
05dfe0ce
JB
85
86# changing default -O to optflags causes memory fault on amd64
87# - so something is broken... code or compiler
0c5f0ead
JB
88# -fno-strict-aliasing seems to fix crashes on amd64 but doesn't fix
89# random crashes on sparc (which occur with default CFLAGS)
90#%{__perl} -pi -e "s@' -O2?([^0])@' %{rpmcflags} -fno-strict-aliasing\$1@" src/makemake.in
59f7b327 91
92%build
5ce91178 93%ifarch ppc ppc64
94ulimit -s unlimited
95%else
df1563da 96ulimit -s 32768
5ce91178 97%endif
fdf4594b 98
79f0f74b 99CC="%{__cc}" \
72f0b7ac 100%ifarch sparc sparcv9 sparc64
101CFLAGS="%{rpmcflags} -DSAFETY=3" \
102%else
01570cfa
JR
103%ifarch %{ix86} x32
104CFLAGS="%{rpmcflags} -falign-functions=4" \
105%else
df1563da 106CFLAGS="%{rpmcflags}" \
72f0b7ac 107%endif
01570cfa 108%endif
79f0f74b 109./configure \
ffbf3c1c 110%ifarch x32
01570cfa 111 --host=%{_target_platform} \
ffbf3c1c 112%endif
00fbe0f1 113 --prefix=%{_prefix}
f404e321 114
59f7b327 115cd src
116./makemake \
117 --prefix=%{_prefix} \
118 --with-readline \
119 --with-gettext \
120 --with-dynamic-ffi \
e4912e71 121 --fsstnd=redhat \
5d55e2b8 122 --with-module=bindings/glibc \
e4912e71 123 --with-module=clx/new-clx \
59f7b327 124 >Makefile
a6fd4b7b 125%{__make} -j1 config.lisp \
3cd314f5 126 TOPDIR=clisp
a6fd4b7b 127%{__make} -j1 \
3cd314f5
ŁK
128 libdir=%{_libdir} \
129 TOPDIR=clisp
bfd7e11e 130
a6fd4b7b 131%{?with_tests:%{__make} -j1 check}
59f7b327 132
133%install
134rm -rf $RPM_BUILD_ROOT
05dfe0ce 135
a6fd4b7b 136%{__make} -j1 -C src install \
59f7b327 137 DESTDIR=$RPM_BUILD_ROOT \
05dfe0ce 138 libdir=%{_libdir} \
2eb6106d 139 docdir=%{_docdir}/%{name}-%{version} \
3cd314f5
ŁK
140 mandir=%{_mandir} \
141 TOPDIR=clisp
05dfe0ce 142
2eb6106d
JB
143# already packaged as man/html/pdf
144%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/doc/clisp*.{1,ps}
59f7b327 145
2eb6106d 146# clisp and clisplow domains
085d3d70 147%find_lang %{name} --all-name
148
59f7b327 149%clean
150rm -rf $RPM_BUILD_ROOT
151
085d3d70 152%files -f %{name}.lang
59f7b327 153%defattr(644,root,root,755)
154%attr(755,root,root) %{_bindir}/clisp
2eb6106d 155%attr(755,root,root) %{_bindir}/clisp-link
bb3deaa0 156%doc %{_docdir}/%{name}-%{version}
59f7b327 157%dir %{_libdir}/clisp
158%dir %{_libdir}/clisp/base
159%{_libdir}/clisp/base/*.[aho]
160%{_libdir}/clisp/base/lispinit.mem
161%attr(755,root,root) %{_libdir}/clisp/base/lisp.run
162%{_libdir}/clisp/base/makevars
2eb6106d
JB
163%{_libdir}/clisp/bindings
164%{_libdir}/clisp/build-aux
165%{_libdir}/clisp/clx
59f7b327 166%{_libdir}/clisp/data
2eb6106d
JB
167%dir %{_libdir}/clisp/dynmod
168%{_libdir}/clisp/dynmod/*.lisp
169%attr(755,root,root) %{_libdir}/clisp/dynmod/lib-*.so
59f7b327 170%{_libdir}/clisp/linkkit
2eb6106d
JB
171%{_aclocaldir}/clisp.m4
172%{_mandir}/man1/clisp.1*
173%{_mandir}/man1/clisp-link.1*
174
175# TODO:
176#%{_datadir}/emacs/site-lisp/clhs.el
177#%{_datadir}/emacs/site-lisp/clisp-coding.el
178#%{_datadir}/emacs/site-lisp/clisp-ffi.el
179#%{_datadir}/emacs/site-lisp/clisp-indent.el
180#%{_datadir}/emacs/site-lisp/clisp-indent.lisp
181#%{_datadir}/vim/vimfiles/after/syntax/lisp.vim
This page took 0.07028 seconds and 4 git commands to generate.