]> git.pld-linux.org Git - packages/chromaprint.git/blame - chromaprint.spec
- new, based on fedora spec
[packages/chromaprint.git] / chromaprint.spec
CommitLineData
042a8798
ER
1Summary: Library implementing the AcoustID fingerprinting
2Name: chromaprint
3Version: 0.5
4Release: 1
5License: LGPL v2+
6Group: Libraries
7URL: http://www.acoustid.org/chromaprint/
8Source0: https://github.com/downloads/lalinsky/chromaprint/%{name}-%{version}.tar.gz
9BuildRequires: cmake
10BuildRequires: fftw3-devel >= 3
11BuildRequires: python
12BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14%description
15Chromaprint library is the core component of the AcoustID project.
16It's a client-side library that implements a custom algorithm for
17extracting fingerprints from raw audio sources.
18
19The library exposes a simple C API and the package also includes
20bindings for the Python language. The documentation for the C API can
21be found in the main header file.
22
23%package -n libchromaprint
24Summary: Library implementing the AcoustID fingerprinting
25Group: Development/Libraries
26
27%description -n libchromaprint
28Chromaprint library is the core component of the AcoustID project.
29It's a client-side library that implements a custom algorithm for
30extracting fingerprints from raw audio sources.
31
32The library exposes a simple C API and the package also includes
33bindings for the Python language. The documentation for the C API can
34be found in the main header file.
35
36%package -n libchromaprint-devel
37Summary: Headers for developing programs that will use %{name}
38Group: Development/Libraries
39Requires: libchromaprint = %{version}-%{release}
40Requires: pkgconfig
41
42%description -n libchromaprint-devel
43This package contains the headers that programmers will need to
44develop applications which will use %{name}.
45
46%package -n python-chromaprint
47Summary: Python module for %{name}
48License: MIT
49Group: Development/Libraries
50Requires: libchromaprint = %{version}-%{release}
51
52%description -n python-chromaprint
53This package contains the python module to use %{name}.
54
55%prep
56%setup -q
57
58%build
59# examples require ffmpeg, so turn off examples
60%cmake \
61 -DBUILD_EXAMPLES=off \
62 -DBUILD_TESTS=off
63
64%{__make}
65
66cd python
67CFLAGS="%{rpmcflags}" \
68%{__python} setup.py build
69
70%install
71rm -rf $RPM_BUILD_ROOT
72%{__make} install \
73 DESTDIR=$RPM_BUILD_ROOT
74
75cd python
76%{__python} setup.py install \
77 --skip-build \
78 --optimize=2 \
79 --root=$RPM_BUILD_ROOT
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post -n libchromaprint -p /sbin/ldconfig
85%postun -n libchromaprint -p /sbin/ldconfig
86
87%files -n libchromaprint
88%defattr(644,root,root,755)
89%doc CHANGES.txt COPYING.txt NEWS.txt README.txt
90%attr(755,root,root) %{_libdir}/libchromaprint.so.*.*.*
91%ghost %{_libdir}/libchromaprint.so.0
92
93%files -n libchromaprint-devel
94%defattr(644,root,root,755)
95%{_includedir}/chromaprint.h
96%{_libdir}/libchromaprint.so
97%{_pkgconfigdir}/libchromaprint.pc
98
99# MIT licensed
100%files -n python-chromaprint
101%defattr(644,root,root,755)
102%doc python/examples python/LICENSE
103%{py_sitescriptdir}/chromaprint
104%{py_sitescriptdir}/*.egg-info
This page took 0.087979 seconds and 4 git commands to generate.