]> git.pld-linux.org Git - packages/chef.git/blame - chef.spec
- updated deps
[packages/chef.git] / chef.spec
CommitLineData
4613dfe7
ER
1# NOTE:
2# - check releases here: https://github.com/opscode/chef/releases
3
8354a17e
ER
4# Conditional build:
5%bcond_with tests # build without tests
6
e307965b
ER
7Summary: A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
8Name: chef
27cfe329
JR
9Version: 14.1.21
10Release: 0.1
e307965b 11License: Apache v2.0
aabebe0b 12Group: Networking/Admin
27cfe329
JR
13Source0: https://github.com/chef/chef/archive/v%{version}/%{name}-%{version}.tar.gz
14# Source0-md5: b67966a9b9e6c0a5947a604239267415
02d95ccd 15Source2: %{name}.tmpfiles
5c13348f
ER
16Source3: https://raw.github.com/stevendanna/knife-hacks/master/shell/knife_completion.sh
17# Source3-md5: a4c1e41370be8088a59ddb3b2e7ea397
7abbc83b 18Patch0: platform-pld.patch
bc8e6547 19Patch1: FHS.patch
0e535bd2 20Patch2: poldek.patch
7fbe09ae 21Patch3: https://github.com/glensc/chef/compare/pld-knife-boostrap.patch
27cfe329 22# Patch3-md5: 9bc4b39952e6bc326b16207cd6a59141
fce4f0b8 23Patch4: optional-plist.patch
c7e18403 24URL: https://www.chef.io/
303651f6 25BuildRequires: rpm-rubyprov
5c13348f 26BuildRequires: rpmbuild(macros) >= 1.673
68cfa14e
ER
27BuildRequires: sed >= 4.0
28%if %{with tests}
29BuildRequires: ruby-rack
30BuildRequires: ruby-rake
5165006a
ER
31BuildRequires: ruby-rspec-core < 2.15
32BuildRequires: ruby-rspec-core >= 2.14.0
33BuildRequires: ruby-rspec-expectations < 2.15
34BuildRequires: ruby-rspec-expectations >= 2.14.0
35BuildRequires: ruby-rspec-mocks < 2.15
36BuildRequires: ruby-rspec-mocks >= 2.14.0
37BuildRequires: ruby-rspec_junit_formatter
68cfa14e 38%endif
97e7edae 39Requires: lsb-release
31feaf16 40Requires: poldek >= 0.30
27cfe329 41Requires: ruby >= 1:2.4.0
d2f68b79
JR
42Requires: ruby-addressable >= 0
43Requires: ruby-diff-lcs >= 1.3
bf7e149a 44Requires: ruby-erubis >= 2.7.0-3
d2f68b79
JR
45Requires: ruby-erubis < 3
46Requires: ruby-ffi < 1.9.23
27cfe329 47Requires: ruby-ffi-yajl >= 2.2
2a1bbc08 48Requires: ruby-highline >= 1.6.9
d2f68b79
JR
49Requires: ruby-highline < 2
50Requires: ruby-iniparse >= 1.4
51Requires: ruby-iniparse < 2
52Requires: ruby-iso8601 >= 0.9.1
53Requires: ruby-iso8601 < 0.10
54Requires: ruby-json >= 2.1.0
55Requires: ruby-mixlib-archive >= 0.4
56Requires: ruby-mixlib-archive < 1
27cfe329 57Requires: ruby-mixlib-authentication >= 2.0
27cfe329 58Requires: ruby-mixlib-cli >= 1.7
e8757686 59Requires: ruby-mixlib-config >= 2.0
d2f68b79 60Requires: ruby-mixlib-config < 3
27cfe329
JR
61Requires: ruby-mixlib-log >= 2.0.3
62Requires: ruby-mixlib-shellout >= 2.0
d2f68b79
JR
63Requires: ruby-net-sftp >= 2.1.2
64Requires: ruby-net-sftp < 3
27cfe329 65Requires: ruby-net-ssh >= 4.2
27cfe329 66Requires: ruby-net-ssh-multi >= 1.2.1
d2f68b79
JR
67Requires: ruby-net-ssh-multi < 2
68Requires: ruby-ohai >= 13.0
69Requires: ruby-proxifier >= 1.0
70Requires: ruby-proxifier < 2
2a1bbc08 71Requires: ruby-rest-client >= 1.0.4
d2f68b79
JR
72Requires: ruby-rspec-core >= 3.5
73Requires: ruby-rspec-core < 4
74Requires: ruby-rspec-expectations >= 3.5
75Requires: ruby-rspec-expectations < 4
76Requires: ruby-rspec_junit_formatter >= 0.2.0
77Requires: ruby-rspec_junit_formatter < 0.3
78Requires: ruby-rspec-mocks >= 3.5
79Requires: ruby-rspec-mocks < 4
bce16be1 80Requires: ruby-rubygems
d2f68b79
JR
81Requires: ruby-serverspec >= 2.7
82Requires: ruby-serverspec < 3
83Requires: ruby-specinfra >= 2.10
84Requires: ruby-specinfra < 3
85Requires: ruby-syslog-logger >= 1.6
86Requires: ruby-syslog-logger < 2
87Requires: ruby-uuidtools >= 2.1.5
88Requires: ruby-uuidtools < 2.2
2a1bbc08 89Requires: ruby-yajl >= 1.1
d2f68b79
JR
90Requires: ruby-yajl < 2
91Suggests: chef-zero >= 13.0
92Suggests: ruby-plist >= 3.2
e307965b
ER
93BuildArch: noarch
94BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
95
820f7abc
ER
96# do not generate python dependency, yum support is optional
97%define _noautoreqfiles %{ruby_vendorlibdir}/chef/provider/package/yum-dump.py
98
e307965b
ER
99%description
100A systems integration framework, built to bring the benefits of
101configuration management to your entire infrastructure.
102
5c13348f
ER
103%package -n bash-completion-knife
104Summary: bash-completion for knife
105Summary(pl.UTF-8): bashowe uzupełnianie nazw dla knifea
106Group: Applications/Shells
107Requires: %{name} >= 0.10
108Requires: bash-completion >= 2.0
109
110%description -n bash-completion-knife
111This package provides bash-completion for knife.
112
113%description -n bash-completion-knife -l pl.UTF-8
114Pakiet ten dostarcza bashowe uzupełnianie nazw dla knifea.
115
be8cf7bb
ER
116%package -n knife
117Summary: knife - Chef Server API client utility
aabebe0b 118Group: Networking/Admin
be8cf7bb
ER
119Requires: %{name} = %{version}-%{release}
120
121%description -n knife
122Knife is a command-line utility used to manage data on a Chef server
123through the HTTP(S) API. Knife is organized into groups of subcommands
124centered around the various object types in Chef. Each category of
125subcommand is documented in its own manual page.
126
e307965b 127%prep
303651f6 128%setup -q
a8f01bdc
JR
129%patch0 -p1
130%patch1 -p1
131%patch2 -p1
132%patch3 -p1
133%patch4 -p1
e307965b 134
68cfa14e
ER
135%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
136
5165006a
ER
137# cleanup backups after patching
138find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
139
27cfe329 140#grep --exclude-dir=spec --exclude-dir=distro -r /var/chef . && exit 1
5165006a 141
8354a17e
ER
142%build
143%if %{with tests}
144rspec spec
145%endif
146
e307965b
ER
147%install
148rm -rf $RPM_BUILD_ROOT
f972dda7
ER
149install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_bindir},%{_mandir}/man1,%{systemdtmpfilesdir}} \
150 $RPM_BUILD_ROOT%{ruby_vendorlibdir}/chef/reporting \
151 $RPM_BUILD_ROOT/var/{run/%{name},cache/%{name},lib/%{name}/{roles,data_bags,environments,backup}}
66164e90 152
68cfa14e 153cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
e307965b 154cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
e307965b 155
02d95ccd 156cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
303651f6 157
5c13348f
ER
158install -d $RPM_BUILD_ROOT%{bash_compdir}
159cp -p %{SOURCE3} $RPM_BUILD_ROOT%{bash_compdir}/knife
160
bce16be1
ER
161%clean
162rm -rf $RPM_BUILD_ROOT
163
e307965b
ER
164%files
165%defattr(644,root,root,755)
2a1bbc08 166%doc README.md CONTRIBUTING.md
303651f6 167%dir %{_sysconfdir}/%{name}
2a1bbc08 168%attr(755,root,root) %{_bindir}/chef-apply
e307965b 169%attr(755,root,root) %{_bindir}/chef-client
27cfe329 170%attr(755,root,root) %{_bindir}/chef-resource-inspector
f0820095 171%attr(755,root,root) %{_bindir}/chef-service-manager
2a1bbc08 172%attr(755,root,root) %{_bindir}/chef-shell
e307965b 173%attr(755,root,root) %{_bindir}/chef-solo
27cfe329 174%attr(755,root,root) %{_bindir}/chef-windows-service
be8cf7bb
ER
175%{ruby_vendorlibdir}/chef.rb
176%{ruby_vendorlibdir}/chef
177%exclude %{ruby_vendorlibdir}/chef/knife
178%exclude %{ruby_vendorlibdir}/chef/application/knife.rb
179%exclude %{ruby_vendorlibdir}/chef/chef_fs/knife.rb
180%exclude %{ruby_vendorlibdir}/chef/knife.rb
181%{systemdtmpfilesdir}/chef.conf
182
183%dir /var/lib/%{name}
184%dir /var/lib/%{name}/roles
185%dir /var/lib/%{name}/data_bags
186%dir /var/lib/%{name}/environments
7e5aff6c 187%dir %attr(750,root,root) /var/lib/%{name}/backup
be8cf7bb
ER
188
189%dir /var/cache/%{name}
190%dir /var/run/%{name}
191
192%files -n knife
193%defattr(644,root,root,755)
194%attr(755,root,root) %{_bindir}/knife
195%{ruby_vendorlibdir}/chef/knife.rb
196%{ruby_vendorlibdir}/chef/knife
197%{ruby_vendorlibdir}/chef/application/knife.rb
198%{ruby_vendorlibdir}/chef/chef_fs/knife.rb
303651f6 199
5c13348f
ER
200%files -n bash-completion-knife
201%defattr(644,root,root,755)
202%{bash_compdir}/knife
This page took 0.14306 seconds and 4 git commands to generate.