]> git.pld-linux.org Git - packages/celestia.git/blame - celestia.spec
- missing BR: gettext-devel
[packages/celestia.git] / celestia.spec
CommitLineData
efaf8d4e 1
2%bcond_without kde # KDE UI as the default one
3%bcond_with gtk # use gtk2 UI instead
4%bcond_with gnome # use libgnome2 UI instead
5%bcond_with glut # use glut UI instead
6
7%if %{with gtk} || %{with gnome} || %{with glut}
8%undefine with_kde
9%endif
10
ff9c6890 11Summary: A real-time visual space simulation
57396fd6 12Summary(pl.UTF-8): Symulacja przestrzeni kosmicznej w czasie rzeczywistym
ff9c6890 13Name: celestia
84e273a4 14Version: 1.5.1
7277547a 15Release: 1
ff9c6890 16License: GPL
0e5662ec 17Group: X11/Applications/Science
f0c406a2 18Source0: http://dl.sourceforge.net/celestia/%{name}-%{version}.tar.gz
84e273a4
KK
19# Source0-md5: df6854a2cf62d2e96612398c13b68fd2
20Patch0: %{name}-as-needed.patch
21Patch1: %{name}-gcc43.patch
22Patch2: %{name}-extras.patch
23Patch3: %{name}-desktop.patch
ff9c6890 24URL: http://www.shatters.net/celestia/
89ee6494 25BuildRequires: OpenGL-devel
7277547a 26%{?with_glut:BuildRequires: OpenGL-glut-devel >= 4.0}
1a2dda0a
JB
27BuildRequires: autoconf
28BuildRequires: automake
efaf8d4e 29%if %{with gtk} || %{with gnome}
30BuildRequires: cairo-devel
933259d8 31BuildRequires: gettext-devel
efaf8d4e 32BuildRequires: gtk+2-devel >= 2.6
33BuildRequires: gtkglext-devel
34%endif
35%{?with_kde:BuildRequires: kdelibs-devel}
36%{?with_gnome:BuildRequires: libgnomeui-devel}
a684a621 37BuildRequires: libjpeg-devel
38BuildRequires: libpng-devel
39BuildRequires: libstdc++-devel
0490466f 40BuildRequires: libtool
d267ffc3 41BuildRequires: lua50-devel
4322beb0 42BuildRequires: pkgconfig
efaf8d4e 43BuildRequires: sed >= 4.0
45cdd808 44Requires: OpenGL
efaf8d4e 45# celestia < 1.4 original packages
46Obsoletes: celestia-extrasolar
47Obsoletes: celestia-generator
48Obsoletes: celestia-stars
49Obsoletes: celestia-task-default
50# texture replacement addons, virtual provides
51Obsoletes: celestia-textures-earth
52Obsoletes: celestia-textures-earth-clouds
53Obsoletes: celestia-textures-earth-night
54Obsoletes: celestia-textures-galileanmoons
55Obsoletes: celestia-textures-mars
56Obsoletes: celestia-textures-mars-bumpmap
57Obsoletes: celestia-textures-mercury
58Obsoletes: celestia-textures-mercury-bumpmap
59Obsoletes: celestia-textures-moon
60Obsoletes: celestia-textures-moon-bumpmap
61# celestia addons
62Obsoletes: celestia-blackhole
63Obsoletes: celestia-galaxies_extended
64Obsoletes: celestia-galaxy_clusters
65Obsoletes: celestia-globular_clusters
66Obsoletes: celestia-im-starwars
67Obsoletes: celestia-pathfinder
68Obsoletes: celestia-voyager
ff9c6890 69BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
a684a621 71%define _noautoreqdep libGL.so.1 libGLU.so.1 libGLcore.so.1
1a2dda0a 72
ff9c6890 73%description
74Celestia is a free real-time space simulation that lets you experience
75our universe in three dimensions. Unlike most planetarium software,
76Celestia doesn't confine you to the surface of the Earth. You can
77travel throughout the solar system, to any of over 100,000 stars, or
78even beyond the galaxy. All travel in Celestia is seamless; the
79exponential zoom feature lets you explore space across a huge range of
80scales, from galaxy clusters down to spacecraft only a few meters
81across. A 'point-and-goto' interface makes it simple to navigate
82through the universe to the object you want to visit.
83
4107a3bb 84%description -l pl.UTF-8
ff9c6890 85Celestia to wolny symulator przestrzeni komicznej w czasie
7277547a
KK
86rzeczywistym, który pozwala doświadczać naszego Wszechświata w
87trzech wymiarach. W odróżnieniu od innych programów planetarnych
88Celestia nie przywiązuje Cię do powierzchni ziemi. Możesz
89podróżować przez Układ Słoneczny do ponad 100,000 gwiazd lub
90nawet poza galaktykę. Wszystkie podróże w Celestii są
91niezauważalne; funkcja wykładniczego przybliżenia pozwala Ci
92odkrywać Kosmos w różnych skalach - od spojrzenia na galaktyki do
93widoku kilkumetrowych statków kosmicznych. Interfejs typu
94'pokaż-i-leć' czyni nawigację przez Wszechświat prostą.
ff9c6890 95
96%prep
f0c406a2 97%setup -q
84e273a4 98%patch0
d267ffc3 99%patch1 -p1
f0c406a2 100%patch2 -p1
101%patch3 -p1
724d8895 102
efaf8d4e 103# ugly hack not to require GConf2-devel if we're not building gnome version
104%{!?with_gnome:sed -i "s#AM_GCONF_SOURCE_2##g" configure.in}
36f18dc6 105
efaf8d4e 106%build
107cp -f /usr/share/automake/config.sub admin
108%{__make} -f admin/Makefile.common
36f18dc6 109
0490466f 110%configure \
efaf8d4e 111 %{?with_kde:--with-kde} \
112 %{?with_gtk:--with-gtk} \
113 %{?with_gnome:--with-gnome} \
114 %{?with_glut:--with-glut} \
0490466f 115 --disable-rpath \
d267ffc3 116 --with-lua \
8cb97c25 117 --with-xinerama \
118 --with-qt-dir=%{_libdir}
36f18dc6 119
efaf8d4e 120%{__make}
ff9c6890 121
122%install
123rm -rf $RPM_BUILD_ROOT
2560aac7 124
125%{__make} install \
36f18dc6 126 DESTDIR=$RPM_BUILD_ROOT \
efaf8d4e 127 kde_htmldir=%{_kdedocdir} \
52c7f06c 128 kde_libs_htmldir=%{_kdedocdir} \
efaf8d4e 129 appsdir=%{_desktopdir}/kde
2560aac7 130
131# desktop/icon
f0c406a2 132install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
efaf8d4e 133%{!?with_kde:install src/celestia/kde/data/celestia.desktop $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop}
134install src/celestia/kde/data/hi48-app-celestia.png $RPM_BUILD_ROOT%{_pixmapsdir}/celestia.png
36f18dc6 135
52c7f06c 136%find_lang %{name} --all-name --with-kde
89ee6494 137
ff9c6890 138%clean
139rm -rf $RPM_BUILD_ROOT
140
efaf8d4e 141%if %{with gnome}
142%post
143%gconf_schema_install celestia.schemas
144
145%preun
146%gconf_schema_uninstall celestia.schemas
147%endif
148
f0c406a2 149%files -f %{name}.lang
ff9c6890 150%defattr(644,root,root,755)
efaf8d4e 151%doc README AUTHORS TODO controls.txt ChangeLog
ff9c6890 152%attr(755,root,root) %{_bindir}/*
f0c406a2 153%{_datadir}/celestia
2560aac7 154%{_pixmapsdir}/*
efaf8d4e 155%if %{with kde}
f0c406a2 156%{_datadir}/apps/celestia
89ee6494 157%{_datadir}/config/*
2560aac7 158%{_datadir}/mimelnk/application/*
159%{_datadir}/services/*
efaf8d4e 160%{_iconsdir}/*/*/apps/%{name}.png
e812d11b 161%{_desktopdir}/kde/*.desktop
efaf8d4e 162%else
e812d11b 163%{_desktopdir}/*.desktop
efaf8d4e 164%endif
165%{?with_gnome:%{_sysconfdir}/gconf/schemas/celestia.schemas}
This page took 0.092393 seconds and 4 git commands to generate.