]> git.pld-linux.org Git - packages/caja-python.git/blame - caja-python.spec
up to 1.26.0
[packages/caja-python.git] / caja-python.spec
CommitLineData
911c11cc
JB
1# NOTE: despite upstream name python-caja, it's not a binding from Python to Caja,
2# but from Caja to Python, allowing to write Caja extensions in Python - thus our Name.
3Summary: Python bindings for libcaja-extension library
4Summary(pl.UTF-8): Wiązania Pythona do biblioteki libcaja-extension
d658ea88 5Name: caja-python
02b9fe0a
JP
6Version: 1.26.0
7Release: 1
911c11cc
JB
8License: GPL v2+
9Group: Libraries/Python
02b9fe0a
JP
10Source0: https://pub.mate-desktop.org/releases/1.26/python-caja-%{version}.tar.xz
11# Source0-md5: 08991236a39d9ad8e4c59e564786b9bd
911c11cc
JB
12URL: http://mate-desktop.org/
13BuildRequires: autoconf >= 2.53
fb4a7cd3 14BuildRequires: automake >= 1:1.10
b06bdf71 15BuildRequires: caja-devel >= 1.17.1
f9c9cb0e 16BuildRequires: gettext-tools >= 0.19.8
911c11cc
JB
17BuildRequires: gtk-doc >= 1.9
18BuildRequires: libtool >= 1:1.4.3
19BuildRequires: libxslt-progs
911c11cc 20BuildRequires: pkgconfig
f9c9cb0e
JP
21BuildRequires: python3-devel >= 1:3.6
22BuildRequires: python3-pygobject3-devel >= 3.0.0
911c11cc
JB
23BuildRequires: rpm-pythonprov
24BuildRequires: rpmbuild(macros) >= 1.219
25BuildRequires: tar >= 1:1.22
26BuildRequires: xz
b06bdf71 27Requires: caja >= 1.17.1
f9c9cb0e 28Requires: python3-libs >= 1:3.6
d658ea88 29Obsoletes: mate-file-manager-python
911c11cc
JB
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33Python bindings for libcaja-extension library, allowing to write Caja
34extensions in Python.
35
36%description -l pl.UTF-8
37Wiązania Pythona do biblioteki libcaja-extension, pozwalające na
38tworzenie rozszerzeń zarządcy plików Caja w Pythonie.
39
40%package devel
41Summary: Development files for Python Caja extensions
42Summary(pl.UTF-8): Pliki programistyczne dla pythonowych rozszerzeń zarządcy plików Caja
43Group: Development/Libraries
44# doesn't require base; the only file is pkg-config specific, so let's require it
45Requires: pkgconfig
d658ea88 46Obsoletes: mate-file-manager-python-devel
911c11cc
JB
47
48%description devel
49Development files for Caja extensions written in Python.
50
51%description devel -l pl.UTF-8
52Pliki programistyczne dla rozszerzeń zarządcy plików Caja pisanych w
53Pythonie.
54
55%package apidocs
56Summary: Python Caja API documentation
57Summary(pl.UTF-8): Dokumentacja API Pythona dla rozszerzeń zarządcy plików Caja
58Group: Documentation
d658ea88 59Obsoletes: mate-file-manager-python-apidocs
d3b5c796 60BuildArch: noarch
911c11cc
JB
61
62%description apidocs
63Python Caja API documentation.
64
65%description apidocs -l pl.UTF-8
66Dokumentacja API Pythona dla rozszerzeń zarządcy plików Caja.
67
68%package examples
69Summary: Example Python extensions for Caja file manager
70Summary(pl.UTF-8): Przykładowe pythonowe rozszerzenia dla zarządcy plików Caja
71Group: Documentation
d658ea88 72Obsoletes: mate-file-manager-python-examples
911c11cc
JB
73
74%description examples
75Example Python extensions for Caja file manager.
76
77%description examples -l pl.UTF-8
78Przykładowe rozszerzenia dla zarządcy plików Caja napisane w Pythonie.
79
80%prep
81%setup -q -n python-caja-%{version}
82
83%build
84%{__libtoolize}
85%{__aclocal} -I m4
86%{__autoconf}
87%{__autoheader}
88%{__automake}
89%configure \
90 --enable-gtk-doc \
52974e09 91 --disable-silent-rules \
911c11cc
JB
92 --with-html-dir=%{_gtkdocdir}
93
fb4a7cd3 94%{__make}
911c11cc
JB
95
96%install
97rm -rf $RPM_BUILD_ROOT
98
99%{__make} install \
100 DESTDIR=$RPM_BUILD_ROOT \
fb4a7cd3 101 HTMLdir=%{_gtkdocdir}/caja-python
911c11cc
JB
102
103%{__rm} $RPM_BUILD_ROOT%{_libdir}/caja/extensions-2.0/*.la
104
105# not installed because of incomplete docs/Makefile
106cp -p docs/html/* $RPM_BUILD_ROOT%{_gtkdocdir}/caja-python
107
108# examples
109install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
8b1b8983
JB
110%{__mv} $RPM_BUILD_ROOT%{_docdir}/python-caja/README $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
111%{__mv} $RPM_BUILD_ROOT%{_docdir}/python-caja/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
911c11cc
JB
112
113# directory for python plugins for caja - see src/caja-python.c or caja-python.pc
114install -d $RPM_BUILD_ROOT%{_datadir}/caja-python/extensions
115
c672e77d 116%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{es_ES,frp,ie,jv,ku_IQ,pms}
8cbf9ea2 117
db2c8960
JB
118%find_lang python-caja
119
911c11cc
JB
120%clean
121rm -rf $RPM_BUILD_ROOT
122
db2c8960 123%files -f python-caja.lang
911c11cc
JB
124%defattr(644,root,root,755)
125%doc AUTHORS ChangeLog NEWS README
126%attr(755,root,root) %{_libdir}/caja/extensions-2.0/libcaja-python.so
db2c8960 127%{_datadir}/caja/extensions/libcaja-python.caja-extension
911c11cc
JB
128%dir %{_datadir}/caja-python
129%dir %{_datadir}/caja-python/extensions
130
131%files devel
132%defattr(644,root,root,755)
133%{_pkgconfigdir}/caja-python.pc
134
135%files apidocs
136%defattr(644,root,root,755)
137%{_gtkdocdir}/caja-python
138
139%files examples
140%defattr(644,root,root,755)
141%{_examplesdir}/%{name}-%{version}
This page took 0.071495 seconds and 4 git commands to generate.