]> git.pld-linux.org Git - projects/template-specs.git/blame - browser-plugin.spec
- cleanup backups
[projects/template-specs.git] / browser-plugin.spec
CommitLineData
01e6d23d
ER
1#
2# NOTE: using symlinks will not have rpm file conflicts verification,
3# but that's okay since most of the plugins are cross browser, so you
4# won't be having any regular files in browser specific plugin dir.
5#
66de52ac
ER
6Summary: NAME Browser plugin
7Summary(pl): NAME Browser plugin
01e6d23d
ER
8Name: template-browser-plugin
9Version: 0.1
10Release: 0.1
11License: GPL
b110b56a 12Group: X11/Applications/Multimedia
444e4d2a 13BuildRequires: rpmbuild(macros) >= 1.236
7e895160 14Requires: browser-plugins(%{_target_base_arch})
01e6d23d
ER
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17# directory where you store the plugin
18%define _plugindir %{_libdir}/browser-plugins
19
5ac49963
ER
20# TODO: galeon and skipstone.
21# use macro, otherwise extra LF inserted along with the ifarch
22%define browsers mozilla, mozilla-firefox, konqueror, opera, seamonkey
23
01e6d23d 24%description
5ac49963 25NAME browser plugin.
01e6d23d 26
5ac49963 27Supported browsers: %{browsers}.
01e6d23d
ER
28
29%prep
30%setup -q -c -T
31
32%install
33rm -rf $RPM_BUILD_ROOT
34install -d $RPM_BUILD_ROOT%{_plugindir}
35
36cat >> $RPM_BUILD_ROOT%{_plugindir}/%{name}.so <<EOF
37# dummy plugin
38EOF
39cat >> $RPM_BUILD_ROOT%{_plugindir}/%{name}.xpi <<EOF
40# Second plugin file.
41EOF
42
43%triggerin -- mozilla-firefox
444e4d2a 44%nsplugin_install -d %{_libdir}/mozilla-firefox/plugins %{name}.so %{name}.xpi
01e6d23d
ER
45
46%triggerun -- mozilla-firefox
444e4d2a 47%nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins %{name}.so %{name}.xpi
01e6d23d
ER
48
49%triggerin -- mozilla
444e4d2a 50%nsplugin_install -d %{_libdir}/mozilla/plugins %{name}.so %{name}.xpi
01e6d23d
ER
51
52%triggerun -- mozilla
444e4d2a 53%nsplugin_uninstall -d %{_libdir}/mozilla/plugins %{name}.so %{name}.xpi
01e6d23d
ER
54
55%triggerin -- opera
444e4d2a 56%nsplugin_install -d %{_libdir}/opera/plugins %{name}.so %{name}.xpi
01e6d23d
ER
57
58%triggerun -- opera
444e4d2a 59%nsplugin_uninstall -d %{_libdir}/opera/plugins %{name}.so %{name}.xpi
01e6d23d
ER
60
61%triggerin -- konqueror
444e4d2a 62%nsplugin_install -d %{_libdir}/kde3/plugins/konqueror %{name}.so %{name}.xpi
01e6d23d
ER
63
64%triggerun -- konqueror
444e4d2a
ER
65%nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror %{name}.so %{name}.xpi
66
f5c90abe
AG
67%triggerin -- seamonkey
68%nsplugin_install -d %{_libdir}/seamonkey/plugins %{name}.so %{name}.xpi
69
70%triggerun -- seamonkey
71%nsplugin_uninstall -d %{_libdir}/seamonkey/plugins %{name}.so %{name}.xpi
72
444e4d2a
ER
73# as rpm removes the old obsoleted package files after the triggers
74# are ran, add another trigger to make the links there.
75%triggerpostun -- mozilla-firefox-plugin-macromedia-flash
76%nsplugin_install -f -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
01e6d23d
ER
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%files
82%defattr(644,root,root,755)
83%attr(755,root,root) %{_plugindir}/*.so
84%{_plugindir}/*.xpi
This page took 0.045929 seconds and 4 git commands to generate.