]> git.pld-linux.org Git - packages/binwalk.git/blame - binwalk.spec
- python 3.6
[packages/binwalk.git] / binwalk.spec
CommitLineData
789bf746
AM
1# TODO:
2# - split library into subpackage?
3#
4%define module binwalk
17e8446a
TP
5Summary: Binary image analyze tool
6Name: binwalk
789bf746 7Version: 2.1.1
1064d396 8Release: 2
17e8446a
TP
9License: MIT
10Group: Applications/Development
789bf746
AM
11Source0: https://github.com/devttys0/binwalk/archive/v%{version}.tar.gz
12# Source0-md5: e5015a8d0eff287eda8c4afeeca89ed6
13URL: https://github.com/devttys0/binwalk
14%if %{with python3}
15BuildRequires: python3-modules
16BuildRequires: python3-setuptools
17%endif
17e8446a
TP
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
789bf746
AM
21Binwalk is a tool for searching a given binary image for embedded
22files and executable code. Specifically, it is designed for
23identifying files and code embedded inside of firmware images. Binwalk
24uses the libmagic library, so it is compatible with magic signatures
25created for the Unix file utility.
17e8446a
TP
26
27Binwalk also includes a custom magic signature file which contains
28improved signatures for files that are commonly found in firmware
29images such as compressed/archived files, firmware headers, Linux
789bf746 30kernels, bootloaders, filesystems, etc.
17e8446a
TP
31
32%prep
33%setup -q
17e8446a
TP
34
35%build
789bf746 36%py3_build %{?with_tests:test}
17e8446a
TP
37
38%install
39rm -rf $RPM_BUILD_ROOT
40
789bf746 41%py3_install
17e8446a
TP
42
43%clean
44rm -rf $RPM_BUILD_ROOT
45
46%files
47%defattr(644,root,root,755)
789bf746
AM
48%doc API.md README.md
49%attr(755,root,root) %{_bindir}/binwalk
50%{py3_sitescriptdir}/%{module}
51%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
52
This page took 0.102133 seconds and 4 git commands to generate.