]> git.pld-linux.org Git - packages/argus-clients.git/blame - argus-clients.spec
- pl fix
[packages/argus-clients.git] / argus-clients.spec
CommitLineData
d31e0d15 1#
2# Conditional build:
3%bcond_without sasl # build with sasl support
4#
5%define _ver_major 3.0
6%define _ver_minor 0
7%define _rc rc.40
8%define _rel 0.1
a3a0742a
JB
9Summary: Real time network flow monitor - client applications
10Summary(pl.UTF-8): Monitor obciążenia sieci czasu rzeczywistego - programy klienckie
d31e0d15 11Name: argus-clients
12Version: %{_ver_major}.%{_ver_minor}
13Release: 0.%{_rc}.%{_rel}
14License: GPL v2
15Group: Applications/Networking
16Source0: ftp://qosient.com/dev/argus-%{_ver_major}/%{name}-%{version}.%{_rc}.tar.gz
17# Source0-md5: 78ad75c148f1ee7b48d0c3029c4be7e4
18Source1: %{name}-excel.rc
19Source2: %{name}-racluster.conf
20Source3: %{name}-radium.conf
21Source4: %{name}-radium.init
22Source5: %{name}-radium.sysconfig
23Source6: %{name}-radium.logrotate
24Source7: %{name}-ranonymize.conf
25Source8: %{name}-ra.print.all.conf
26Source9: %{name}-rarc
eff76aa1 27Patch0: %{name}-ragraph-rabins-paths.patch
d31e0d15 28URL: http://www.qosient.com/argus/
29BuildRequires: bison
30%{?with_sasl:BuildRequires: cyrus-sasl-devel}
31BuildRequires: flex
32BuildRequires: rpmbuild(macros) >= 1.268
33Requires(post,preun): /sbin/chkconfig
85654b18 34Requires: perl-rrdtool
d31e0d15 35Requires: rc-scripts
36Provides: group(argus)
37Provides: user(argus)
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41Argus is a Real Time Flow Monitor designed to track and report on the
42status and performance of all network transactions seen in a data
43network traffic stream. It is similiar to Cisco NetFlow, however more
44powerful and with different data format.
45
46This package provides variuos methods to process and present the data.
47
48%description -l pl.UTF-8
49Argus jest monitorem sieci czasu rzeczywistego zaprojektowanym do
50śledzenia i raportowania stanu sieci oraz wszelkiego typu transakcji
a3a0742a
JB
51sieciowych widzianych w strumieniu danych. Jest bardzo podobny do
52NetFlow z Cisco, jednak bardziej rozbudowany i posiada inny format
53danych.
d31e0d15 54
da88597f 55Ta paczka dostarcza różne metody do przetwarzania i prezentowania
d31e0d15 56danych.
57
58%prep
59%setup -q -n %{name}-%{version}.%{_rc}
eff76aa1 60%patch0
d31e0d15 61
62%build
63%configure \
64 --with%{!?with_sasl:out}-sasl
65%{__make}
66
67%install
68rm -rf $RPM_BUILD_ROOT
69
70install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
71install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig}
72install -d $RPM_BUILD_ROOT%{_var}/log/%{name}
73
74install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/excel.rc
75install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/racluster.conf
76install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/radium.conf
77install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/randomize.conf
78install %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/ra.print.all.conf
79install %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/rarc
80
81install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/radium
82install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/radium
83install %{SOURCE6} $RPM_BUILD_ROOT/etc/logrotate.d/radium
84
85touch $RPM_BUILD_ROOT%{_var}/log/%{name}/radium.log
86
87%{__make} install \
88 DESTDIR=$RPM_BUILD_ROOT
89
90# same file is in argus.spec
91mv $RPM_BUILD_ROOT%{_bindir}/argusbug $RPM_BUILD_ROOT%{_bindir}/argusbug-clients
92
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%pre
97%groupadd -g 214 argus
98%useradd -u 214 -d /usr/share/empty -s /bin/sh -g argus -c "argus daemon" argus
99
100%post
101/sbin/chkconfig --add radium
102%service radium restart
103
104%preun
105if [ "$1" = "0" ]; then
106 %service -q radium stop
107 /sbin/chkconfig --del radium
108fi
109
110%files
111%defattr(644,root,root,755)
112%doc CREDITS ChangeLog README doc/{CHANGES,FAQ,HOW-TO}
113%attr(755,root,root) %{_bindir}/argusbug-clients
114%attr(755,root,root) %{_bindir}/ra
115%attr(755,root,root) %{_bindir}/rabins
116%attr(755,root,root) %{_bindir}/racluster
117%attr(755,root,root) %{_bindir}/racount
118%attr(755,root,root) %{_bindir}/ragraph
119%attr(755,root,root) %{_bindir}/ragrep
120%attr(755,root,root) %{_bindir}/rahisto
121%attr(755,root,root) %{_bindir}/ranonymize
122%attr(755,root,root) %{_bindir}/rapath
123%attr(755,root,root) %{_bindir}/rapolicy
124%attr(755,root,root) %{_bindir}/rasort
125%attr(755,root,root) %{_bindir}/rasplit
126%attr(755,root,root) %{_bindir}/rastrip
127%attr(755,root,root) %{_bindir}/ratemplate
128%attr(755,root,root) %{_bindir}/ratop
129%attr(755,root,root) %{_sbindir}/radium
130%attr(754,root,root) /etc/rc.d/init.d/radium
131%dir %{_sysconfdir}/%{name}
132%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/excel.rc
133%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/racluster.conf
134%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/radium.conf
135%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/randomize.conf
136%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ra.print.all.conf
137%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/rarc
138%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/radium
139%config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/radium
62b74fbe
ER
140%{_mandir}/man1/ra.1*
141%{_mandir}/man1/rabins.1*
142%{_mandir}/man1/racluster.1*
143%{_mandir}/man1/racount.1*
144%{_mandir}/man1/ragraph.1*
145%{_mandir}/man1/ragrep.1*
146%{_mandir}/man1/rahisto.1*
147%{_mandir}/man1/rasort.1*
148%{_mandir}/man1/rasplit.1*
149%{_mandir}/man1/rastrip.1*
150%{_mandir}/man5/racluster.5*
151%{_mandir}/man5/radium.conf.5*
152%{_mandir}/man5/rarc.5*
153%{_mandir}/man8/radium.8*
d31e0d15 154%attr(770,root,argus) %dir %{_var}/log/%{name}
155%attr(660,root,argus) %ghost %{_var}/log/%{name}/radium.log
This page took 0.090792 seconds and 4 git commands to generate.