]> git.pld-linux.org Git - packages/apache-mod_mpm_itk.git/blame - apache-mod_mpm_itk.spec
no utf8 in C description
[packages/apache-mod_mpm_itk.git] / apache-mod_mpm_itk.spec
CommitLineData
c9c87750
AM
1%define mod_name mpm_itk
2%define apxs /usr/sbin/apxs
3%define ver 2.4.7
4%define subver 01
5Summary: mod_mpm_itk - allows you to run each of your vhost under a separate uid and gid
6Name: apache-mod_mpm_itk
7Version: %{ver}.%{subver}
8Release: 1
9License: Apache v2.0
10Group: Networking/Daemons/HTTP
11Source0: http://mpm-itk.sesse.net/mpm-itk-%{ver}-%{subver}.tar.gz
12# Source0-md5: 3d7a14aef93bb5c1eb1c01081585c4bc
13URL: http://mpm-itk.sesse.net/
14BuildRequires: %{apxs}
15BuildRequires: apache-devel >= 2.4.7
16BuildRequires: apr-devel >= 1:1.0
17BuildRequires: apr-util-devel >= 1:1.0
18BuildRequires: libcap-devel
19Requires: apache(modules-api) = %{apache_modules_api}
20Requires: apache-base >= 2.4.7
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
24%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
25
26%description
27apache2-mpm-itk (just mpm-itk for short) is an MPM (Multi-Processing
28Module) for the Apache web server. mpm-itk allows you to run each of
ae0cdc1e 29your vhost under a separate uid and gid - in short, the scripts and
c9c87750
AM
30configuration files for one vhost no longer have to be readable for
31all the other vhosts.
32
33mpm-itk is based on the traditional prefork MPM, which means it's
34non-threaded; in short, this means you can run non-thread-aware code
35(like many PHP extensions) without problems. On the other hand, you
36lose out to any performance benefit you'd get with threads, of course;
37you'd have to decide for yourself if that's worth it or not. You will
38also take an additional performance hit over prefork, since there's an
39extra fork per request.
40
41%prep
42%setup -q -n mpm-itk-%{ver}-%{subver}
43
44%build
45%configure \
46 --with-apxs=%{apxs}
c9c87750
AM
47%{__make}
48
49%install
50rm -rf $RPM_BUILD_ROOT
51install -d $RPM_BUILD_ROOT{%{_sbindir},%{_pkglibdir},%{_sysconfdir}/conf.d}
52
ae0cdc1e
ER
53install -p .libs/mpm_itk.so $RPM_BUILD_ROOT%{_pkglibdir}
54echo "LoadModule mpm_itk_module modules/mod_mpm_itk.so" \
55 > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/10_mod_%{mod_name}.conf
c9c87750
AM
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%post
61%service -q httpd restart
62
63%postun
64if [ "$1" = "0" ]; then
65 %service -q httpd restart
66fi
67
68%files
69%defattr(644,root,root,755)
70%doc CHANGES README
71%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
72%attr(755,root,root) %{_pkglibdir}/mpm_itk.so
This page took 0.065126 seconds and 4 git commands to generate.