]> git.pld-linux.org Git - packages/apache-mod_auth_any.git/blame - apache-mod_auth_any.spec
- new
[packages/apache-mod_auth_any.git] / apache-mod_auth_any.spec
CommitLineData
9ad9f9b8 1%define mod_name auth_any
2Summary: This is the any authentication module for Apache
3Name: apache-mod_%{mod_name}
4Version: 1.2
5Release: 1
6License: GPL
7Group: Networking/Daemons
8Group(de): Netzwerkwesen/Server
9Group(pl): Sieciowe/Serwery
10Source0: ftp://ftp.itlab.musc.edu/pub/toolbox/mod_%{mod_name}/mod_%{mod_name}-%{version}.tar.gz
11URL: http://www.itlab.musc.edu/~nafees/mod_%{mod_name}.html
12Prereq: /usr/sbin/apxs
13Requires: apache(EAPI)
14BuildRequires: /usr/sbin/apxs
15BuildRequires: apache(EAPI)-devel
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%define _pkglibdir %(/usr/sbin/apxs -q LIBEXECDIR)
19
20%description
21This module allows you to use any command line program (such as webNIS) to
22authenticate a user.
23
24%prep
25%setup -q -n mod_%{mod_name}
26
27%build
28/usr/sbin/apxs -c src/mod_%{mod_name}.c -o mod_%{mod_name}.so
29
30%install
31rm -rf $RPM_BUILD_ROOT
32install -d $RPM_BUILD_ROOT%{_pkglibdir}
33
34install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
35gzip -9nf docs/*
36
37%post
38/usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
39if [ -f /var/lock/subsys/httpd ]; then
40 /etc/rc.d/init.d/httpd restart 1>&2
41fi
42
43%preun
44if [ "$1" = "0" ]; then
45 /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
46 if [ -f /var/lock/subsys/httpd ]; then
47 /etc/rc.d/init.d/httpd restart 1>&2
48 fi
49fi
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54%files
55%defattr(644,root,root,755)
56%attr(755,root,root) %{_pkglibdir}/*
57%doc docs/*.gz
This page took 0.066443 seconds and 4 git commands to generate.